PAT 1060. 爱丁顿数
英国天文学家爱丁顿很喜欢骑车。据说他为了炫耀自己的骑车功力,还定义了一个“爱丁顿数”E,即满足有E天骑车超过E英里的最大整数E。据说爱丁顿自己的E等于87。
现给定某人N天的骑车距离,请你算出对应的爱丁顿数E(<=N)。
输入格式:
输入第一行给出一个正整数N(<=105),即连续骑车的天数;第二行给出N个非负整数,代表每天的骑车距离。
输出格式:
在一行中给出N天的爱丁顿数。
输入样例:
10
6 7 6 9 3 10 8 2 7 8
输出样例:
6
代码如下
#include<iostream>
#include<algorithm>
using namespace std;
int main(){
int N;
cin>>N;
int a[N];
for(int i=0;i<N;i++)
cin>>a[i];
sort(a,a+N);
int cnt=0;
for(int i=N-1;i>=0;i--)
if(a[i]<=cnt+1) break;
else cnt++;
cout<<cnt;
return 0;
}
原文地址:https://www.cnblogs.com/A-Little-Nut/p/8137584.html
时间: 2024-10-08 05:07:54