hdoj-1034-Candy Sharing Game

Candy Sharing Game

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 3812 Accepted Submission(s): 2377

Problem Description

A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to
the neighbor on the right. Any student, who ends up with an odd number of pieces of candy, is given another piece by the teacher. The game ends when all students have the same number of pieces of candy.

Write a program which determines the number of times the teacher blows the whistle and the final number of pieces of candy for each student from the amount of candy each child starts with.

Input

The input may describe more than one game. For each game, the input begins with the number N of students, followed by N (even) candy counts for the children counter-clockwise around the circle. The input ends with a student count
of 0. Each input number is on a line by itself.

Output

For each game, output the number of rounds of the game followed by the amount of candy each child ends up with, both on one line.

Sample Input

6
36
2
2
2
2
2
11
22
20
18
16
14
12
10
8
6
4
2
4
2
4
6
8
0

Sample Output

15 14
17 22
4 8

Hint

The game ends in a finite number of steps because:
1. The maximum candy count can never increase.
2. The minimum candy count can never decrease.
3. No one with more than the minimum amount will ever decrease to the minimum.
4. If the maximum and minimum candy count are not the same, at least one student with the minimum amount must have their count increase.

Source

Greater New York 2003

#include<stdio.h>
#include<string.h>
int a[10000];
int n;
bool judge(){
	for(int i=0;i<n-1;++i){
		if(a[i]!=a[i+1]) return false;
	}
	return true;
}
int main(){
	while(~scanf("%d",&n),n){
	    int ncas=0,i,t1,t2;
		for(i=0;i<n;++i) scanf("%d",&a[i]);
		while(!judge()){
			ncas++;
		    t2=a[0];
			for(i=1;i<=n;++i){
				t1=a[i%n];
				a[i%n]=a[i%n]/2+t2/2;
				t2=t1;
			}
			for(i=0;i<n;++i)
			  if(a[i]&1) a[i]++;
		}
		printf("%d %d\n",ncas,a[0]);
	}
	return 0;
}

We have carefully selected several similar problems for you:
1035 1031 1037 1038 1015

版权声明:本文为博主原创文章,未经博主允许不得转载。

时间: 2024-08-01 02:16:39

hdoj-1034-Candy Sharing Game的相关文章

HDU 1034 Candy Sharing Game 模拟题

一个分糖游戏,找了会规律,没找到,只能直接模拟玩了. 果然0ms过了,看来数据不大,只是考编码能力罢了. #include <stdio.h> #include <vector> #include <string.h> #include <algorithm> #include <iostream> #include <string> #include <limits.h> #include <stack> #

hdu 1034 Candy Sharing Game

Candy Sharing Game Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 4942    Accepted Submission(s): 3020 Problem Description A number of students sit in a circle facing their teacher in the cente

ACM-模拟之Candy Sharing Game——hdu1034

Candy Sharing Game Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 2897    Accepted Submission(s): 1811 Problem Description A number of students sit in a circle facing their teacher in the cent

Candy Sharing Game(hdoj1034)

Problem Description A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to

sicily 1052. Candy Sharing Game

Constraints Time Limit: 1 secs, Memory Limit: 32 MB Description A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simu

J - Candy Sharing Game(模拟题)

主要是理解题目意思,然后就按照它说的来模拟就好了. Description A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of h

题目1145:Candy Sharing Game

题目描述: A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to the neighbor

hdoj 4322 Candy 【最大费用最大流】【经典题目】【最大流时 维护费用的最大效益】

Candy Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 1829    Accepted Submission(s): 500 Problem Description There are N candies and M kids, the teacher will give this N candies to the M kids.

HDOJ

第一篇 1001 这个就不用说了吧1002 简单的大数1003 DP经典问题,最大连续子段和1004 简单题1005 找规律(循环点)1006 感觉有点BT的题,我到现在还没过1007 经典问题,最近点对问题,用分治1008 简单题1009 贪心1010 搜索题,剪枝很关键1011 1012 简单题1013 简单题(有个小陷阱)1014 简单题1015 可以看作搜索题吧1016 经典的搜索1017 简单数学题1018 简单数学题1019 简单数学题1020 简单的字符串处理1021 找规律的数学

hdoj分类(转)

注:网上搜的 第一篇 1001 这个就不用说了吧 1002 简单的大数 1003 DP经典问题,最大连续子段和 1004 简单题 1005 找规律(循环点) 1006 感觉有点BT的题,我到现在还没过 1007 经典问题,最近点对问题,用分治 1008 简单题 1009 贪心 1010 搜索题,剪枝很关键 1011 1012 简单题 1013 简单题(有个小陷阱) 1014 简单题 1015 可以看作搜索题吧 1016 经典的搜索 1017 简单数学题 1018 简单数学题 1019 简单数学题