记忆化搜索——POJ 1088

对应POJ题目:点击打开链接

滑雪

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 80180   Accepted: 29857

Description

Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长底滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子

 1  2  3  4 5

16 17 18 19 6

15 24 25 20 7

14 23 22 21 8

13 12 11 10 9

一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-...-3-2-1更长。事实上,这是最长的一条。

Input

输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。

Output

输出最长区域的长度。

Sample Input

5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

Sample Output

25

思路:枚举搜索每个点,直接搜会超时,当找到一个的最大长度,用mark[i][j] 记录下来,下次再遇到这个点,就直接取数!

#include<cstdio>
#include<cstdlib>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define M 100
int G[M][M];
int vis[M][M];
int mark[M][M];
int r, c;

void Dfs(int i, int j, int &step, int &max_step)
{
	if(vis[i][j] || i < 0 || i == r || j < 0 || j == c) return;
	if(mark[i][j]){ /* 如果走到了当前位置,则不需要再往下递归,因为此值已记录过,直接加上就行了 */
		step += mark[i][j];
		if(step > max_step) max_step = step;
		step -= mark[i][j];
		vis[i][j] = 0;
		return;
	}
	vis[i][j] = 1;
	int base = G[i][j];
	step++;
	if(G[i+1][j] < base) Dfs(i + 1, j, step, max_step);
	if(G[i-1][j] < base) Dfs(i - 1, j, step, max_step);
	if(G[i][j+1] < base) Dfs(i, j + 1, step, max_step);
	if(G[i][j-1] < base) Dfs(i, j - 1, step, max_step);
	if(step > max_step) max_step = step;
	step--;
	vis[i][j] = 0;
	return;
}

int main()
{
	//freopen("in.txt","r",stdin);
	while(~scanf("%d%d", &r, &c))
	{
		memset(mark, 0, sizeof(mark));
		int i, j;
		for(i=0; i<r; i++)
			for(j=0; j<c; j++)
				scanf("%d", &G[i][j]);
		int max_step = 0;
		int step = 0;
		for(i=0; i<r; i++){
			for(j=0; j<c; j++){
				memset(vis, 0, sizeof(vis));
				int m = 0;
				Dfs(i, j, step, m);
				mark[i][j] = m; /* 记录从点G[i,j]开始的最长距离 */
				if(m > max_step) max_step = m;
			}
		}
		printf("%d\n", max_step);
	}
	return 0;
}
时间: 2024-10-12 08:06:44

记忆化搜索——POJ 1088的相关文章

POJ 1088 滑雪(记忆化搜索)

滑雪 Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 92384   Accepted: 34948 Description Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激.可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你.Michael想知道载一个区域中最长底滑坡.区域由一个二维数组给出.数组的每个数字代表点的高度.下面是一个例子 1 2 3 4 5 16 17

[ACM] poj 1088 滑雪 (记忆化搜索DFS)

求n*m网格内矩形的数目[ACM] poj 1088 滑雪 (记忆化搜索DFS),布布扣,bubuko.com

poj 1088 滑雪 【记忆化搜索】+【DFS】

策略:如题 题目链接:http://poj.org/problem?id=1088 代码: #include<stdio.h> #include<string.h> int map[105][105], dp[105][105], n, m; const int dir[4][2] = {0, 1, 1, 0, 0, -1, -1, 0}; //四个方向 int limit(int x, int y) //判断是不是越界了 { if(x<1||x>n||y<1||

poj 1088 记忆化搜索

滑雪 Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 90368   Accepted: 34028 Description Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激.可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你.Michael想知道载一个区域中最长底滑坡.区域由一个二维数组给出.数组的每个数字代表点的高度.下面是一个例子 1 2 3 4 5 16 17

POJ 1088 滑雪(记忆化搜索+dfs)

滑雪 Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 83489   Accepted: 31234 Description Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激.可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你.Michael想知道载一个区域中最长底滑坡.区域由一个二维数组给出.数组的每个数字代表点的高度.下面是一个例子 1 2 3 4 5 16 17

poj 1088 动态规划+dfs(记忆化搜索)

滑雪 Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u Description Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激.可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你.Michael想知道载一个 区域中最长底滑坡.区域由一个二维数组给出.数组的每个数字代表点的高度.下面是一个例子 1 2 3 4 5 16 17 18 19 6

POJ 2704 Pascal&#39;s Travels (基础记忆化搜索)

Pascal's Travels Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 5328   Accepted: 2396 Description An n x n game board is populated with integers, one nonnegative integer per square. The goal is to travel along any legitimate path from t

POJ 1351 Number of Locks (记忆化搜索 状态压缩)

Number of Locks Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 1161   Accepted: 571 Description In certain factory a kind of spring locks is manufactured. There are n slots (1 < n < 17, n is a natural number.) for each lock. The height

POJ 3249 Test for Job (记忆化搜索 好题)

Test for Job Time Limit: 5000MS   Memory Limit: 65536K Total Submissions: 9512   Accepted: 2178 Description Mr.Dog was fired by his company. In order to support his family, he must find a new job as soon as possible. Nowadays, It's hard to have a job