Poj 3279 Fliptile 【枚举】

Fliptile

Time Limit: 2000MS Memory Limit: 65536K

Total Submissions: 4161 Accepted: 1585

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word “IMPOSSIBLE”.

Input

Line 1: Two space-separated integers: M and N

Lines 2..M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white

Output

Lines 1..M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4

1 0 0 1

0 1 1 0

0 1 1 0

1 0 0 1

Sample Output

0 0 0 0

1 0 0 1

1 0 0 1

0 0 0 0

Source

USACO 2007 Open Silver

题意:有一个M*N的长方形,每个位置都有一个点(要么是白色或黑色),点击这个点会将它连同周围连着的点都翻转过来,问能不能用最少的点击数,使得这个图全白色。

分析:可以发现只要我们确定了第一行的放置后面的就可以确定了。 一个位置最多可以翻转一次,翻转两次就等于没翻转。所以我们最后只需要统计最后的翻转次数就好了,如果有相同的翻转次数那么就输出字典序最少了那个!因为第一行有N个点,每个点都有两个状态,所以就有1<

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
const int MAX = 25;
using namespace std;

int tile[MAX][MAX], flip[MAX][MAX], ans[MAX][MAX], N, M;
const int dx[] = {0, 0, 0, 1, -1};
const int dy[] = {1, -1, 0, 0, 0};

int get(int x, int y){//是判断有几个需要改变的
    int c = tile[x][y];
    int xx, yy;
    for(int i = 0; i < 5; ++ i){
        xx = x + dx[i]; yy = y + dy[i];
        if(xx >= 0&& xx < M&& yy >= 0&&yy < N)
            c += flip[xx][yy];
    }
    return c&1;
}

int cal(){ //计算某个状态是否可以满足条件,如果是可以返回翻转次数,否则返回-1
    for(int i = 1; i < M; ++i){
        for(int j = 0; j < N; ++ j){
            if(get(i-1, j)) //根据左上角潘多
                flip[i][j] = 1; //如果需要改变的是奇数,那么就需要将这个点需要的次数变为1
        }
    }
    for(int j = 0; j < N; ++j){//判断最后一行
        if(get(M-1, j)) return -1;
    }
    int res = 0;
    for(int i = 0; i < M; ++ i)
        for(int j = 0; j < N; ++ j)
            res += flip[i][j];
    return res;
}

void solve(){
    int upp = (1<<N);//总的状态,然后枚举
    int res = -1;
    for(int i = 0; i < upp; ++i){
        memset(flip, 0, sizeof(flip));//初始化
        for(int j = 0; j < N; ++ j){
            flip[0][j] = (i>>j)&1;//j或N-1-j都行
        }
        int num = cal();
        if(num >= 0&&(res < 0|| res > num)){
            res = num;
            memcpy(ans, flip, sizeof(flip));
        }
    }
    if(res == -1) printf("IMPOSSIBLE\n");
    else{
        for(int i = 0; i < M; ++i){
            printf("%d", ans[i][0]);
            for(int j = 1; j < N; ++ j)
            printf(" %d", ans[i][j]);
            printf("\n");
        }
    }
}

int main(){
    while(scanf("%d%d", &M, &N) == 2){
        for(int i = 0; i < M; ++ i){
            for(int j = 0; j < N; ++ j)
                scanf("%d", &tile[i][j]);
        }
        solve();
    }
    return 0;
}
时间: 2024-10-05 04:40:55

Poj 3279 Fliptile 【枚举】的相关文章

状态压缩+枚举 POJ 3279 Fliptile

题目传送门 1 /* 2 题意:问最少翻转几次使得棋子都变白,输出翻转的位置 3 状态压缩+枚举:和之前UVA_11464差不多,枚举第一行,可以从上一行的状态知道当前是否必须翻转 4 */ 5 #include <cstdio> 6 #include <cstring> 7 #include <algorithm> 8 using namespace std; 9 10 const int MAXN = 20; 11 const int INF = 0x3f3f3f3

POJ 3279(Fliptile)题解

以防万一,题目原文和链接均附在文末.那么先是题目分析: [一句话题意] 给定长宽的黑白棋棋盘摆满棋子,每次操作可以反转一个位置和其上下左右共五个位置的棋子的颜色,求要使用最少翻转次数将所有棋子反转为黑色所需翻转的是哪些棋子(这句话好长...). [题目分析] 盯着奇怪的题目看了半天发现和奶牛没什么卵关系..奶牛智商高了产奶高是什么鬼说法... 这题刚开始被放到搜索的分类下了..然而这和搜索有什么关系..没经验所以想了各种和搜索沾边的方法,结果没想出解法,直到看了网上的题解,压根不是搜索啊有木有.

POJ 3279 Fliptile (二进制枚举+模拟)

Fliptile Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 3992   Accepted: 1518 Description Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which

(简单) POJ 3279 Fliptile,集合枚举。

Description Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is co

poj 3279 Fliptile (简单搜索)

Fliptile Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 16558   Accepted: 6056 Description Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in whic

【POJ 3279 Fliptile】开关问题,模拟

题目链接:http://poj.org/problem?id=3279 题意:给定一个n*m的坐标方格,每个位置为黑色或白色.现有如下翻转规则:每翻转一个位置的颜色,与其四连通的位置都会被翻转,但注意只扩散一圈,不是连锁反应. 求最少翻转几个位置能够使所有n*m个位置都变为白色.若有解,求字典序最小的翻转方案(给出每个位置的翻转次数). 数据范围:n, m 属于 [1, 15] 思路:我们把翻转方案中的翻转称为“主动翻转”,翻转过程中受邻居影响而发生的翻转称为“被动翻转”.观察例子可得出如下几个

POJ 3279 Fliptile(DFS+反转)

题目链接:http://poj.org/problem?id=3279 题目大意:有一个n*m的格子,每个格子都有黑白两面(0表示白色,1表示黑色).我们需要把所有的格子都反转成黑色,每反转一个格子,它上下左右的格子都会跟着反转.请求出用最小步数完成反转时每个格子反转的次数.有多个解时,输出字典序最小的一组. 解题思路:只要枚举第一行的2^m种情况,如果一个位置上一行是1,那这个位置一定要反转,因为只有这一行能改变上一行,所以每一行的状态都是由前一行决定的.只要最后判断最后一行是不是都是0即可,

poj 3279 Fliptile(二进制)

http://poj.org/problem?id=3279 在n*N的矩阵上,0代表白色,1代表黑色,每次选取一个点可以其颜色换过来,即白色变成黑色,黑色变成白色,而且其上下左右的点颜色也要交换,求最少交换多少点能把全部换成颜色0 输出所需要换的点,用1表示,如果有多种方案,输出字典序足最小的方案 但是这题的数据里没有字典序的情况,所以没有比较字典序也可以过,我一开始就不知道这个怎么按字典序排 用二进制枚举第一行所有的情况,第一行的情况确定了,下面的就确定了 1 #include<cstdio

POJ 3279 Fliptile(翻转)

题目链接:http://poj.org/problem?id=3279 题意:n*m棋盘区域,由0和1填充,0白,1,黑,(正反两面颜色各异)通过翻转操作使棋盘全部白色朝上,每次翻转棋子,棋子周围(上下左右)都要被翻转,问是否可能翻转 翻转成功,如果翻转成功,输出最少的翻转次数下每个棋子的翻转次数. 题解:有m列,所以最多有2^m种可能性,枚举第一行.然后从第i行(i从2开始)先开始考虑第i-1行,然后依次往下推,再判断最后一行是不是都翻转成白色. 1 #include <string> 2