刷题总结——书架(bzoj1861)

题解:

Description

小T有一个很大的书柜。这个书柜的构造有些独特,即书柜里的书是从上至下堆放成一列。她用1到n的正整数给每本书都编了号。 小T在看书的时候,每次取出一本书,看完后放回书柜然后再拿下一本。由于这些书太有吸引力了,所以她看完后常常会忘记原来是放在书柜的什么位置。不过小T的记忆力是非常好的,所以每次放书的时候至少能够将那本书放在拿出来时的位置附近,比如说她拿的时候这本书上面有X本书,那么放回去时这本书上面就只可能有X-1、X或X+1本书。 当然也有特殊情况,比如在看书的时候突然电话响了或者有朋友来访。这时候粗心的小T会随手把书放在书柜里所有书的最上面或者最下面,然后转身离开。 久而久之,小T的书柜里的书的顺序就会越来越乱,找到特定的编号的书就变得越来越困难。于是她想请你帮她编写一个图书管理程序,处理她看书时的一些操作,以及回答她的两个提问:(1)编号为X的书在书柜的什么位置;(2)从上到下第i本书的编号是多少。

Input

第一行有两个数n,m,分别表示书的个数以及命令的条数;第二行为n个正整数:第i个数表示初始时从上至下第i个位置放置的书的编号;第三行到m+2行,每行一条命令。命令有5种形式: 1. Top S——表示把编号为S的书房在最上面。 2. Bottom S——表示把编号为S的书房在最下面。 3. Insert S T——T∈{-1,0,1},若编号为S的书上面有X本书,则这条命令表示把这本书放回去后它的上面有X+T本书; 4. Ask S——询问编号为S的书的上面目前有多少本书。 5. Query S——询问从上面数起的第S本书的编号。

Output

对于每一条Ask或Query语句你应该输出一行,一个数,代表询问的答案。

Sample Input

10 10

1 3 2 7 5 8 10 4 9 6

Query 3

Top 5

Ask 6

Bottom 3

Ask 3

Top 6

Insert 4 -1

Query 5

Query 2

Ask 2

Sample Output

2

9

9

7
5 3

HINT

数据范围

100%的数据,n,m < = 80000

题解:

一道卡了我几乎一个上午的splay的模板题····

md表示insert操作脑残了·····又是删点又是加点的···导致直接t····

最后发现直接交换两者的pos和val就可以了···我tm·······

代码:

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<ctime>
#include<cctype>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;
const int N=1e5+5;
int father[N],son[N][2],val[N],size[N],root,tot,pos[N];
int n,m,a,b;
char s[5];
inline int R()
{
  char c;int f=0,i=1;
  for(c=getchar();(c<‘0‘||c>‘9‘)&&(c!=‘-‘);c=getchar());
  if(c==‘-‘)
    i=-1,c=getchar();
  for(;c<=‘9‘&&c>=‘0‘;c=getchar())
    f=(f<<3)+(f<<1)+c-‘0‘;
  return f*i;
}
 inline void clear(int now)
{
  father[now]=son[now][0]=son[now][1]=size[now]=0;
}
inline void update(int now)
{
  if(now)
  {
    size[now]=1;
    if(son[now][0])  size[now]+=size[son[now][0]];
    if(son[now][1])  size[now]+=size[son[now][1]];
  }
}
inline int get(int now)
{
  return son[father[now]][1]==now;
}
inline void rotate(int now)
{
  int fa=father[now],ofa=father[fa],which=get(now);
  son[fa][which]=son[now][which^1],father[son[fa][which]]=fa;
  son[now][which^1]=fa,father[fa]=now,father[now]=ofa;
  if(ofa)  son[ofa][son[ofa][1]==fa]=now;
  update(fa),update(now);
}
inline void splay(int now,int to)
{
  while(father[now]!=to)
  {
    if(father[father[now]]!=to)  rotate(get(now)==get(father[now])?father[now]:now);
    rotate(now);
  }
  if(!to) root=now;
}
inline void build(int x)
{
  int now=root,last=0;
  while(true)
  {
    if(!now)
    {
      now=++tot;father[now]=last;size[now]=1;val[now]=x;pos[x]=now;
      if(last)  son[last][1]=now;update(last);
      splay(now,0);
      break;
    }
    last=now;
    now=son[now][1];
  }
}
inline int find(int x)  //找到第x本的编号
{
  int now=root;
  while(true)
  {
    if(x<=size[son[now][0]])  now=son[now][0];
    else
    {
      int temp=size[son[now][0]]+1;
      if(x==temp)  {return val[now];}
      x-=temp;now=son[now][1];
    }
  }
}
inline int pre()
{
  int now=son[root][0];
  while(son[now][1])  now=son[now][1];
  return now;
}
inline int next()
{
  int now=son[root][1];
  while(son[now][0])  now=son[now][0];
  return now;
}

inline void Delete(int x)  //找到编号为x的书将其删除
{
  splay(pos[x],0);
  if(!son[root][0]){int oldroot=root;root=son[root][1];father[root]=0;clear(oldroot);return;}
  if(!son[root][1]){int oldroot=root;root=son[root][0];father[root]=0;clear(oldroot);return;}
  else
  {
    int leftbig=pre(),oldroot=root;
    splay(leftbig,0);
    son[root][1]=son[oldroot][1];
    father[son[root][1]]=root;
    update(root);clear(oldroot);
    return;
  }
}
inline void findtop()//找到最上面的书并将其旋转至根节点
{
  int now=root;
  while(son[now][0])  now=son[now][0];
  splay(now,0);
}
inline void findbot()
{
  int now=root;
  while(son[now][1])  now=son[now][1];
  splay(now,0);
}
inline void inserttop(int x)  //把x放在书的最上面
{
  Delete(x);findtop();
  son[root][0]=pos[x];
  father[pos[x]]=root;size[pos[x]]=1;son[pos[x]][0]=son[pos[x]][1]=0;
  update(root);
}
inline void insertbot(int x)  //把x放在书的最下面
{
  Delete(x);findbot();
  son[root][1]=pos[x];
  father[pos[x]]=root;size[pos[x]]=1;son[pos[x]][0]=son[pos[x]][1]=0;
  update(root);
}
int main()
{
  //freopen("a.in","r",stdin);
  n=R(),m=R();
  for(int i=1;i<=n;i++)
    a=R(),build(a);
  while(m--)
  {
    scanf("%s",s);
    if(s[0]==‘T‘)  {a=R();inserttop(a);}
    if(s[0]==‘B‘)  {a=R();insertbot(a);}
    if(s[0]==‘I‘)
    {
      a=R(),b=R();
      if(!b)  continue;
      else
      {
        splay(pos[a],0);int temp,flag=0;
        if(b==0)  continue;
        if(b==-1)  temp=pre();
        if(b==1)  temp=next();
        int t1=val[temp],t2=pos[a];
        swap(pos[t1],pos[a]);
        swap(val[t2],val[temp]);
      }
    }
    if(s[0]==‘A‘)
    {
      a=R();splay(pos[a],0);
      if(!son[root][0])
        cout<<"0"<<endl;
      else
        cout<<size[son[root][0]]<<endl;
    }
    if(s[0]==‘Q‘)
      a=R(),cout<<find(a)<<endl;
  }
  return 0;
}
时间: 2024-10-13 11:38:30

刷题总结——书架(bzoj1861)的相关文章

用js刷题的一些坑

leecode可以用js刷题了,我大js越来越被认可了是吧.但是刷题中会因为忽略js的一些特性掉入坑里.我这里总结一下我掉过的坑. 坑1:js中数组对象是引用对象 js中除了object还有数组对象也是引用对象,这点常常被忽视,所以在递归的时候传递数组要用arr.slice(0)这样复制一个一样的新数组,不然会出现你传入的数组会被同级的递归改变,结果就不对了. 所以只要数组复制的地方最好都要这么写,除非你真的想引用.而且注意是slice不是splice这两个方法差别很大,你如果用splice(0

LeetCode刷题之一:寻找只出现一次的数字

投简历的时候看到了个刷题网站,http://www.nowcoder.com/527604,就做了一套题,现记录下来. 题目为: Given an array of integers, every element appears twice except for one. Find that single one. Note: Your algorithm should have a linear runtime complexity. Could you implement it withou

【leetcode刷题笔记】Sum Root to Leaf Numbers

Given a binary tree containing digits from 0-9 only, each root-to-leaf path could represent a number. An example is the root-to-leaf path 1->2->3 which represents the number 123. Find the total sum of all root-to-leaf numbers. For example, 1 / 2 3 T

BZOJ第一页刷题计划

BZOJ第一页刷题计划 已完成:1 / 100 BZOJ1000:A+B

刷题记录

刷题啦,刷题啦,咱也刷算法题. 先从牛客网的JS方面刷起,接着刷数据结构和算法,然后去刷leetcode,这儿记载自己从出错的地方. 1.题目描述 移除数组 arr 中的所有值与 item 相等的元素,直接在给定的 arr 数组上进行操作,并将结果返回 . 没有认真思考,写下了如下的答案 function removeWithoutCopy(arr, item) { for(i = 0; i < arr.length; i++) { if( arr[i] === item) { arr.spli

停课刷题总结-给自己一点鼓励吧

嗯,我已经停了四五天课在家刷BZOJ准备复赛了,感觉压力好大.但是,实际上感觉效率并不高,每天就是7-8题的样子,而且并不是每题都有质量.而且这几天刷下来,我貌似因为刷了太多水题的关系,打字写题的速度变慢了,有一点悠闲没有紧迫感了,要赶快把这个习惯给改掉!今天去学校做题被虐了,竟然一个简单的Hash没有调对[虽然我现在还是不知道为什么会死循环QAQ.]感觉吧,可能因为刷题有点不在状态了.[其实也因为刷题的间隙玩了几盘LOL,游戏这东西QAQ]被虐了,感觉很不爽,有点难受,毕竟我付出了那么多努力,

leetcode 刷题之路 63 Binary Tree Zigzag Level Order Traversal

Given a binary tree, return the zigzag level order traversal of its nodes' values. (ie, from left to right, then right to left for the next level and alternate between). For example: Given binary tree {3,9,20,#,#,15,7}, 3 / 9 20 / 15 7 return its zig

leetcode 刷题之路 64 Construct Binary Tree from Inorder and Postorder Traversal

Given inorder and postorder traversal of a tree, construct the binary tree. Note: You may assume that duplicates do not exist in the tree. 给出二叉树的中序遍历和后序遍历结果,恢复出二叉树. 后序遍历序列的最后一个元素值是二叉树的根节点的值,查找该元素在中序遍历序列中的位置mid,根据中序遍历和后序遍历性质,有: 位置mid以前的序列部分为二叉树根节点左子树中

半个暑假的刷题有感

这半个多月一来,主要是在刷DP.开始是一些简单的DP(可是我没有感觉有多简单=_=!!),然后是最大连续子序列,最大公共子序列,最大子矩阵等等,这些题目还好,有的题目甚至可以模板化. 还有一些没有解决的难题: 1024 Max Sum Plus Plus 最大m段不重叠子段和](可不连续)1244 Max Sum Plus Plus Plus [最大m段不重叠子段和](连续) 1074 Doing Homework [压缩dp](这个题整个程序都在用位运算,让我这个小白情何以堪啊) 还有记忆化搜