POJ 2524 :Ubiquitous Religions

Ubiquitous Religions

Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 23171 Accepted: 11406

Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe
in.

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask
m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound
of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe
in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample Input

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output

Case 1: 1
Case 2: 7

额。。难道题单错了?。。。我一看就是并查集。。所以就这么水过了。。

并查集一A水过

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
#include<sstream>
#include<cmath>

using namespace std;

#define M 100500
int p[M];
int n, m;

void start()
{
    for(int i=1; i<=n; i++)
        p[i] = i;
}

int find(int x)
{
    return p[x] == x ? x : p[x] = find( p[x] );
}

void Kruskal(int x, int y)
{
    int xx = find(x);
    int yy = find(y);
    if(xx!=yy)
        p[yy] = xx;
}

int main()
{
    int cas = 0;
    while(scanf("%d%d", &n, &m) &&n &&m)
    {
        cas++;
        start();
        int ans = 0;
        for(int i=1; i<=m; i++)
        {
            int x; int y;
            scanf("%d%d", &x, &y);
            Kruskal(x, y);
        }
        for(int i=1; i<=n; i++)
        {
            if( p[i]==i )
                ans++;
        }
        printf("Case %d: %d\n", cas, ans);
    }

    return 0;
}

POJ 2524 :Ubiquitous Religions

时间: 2024-10-12 13:31:53

POJ 2524 :Ubiquitous Religions的相关文章

POJ 2524 (Ubiquitous Religions)

Ubiquitous Religions Time Limit: 5000MS   Memory Limit: 65536K Total Submissions: 20668   Accepted: 10153 Description There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in findi

【原创】poj ----- 2524 Ubiquitous Religions 解题报告

题目地址: http://poj.org/problem?id=2524 题目内容: Ubiquitous Religions Time Limit: 5000MS   Memory Limit: 65536K Total Submissions: 26119   Accepted: 12859 Description There are so many different religions in the world today that it is difficult to keep tra

POJ 2524 Ubiquitous Religions(宗教种类:并差集)

链接:http://poj.org/problem?id=2524 Ubiquitous Religions Time Limit: 5000MS Memory Limit: 65536K Total Submissions: 27774 Accepted: 13610 Description There are so many different religions in the world today that it is difficult to keep track of them al

POJ 2524 Ubiquitous Religions

F - Ubiquitous Religions Time Limit:5000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u Submit Status Practice POJ 2524 Description 当今世界有很多不同的宗教,很难通晓他们.你有兴趣找出在你的大学里有多少种不同的宗教信仰. 你知道在你的大学里有n个学生(0 < n <= 50000) .你无法询问每个学生的宗教信仰.此外,许多学生

poj 2524:Ubiquitous Religions(并查集,入门题)

Ubiquitous Religions Time Limit: 5000MS   Memory Limit: 65536K Total Submissions: 23997   Accepted: 11807 Description There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in findi

POJ 2524 Ubiquitous Religions Union Find 并查集

本题是标准的并查集了,最后利用这些集求有多少独立集. 所以这里也写个标准程序过了. 最后查找独立集合: 看有多少个节点的父母节点是自己的,那么就是独立集合了.自己做自己的父母当然最独立的了,没有任何依赖,呵呵. #include <stdio.h> const int MAX_N = 50001; //const int MAX_M = MAX_N/2 * (MAX_N-1) + 1; int N, M; struct SubSet { int p, r; }; SubSet sub[MAX_

POJ 2524 Ubiquitous Religions (幷查集)

Ubiquitous Religions Time Limit: 5000MS   Memory Limit: 65536K Total Submissions: 23090   Accepted: 11378 Description There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in findi

POJ 2524 Ubiquitous Religions (简单并查集,三种方式)

Ubiquitous Religions Time Limit: 5000MS   Memory Limit: 65536K Total Submissions: 30791   Accepted: 14928 Description There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in findi

poj 2524 Ubiquitous Religions(并查集)

Ubiquitous Religions Time Limit: 5000MS   Memory Limit: 65536K Total Submissions: 23168   Accepted: 11404 Description There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in findi