HDU3746-Cyclic Nacklace(KMP)

Cyclic Nacklace

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2514    Accepted Submission(s): 1136

Problem Description

CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial
spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl‘s fond of the colorful
decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with
colorful pearls to show girls‘ lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost
pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet‘s cycle is 9 and its cyclic count is 2:

Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that
is to say, adding to the middle is forbidden.

CC is satisfied with his ideas and ask you for help.

Input

The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.

Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by ‘a‘ ~‘z‘ characters. The length of the string Len: ( 3 <= Len <= 100000
).

Output

For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.

Sample Input

3
aaa
abca
abcde

Sample Output

0
2
5

KMP的简单应用:提供几组样例:

abbabbabbab

abcabcabc

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <string>
#include <algorithm>
#include <queue>
using namespace std;
const int maxn = 100000+10;
int next[maxn],n,ans;
char str[maxn];
void getNext(){
    next[0] = 0,next[1] = 0;
    for(int i = 1; i < n; i++){
        int j = next[i];
        while(j && str[i] != str[j]) j = next[j];
        if(str[i]==str[j]) next[i+1] = j+1;
        else next[i+1] = 0;
    }
}
int main(){

    int ncase;
    cin >>  ncase;
    while(ncase--){
        scanf("%s",str);
        n = strlen(str);
        getNext();
        if(n%(n-next[n])==0&&next[n]!=0){
            ans = 0;
        }else{
            if(next[n]==0) ans = n;
            else{
                int t = n-next[n];
                ans = t - next[n]%t;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

HDU3746-Cyclic Nacklace(KMP)

时间: 2024-08-07 10:17:32

HDU3746-Cyclic Nacklace(KMP)的相关文章

HDU3746 Cyclic Nacklace KMP求循环节

HDU3746给定一个字符串,求:在该字符串末尾最少补充多少个字符,可以使得这个字符串获得周期性. 周期性指存在一个子串,使得该字符串可以正好分解成若干个这个子串(数量要大于1). Input 第一行是一个整数 T ( 0<T<=100 ) 代表测试数据的组数. 之后T行每行一个字符串,由小写字母组成,字符串的长度3<=L<=100000. Output 每组数据输出一行结果. Sample Input 3 AAA ABCA ABCDE Sample Output 0 2 5 本题

HDU3746 Cyclic Nacklace 【KMP】

Cyclic Nacklace Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 2538    Accepted Submission(s): 1154 Problem Description CC always becomes very depressed at the end of this month, he has checke

hdu 3746 Cyclic Nacklace (KMP求最小循环节)

//len-next[len]为最小循环节的长度 # include <stdio.h> # include <algorithm> # include <string.h> using namespace std; int len; char a[100010]; int next[100010]; void Getnext() { int i=0,j=-1; next[0]=-1; while(i<=len) { if(j==-1||a[i]==a[j]) i

hdu-3746 Cyclic Nacklace 【kmp】

Cyclic Nacklace Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 3253    Accepted Submission(s): 1488 Problem Description CC always becomes very depressed at the end of this month, he has checke

HDU 3746 Cyclic Nacklace (KMP 循环节)

分析:对next数组的深入理解,最重要的还是对最小循环节的处理. #include <stdio.h> #include <string.h> int next[100005]; char str2[100005]; void build_next(int len2) { int i=0,j=-1; next[0] = -1; while (i < len2) { if (j==-1 || str2[i] == str2[j]) { i++; j++; // if (str2

hdu 3746 Cyclic Nacklace KMP循环节问题

Cyclic Nacklace Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 4124    Accepted Submission(s): 1866 Problem Description CC always becomes very depressed at the end of this month, he has checke

hdu3746 Cyclic Nacklace(kmp周期问题)

题目链接:点击打开链接 题意描述:给定一个字符串,求使这个字符串是循环字符串至少需要添加多少个字符?要求循环至少两次 解题思路:kmp(next[]数组性质:点击打开链接) 根据next[]数组的性质我们可以得到一个字符串最小循环节为n-next[n],所以我们可以得出结论 if((n%(n-next[n])==0)&&(n/(n-next[n])>1)) printf("0\n"); else printf("%d\n",n-next[n]-

hdu 3746 Cyclic Nacklace KMP

题目地址:http://acm.hdu.edu.cn/showproblem.php?pid=3746 题目: Problem Description CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed

HDU 3746 Cyclic Nacklace (KMP找循环节)

Problem Description CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Bein

HDU3746 Cyclic Nacklace

题目链接:https://vjudge.net/problem/HDU-3746 知识点: KMP 解题思路: 论如何用 \(Next[]\) 数组求循环节. AC代码: 1 #include <bits/stdc++.h> 2 3 using namespace std; 4 const int maxn = 100000+5; 5 char inp[maxn]; 6 int Next[maxn]; 7 void init(int plen){ 8 memset(Next,0,sizeof(