ZOJ 3818 Pretty Poem (暴力模拟 string(substr))

Pretty Poem


Time Limit: 2 Seconds     
Memory Limit: 65536 KB



Poetry is a form of literature that uses aesthetic and rhythmic qualities of language. There are many famous poets in the contemporary era. It is said that a few ACM-ICPC contestants can even write poetic code. Some poems has
a strict rhyme scheme like "ABABA" or "ABABCAB". For example, "niconiconi" is composed of a rhyme scheme "ABABA" with A = "ni" and B = "co".

More technically, we call a poem pretty if it can be decomposed into one of the following rhyme scheme: "ABABA" or "ABABCAB". The symbol
A, B and C are different continuous non-empty substrings of the poem. By the way, punctuation characters should be ignored when considering the rhyme scheme.

You are given a line of poem, please determine whether it is pretty or not.

Input

There are multiple test cases. The first line of input contains an integer
T indicating the number of test cases. For each test case:

There is a line of poem S (1 <= length(S) <= 50).
S will only contains alphabet characters or punctuation characters.

Output

For each test case, output "Yes" if the poem is pretty, or "No" if not.

Sample Input

3
niconiconi~
pettan,pettan,tsurupettan
wafuwafu

Sample Output

Yes
Yes
No

Author: JIANG, Kai

Source: The 2014 ACM-ICPC Asia Mudanjiang Regional First Round

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=5350

题目大意:问除去非字母字符后剩下的字符串是不是满足ABABA或者ABABCAB的结构,其中ABC分别是不同的子串

题目分析:先得到目标字符串,然后分别枚举子串A和B,这里用到stl string里的substr函数( sub = s.substr(startpos, len) ),枚举时枚举到len / 2即可,因为AB显然可能超多len/2,剩下的就是纯粹模拟,关键是substr大法好~

#include <cstdio>
#include <cstring>
#include <string>
using namespace std;
char get[55];

int main()
{
    int T;
    scanf("%d", &T);
    while(T--)
    {
        scanf("%s", get);
        string s;
        bool flag = false;
        int len = strlen(get);
        for(int i = 0; i < len; i++)
            if((get[i] >= 'A' && get[i] <= 'Z') || (get[i] >= 'a' && get[i] <= 'z'))
                s += get[i];
        len = s.length();
        for(int i = 1; i < len / 2; i++)
        {
            for(int j = 1; j < len / 2; j++)
            {
                string A = s.substr(0, i);
                string B = s.substr(i, j);
                if(A == B)
                    continue;
                if(A + B + A + B + A == s)
                {
                    flag = true;
                    break;
                }
                if((i + j) * 3 < len)
                {
                    string AB = A + B;
                    string C = s.substr((i + j) * 2, len - (i + j) * 3);
                    if(A == C || B == C)
                        continue;
                    if(AB + AB + C + AB == s)
                    {
                        flag = true;
                        break;
                    }
                }
            }
            if(flag)
                break;
        }
        printf("%s\n", flag ? "Yes" : "No");
    }
}

时间: 2024-08-04 17:39:35

ZOJ 3818 Pretty Poem (暴力模拟 string(substr))的相关文章

zoj 3818 Pretty Poem (模拟)

ZOJ Problem Set - 3818 Pretty Poem Time Limit: 2 Seconds      Memory Limit: 65536 KB Poetry is a form of literature that uses aesthetic and rhythmic qualities of language. There are many famous poets in the contemporary era. It is said that a few ACM

ZOJ 3818 Pretty Poem

暴力模拟 细节处理很重要... 1 #include <iostream> 2 #include <cstring> 3 #include <cstdio> 4 using namespace std; 5 6 char s1[100],s[100]; 7 int len1,len; 8 int t; 9 char a[55],b[55],c[55]; 10 11 int solved1 (int l,int len){ 12 int temp=0,j; 13 for

zoj 3818 Pretty Poem(暴力处理字符串)2014年牡丹江赛区网络赛

Pretty Poem Time Limit: 2 Seconds      Memory Limit: 65536 KB Poetry is a form of literature that uses aesthetic and rhythmic qualities of language. There are many famous poets in the contemporary era. It is said that a few ACM-ICPC contestants can e

zoj 3818 Pretty Poem(模拟)

# include <stdio.h> # include <algorithm> # include <string.h> # define MAX 55 using namespace std; int L; char a[MAX]; int vis[MAX]; int judge1()//ababa { int i,j; int xx,yy,zz; char x[MAX],y[MAX],z[MAX]; for(i=2; i*2<L; i++) { for(j

ZOJ 3818 Pretty Poem 模拟题

题目链接:点击打开链接 #include <cstdio> #include <iostream> #include <cstring> #include <algorithm> using namespace std; const int N = 55; char a[N], b[N]; int main() { int T; scanf("%d", &T); while(T-- > 0) { scanf("%s

ZOJ 3813 Pretty Poem (暴力)

Pretty Poem Time Limit: 2 Seconds      Memory Limit: 65536 KB Poetry is a form of literature that uses aesthetic and rhythmic qualities of language. There are many famous poets in the contemporary era. It is said that a few ACM-ICPC contestants can e

【瞎搞】ZOJ 3818 Pretty Poem 牡丹江网络赛J题

第一种情况:ABABA. 先判断开头的A与结尾的A,得到A的长度,接着判断ABAB 中的AB与AB是否相同(ABAB的长度一定为偶数) 已经知道了A长度,AB的长度 接着判断下A 与B是否相同 第二种情况:ABABCAB-可先讲AB看成整体即DDCD 若存在一个D满足条件 可得到C的长度和位置再判断A-B是否相同A-C是否相同 B-C是否相同(暴力取A的长度咯) #include <stdio.h> #include <string.h> #include <stdlib.h

[ACM] zoj 3818 Pretty Poem (2014 ACMICPC Regional 牡丹江站网络赛 J题)

Pretty Poem Time Limit: 2 Seconds      Memory Limit: 65536 KB Poetry is a form of literature that uses aesthetic and rhythmic qualities of language. There are many famous poets in the contemporary era. It is said that a few ACM-ICPC contestants can e

ZOJ 3818 Pretty Poem (2014年牡丹江赛区网络赛J题)

1.题目描述:点击打开链接 2.解题思路:本题是一道模拟题,输入一个串,要求判断是否形如"ABABA"或"ABABCAB".只需要对两种情况逐一尝试即可.然而这道题有诸多细节需要考虑.这里说一下我自己的方法. 首先,如果输入的串长度<5,那么直接输出No,或者去掉所有的标点后发现长度<5,输出No.长度上没问题后,写一个专门的solve(int type)函数,来判断是否是上述情况中的一种.对于第一种,只需要枚举A的长度即可,B的长度就是(len-3*i