Square Coins(母函数)

Square Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9926    Accepted Submission(s): 6806

Problem Description

People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland.
There are four combinations of coins to pay ten credits:

ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin.

Your mission is to count the number of ways to pay a given amount using coins of Silverland.

Input

The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.

Output

For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output.

Sample Input

2 10 30 0

Sample Output

1 4 27

题解:钱可以取多次,钱的面值是x^2,最大面值是17^2=289;母函数;

代码:

#include<stdio.h>
#include<math.h>
const int MAXN=310;
int main(){
    int N,a[MAXN],b[MAXN];
    while(~scanf("%d",&N),N){
        for(int i=0;i<=N;i++)
            a[i]=1,b[i]=0;
        for(int i=2;i<=17;i++){//最大硬币值是289
            for(int j=0;j<=N;j++)
            for(int k=0;k+j<=N;k+=i*i)
                b[j+k]+=a[j];
            for(int j=0;j<=N;j++)
                a[j]=b[j],b[j]=0;
        }
            printf("%d\n",a[N]);
    }
    return 0;
} 
时间: 2024-10-25 03:22:36

Square Coins(母函数)的相关文章

杭电ACM1398——Square Coins~~母函数

这一题,简单的母函数的应用,好久没有写过母函数了,有点生疏了. 题目的硬币有17种,分别是1到17的平方的硬币. 下面的是AC的代码: #include <iostream> #include <cstring> #include <cmath> using namespace std; int dp[305], temp[305]; int main() { int i, j, k, l; for(i = 0; i < 305; i++) //初始化 { dp[

hdu 1398 Square Coins(母函数)

#include <stdio.h> #include <string.h> #include <iostream> #include <algorithm> #include <vector> #include <queue> #include <set> #include <map> #include <string> #include <math.h> #include <s

hdu 1398 Square Coins(母函数|完全背包)

http://acm.hdu.edu.cn/showproblem.php?pid=1398 题意:有价值为1^2,2^2....7^2的硬币共17种,每种硬币都有无限个.问用这些硬币能够组成价值为n的钱数共有几种方案数. 母函数: #include <stdio.h> #include <iostream> #include <map> #include <set> #include <stack> #include <vector>

hdu 1398 Square Coins(母函数,完全背包)

链接:hdu 1398 题意:有17种货币,面额分别为i*i(1<=i<=17),都为无限张, 给定一个值n(n<=300),求用上述货币能使价值总和为n的方案数 分析:这题可以用母函数的思想,对300以内的值进行预处理即可 也可用完全背包思想求300以内的方案数 母函数: #include<stdio.h> int main() { int c1[305],c2[305],i,j,k,n; for(i=0;i<=300;i++){ c1[i]=1; c2[i]=0;

HDU 1398 Square Coins(母函数或DP)

Square Coins Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 12929    Accepted Submission(s): 8885 Problem Description People in Silverland use square coins. Not only they have square shapes but

Square Coins (HDU 1398) ———母函数模板详解

Square Coins Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 7748    Accepted Submission(s): 5238 Problem Description People in Silverland use square coins. Not only they have square shapes but

Square Coins(杭电1398)(母函数)

Square Coins Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 8611    Accepted Submission(s): 5851 Problem Description People in Silverland use square coins. Not only they have square shapes but

HDU 1398 Square Coins (母函数-整数拆分变形)

Square Coins Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 7612    Accepted Submission(s): 5156 Problem Description People in Silverland use square coins. Not only they have square shapes but

HDU1398 Square Coins 【母函数模板】

Square Coins Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 7995    Accepted Submission(s): 5416 Problem Description People in Silverland use square coins. Not only they have square shapes but