HDU 搜索练习 非常可乐

非常可乐

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 51 Accepted Submission(s) : 21

Problem Description

大家一定觉的运动以后喝可乐是一件很惬意的事情,但是seeyou却不这么认为。因为每次当seeyou买了可乐以后,阿牛就要求和seeyou一起分享这一瓶可乐,而且一定要喝的和seeyou一样多。但seeyou的手中只有两个杯子,它们的容量分别是N 毫升和M 毫升 可乐的体积为S (S<101)毫升 (正好装满一瓶) ,它们三个之间可以相互倒可乐 (都是没有刻度的,且 S==N+M,101>S>0,N>0,M>0) 。聪明的ACMER你们说他们能平分吗?如果能请输出倒可乐的最少的次数,如果不能输出"NO"。

Input

三个整数 : S 可乐的体积 , N 和 M是两个杯子的容量,以"0 0 0"结束。

Output

如果能平分的话请输出最少要倒的次数,否则输出"NO"。

Sample Input

7 4 3

4 1 3

0 0 0

Sample Output

NO

3

简单题意:

  题目意思就是倒可乐,分成相同分,先判断能不能到相同,再求最少到多少次

思路分析:

  广度搜索,有目标,,一直到倒可乐, 达到目标为止

#include<iostream>
#include<algorithm>
#include<queue>
#include<cstring>
using namespace std;// 照着课件来

bool is[101][101];
int m, n, s, si, sj;
struct node
{
    int x,y,all,t;  //x,y,all分别表示m,n,s杯中可乐的体积,t表示倒了多少次
};
void bfs()
{
    queue<node> que;

    memset(is,false,sizeof(is));
    node p,q;
    p.x = 0,p.y = 0,p.t = 0,p.all = s;
    que.push(p);
    is[p.x][p.y] = true;
    while(!que.empty())
    {
        p = que.front();
        que.pop();
        if(p.y == p.all && p.y == s/2)
        {
            cout << p.t << endl;
            return;
        }
        if(p.all+p.x > m)                               //s倒m
        {
            q.x = m,q.y = p.y,q.all = p.all+p.x-m,q.t = p.t+1;
            if(!is[q.x][q.y])
                que.push(q),is[q.x][q.y] = true;
        }
        else
        {
            q.x = p.all+p.x,q.y = p.y,q.all = 0,q.t = p.t+1;
            if(!is[q.x][q.y])
                que.push(q),is[q.x][q.y] = true;
        }
        if(p.all+p.y > n)                                //s倒n
        {
            q.x = p.x, q.y = n, q.all = p.all+p.y-n,q.t = p.t+1;
            if(!is[q.x][q.y])
                que.push(q),is[q.x][q.y] = true;
        }
        else
        {
            q.x = p.x,q.y = p.all+p.y,q.all = 0,q.t = p.t+1;
            if(!is[q.x][q.y])
                que.push(q),is[q.x][q.y] = true;
        }
        if(p.x+p.y > n)                                //m倒n
        {
            q.x = p.x+p.y-n,q.y = n,q.all = p.all,q.t = p.t+1;
            if(!is[q.x][q.y])
                que.push(q),is[q.x][q.y] = true;
        }
        else
        {
            q.x = 0,q.y = p.x+p.y,q.all = p.all,q.t = p.t+1;
            if(!is[q.x][q.y])
                que.push(q),is[q.x][q.y] = true;
        }
        q.all = p.all+p.x,q.x = 0,q.y = p.y,q.t = p.t+1; //m倒s
        if(!is[q.x][q.y])
            que.push(q),is[q.x][q.y] = true;
        if(p.x+p.y > m)
        {
            q.y = p.y+p.x-m,q.x = m,q.all = p.all,q.t = p.t+1;//n倒m
            if(!is[q.x][q.y])
                que.push(q),is[q.x][q.y] = true;
        }
        else
        {
            q.x = p.x+p.y,q.y = 0,q.all = p.all,q.t = p.t+1;
            if(!is[q.x][q.y])
                que.push(q),is[q.x][q.y] = true;
        }
        q.all = p.all+p.y,q.x = p.x,q.y = 0,q.t = p.t+1; //n倒s
        if(!is[q.x][q.y])
            que.push(q),is[q.x][q.y] = true;
    }
    cout << "NO" << endl;
}
int main()
{

    while(cin >> s >> m >> n)
    {
        if(s == 0 && m == 0 && n == 0)
        break;
        if(s % 2)
        {
            cout << "NO" << endl;
            continue;
        }
        if(m > n) swap(m,n);
        bfs();
    }
    return 0;
}

  

时间: 2024-10-13 23:03:02

HDU 搜索练习 非常可乐的相关文章

HDU 搜索练习 Oil Deposits

Oil Deposits Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other) Total Submission(s) : 61 Accepted Submission(s) : 25 Problem Description The GeoSurvComp geologic survey company is responsible for detecting underground oil

HDU 搜索练习 连连看

连连看 Time Limit: 20000/10000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 27989 Accepted Submission(s): 6952 Problem Description “连连看”相信很多人都玩过.没玩过也没关系,下面我给大家介绍一下游戏规则:在一个棋盘中,放了很多的棋子.如果某两个相同的棋子,可以通过一条线连起来(这条线不能经过其它棋子),而

HDU ACM 1495 非常可乐(广搜BFS)

非常可乐 Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other) Total Submission(s) : 42   Accepted Submission(s) : 21 Font: Times New Roman | Verdana | Georgia Font Size: ← → Problem Description 大家一定觉的运动以后喝可乐是一件很惬意的事情,但是seeyou却

HDU 搜索练习 The magic apple tree

The magic apple tree Time Limit : 3000/1000ms (Java/Other) Memory Limit : 65535/32768K (Java/Other) Total Submission(s) : 26 Accepted Submission(s) : 2 Problem Description Sailormoon girls all like eating many kinds of fruit, such as banana, grape, a

HDU 搜索练习 Red and Black

Red and Black Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other) Total Submission(s) : 23 Accepted Submission(s) : 13 Problem Description There is a rectangular room, covered with square tiles. Each tile is colored either

【HDU - 1495】非常可乐

-->非常可乐  Descriptions: 大家一定觉的运动以后喝可乐是一件很惬意的事情,但是seeyou却不这么认为.因为每次当seeyou买了可乐以后,阿牛就要求和seeyou一起分享这一瓶可乐,而且一定要喝的和seeyou一样多.但seeyou的手中只有两个杯子,它们的容量分别是N 毫升和M 毫升 可乐的体积为S (S<101)毫升 (正好装满一瓶) ,它们三个之间可以相互倒可乐 (都是没有刻度的,且 S==N+M,101>S>0,N>0,M>0) .聪明的AC

HDU 搜索练习 Rescue

Rescue Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other) Total Submission(s) : 44 Accepted Submission(s) : 13 Problem Description Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described a

HDU 搜索练习 Catch him

Catch him Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 797 Accepted Submission(s): 361 Problem Description 在美式足球中,四分卫负责指挥整只球队的进攻战术和跑位,以及给接球员传球的任务.四分卫是一只球队进攻组最重要的球员,而且一般身体都相对比较弱小,所以通常球队会安排5-7名大汉来

[kuangbin带你飞]专题一 简单搜索 - M - 非常可乐

1 #include<iostream> 2 #include<cstdio> 3 #include<cstring> 4 #include<algorithm> 5 #include<queue> 6 using namespace std; 7 bool cup[105][105][105]; 8 struct dot 9 { 10 int a; 11 int b; 12 int c; 13 int s; 14 }; 15 int x, y,