PTA 09-排序3 Insertion or Heap Sort (25分)

题目地址

https://pta.patest.cn/pta/test/16/exam/4/question/676

5-14 Insertion or Heap Sort   (25分)

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer NN (\le 100≤100). Then in the next line, NN integers are given as the initial sequence. The last line contains the partially sorted sequence of the NN numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Heap Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9

Sample Output 2:

Heap Sort
5 4 3 1 0 2 6 7 8 9
/*
评测结果
时间	结果	得分	题目	编译器	用时(ms)	内存(MB)	用户
2017-07-06 18:04	答案正确	25	5-14	gcc	14	1
测试点结果
测试点	结果	得分/满分	用时(ms)	内存(MB)
测试点1	答案正确	7/7	1	1
测试点2	答案正确	6/6	2	1
测试点3	答案正确	2/2	1	1
测试点4	答案正确	2/2	2	1
测试点5	答案正确	4/4	14	1
测试点6	答案正确	4/4	14	1
*/
#include<stdio.h>
#define MAXN 100
int A[MAXN],B[MAXN],tmp[MAXN];
int gNextTurnToPrint=0;
int gPrinted=0;
int gSortType=0;
void swap(int *a,int *b)
{
	int temp;
	temp=*a;
	*a=*b;
	*b=temp;
}
void DBG_printarray(int N) //调试用函数
{
	int d;
	for(d=0;d<N;d++)
	{
		printf("%d ",A[d]);
	}
		printf("\n");
}
void CheckMethod(int N)
{
	if(gPrinted)
		return;

	int i;
	if (gNextTurnToPrint==1)
	{
		if(gSortType==0)
			printf("Insertion Sort\n");
		else
			printf("Heap Sort\n");

		for(i=0;i<N;i++)
			{
				printf("%d",A[i]);
				if(i!=N-1)
					printf(" ");
			}
		gNextTurnToPrint=0;
		gPrinted=1;
		return;
	}

	for (i=0;i<N;i++)
	{
		if(A[i]!=B[i])
		return;
	}
	gNextTurnToPrint=1;
}

void InsertionSort(int a[],int left ,int right,int N)
{
	int i,j,temp;
	for(i=left;i<right;i++)
	{
		temp=a[i+1];
		for(j=i+1;j>left;j--)
		{
			if(temp<a[j-1])
				a[j]=a[j-1];
			else break;
		}
		a[j]=temp;
		CheckMethod(N);
	}
}

void PrecDown(int a[],int x,int N)
{
	int temp=a[x];
	int parent,child;
	parent=x;
	for(child=2*parent+1; child<= N ;child=child*2+1)
	{
		if(child!=N)
		{
			if(a[child+1]>a[child])
				child++;
		}
		if(temp<a[child])
		{
   			a[parent]=a[child];
			parent=child;
		}

		else break;
	}
	a[parent]=temp;
//	DBG_printarray(N+1);
}

void HeapSort(int a[],int N)
{
	//建大顶堆然后把首元素后移
	int i,ptrRight=N-1,temp,d;
	for(i=(ptrRight-1)/2;i>=0;i--)
	{
		PrecDown(a,i,ptrRight);
	}
	for(i=ptrRight;i>0;i--)
	{
		temp=a[i];
		a[i]=a[0];
		a[0]=temp;
		PrecDown(a,0,i-1);
		CheckMethod(N);

	}
}

int main()
{
	int i,N;
	scanf("%d",&N);

	for(i=0;i<N;i++)
	{
		scanf("%d",&A[i]);
		tmp[i]=A[i];
	}

	for(i=0;i<N;i++)
	{
		scanf("%d",&B[i]);
	}

	InsertionSort(A,0,N-1,N);

	if(!gPrinted)
	{
		for(i=0;i<N;i++)
		{
			A[i]=tmp[i];
		}
		gSortType=1;
		HeapSort(A,N);
	}

}

  

时间: 2024-10-25 08:04:50

PTA 09-排序3 Insertion or Heap Sort (25分)的相关文章

【PAT甲级】1098 Insertion or Heap Sort (25 分)

题意: 输入一个正整数N(<=100),接着输入两行N个数,表示原数组和经过一定次数排序后的数组.判断是经过插入排序还是堆排序并输出再次经过该排序后的数组(数据保证答案唯一). AAAAAccepted code: 1 #define HAVE_STRUCT_TIMESPEC 2 #include<bits/stdc++.h> 3 using namespace std; 4 int a[107],b[107]; 5 int c[107][5]; 6 int main(){ 7 ios:

A1098 Insertion or Heap Sort (25分)

一.技术总结 这是一道考查插入排序和堆排序的问题. 这里开始最主要的问题是,没有理解堆排序.堆排序是通过把数组中第一个元素与最后一个元素交换,然后再对于第一个元素进行向下调整downAdjust函数. 所以这里对于插入排序,只要一直遍历发现第一个元素的比前一个元素小,记录下这时的下标.然后同时后面的元素与原数组相同,那么就是插入排序. 对于堆排序怎么知道到哪一步,根据堆排序的特点知道.是通过从后往前交换元素,然后使用downAdjust函数调整,所以要判断,就从后往前判断,如果出现当前元素,比首

1098 Insertion or Heap Sort (25 分)

According to Wikipedia: Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted li

1098. Insertion or Heap Sort (25)【排序】——PAT (Advanced Level) Practise

题目信息 1098. Insertion or Heap Sort (25) 时间限制100 ms 内存限制65536 kB 代码长度限制16000 B According to Wikipedia: Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one el

pat1098. Insertion or Heap Sort (25)

1098. Insertion or Heap Sort (25) 时间限制 100 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue According to Wikipedia: Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, inse

PAT甲题题解1098. Insertion or Heap Sort (25)-(插入排序和堆排序)

题目就是给两个序列,第一个是排序前的,第二个是排序中的,判断它是采用插入排序还是堆排序,并且输出下一次操作后的序列. 插入排序的特点就是,前面是从小到大排列的,后面就与原序列相同. 堆排序的特点就是,后面是从小到大排列的最大的几个数p~n-1,前面第一位则是p-1. 所以只要先按照插入排序的特点来判断是否为插入排序,接下来再进行操作就可以了,这里要手动写下最大堆的更新操作. 代码: #include <iostream> #include <cstdio> #include <

PAT (Advanced Level) 1098. Insertion or Heap Sort (25)

简单题.判断一下是插排还是堆排. #include<cstdio> #include<cstring> #include<cmath> #include<vector> #include<map> #include<queue> #include<stack> #include<algorithm> using namespace std; const int maxn=200; int a[maxn],b[m

PAT 1098 Insertion or Heap Sort (25)

According to Wikipedia: Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. At each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted

1098 Insertion or Heap Sort (25)

According to Wikipedia: Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. At each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted