POJ 1159 Palindrome(lcs加滚动数组)

Palindrome

Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 52350   Accepted: 18041

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order
to obtain a palindrome.

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from ‘A‘ to ‘Z‘, lowercase letters
from ‘a‘ to ‘z‘ and digits from ‘0‘ to ‘9‘. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

设原序列S的逆序列为S‘ ,则这道题目的关键在于,

最少需要补充的字母数 = 原序列S的长度 —  S和S‘的最长公共子串长度

刚开始做的时候没有想到滚动数组,结果就mle了。。(后来听说改成short int ,结果就ac了)空间开销很大

#include <iostream>
#include <cstring>
using namespace std;

#define maxn 5005
char str[maxn];//输入的字符串
char nstr[maxn];//输入的字符串的逆序列
short int dp[maxn][maxn];//定义动态二维数组并初始化

int main()
{
    int n;//输入的字符串长度
    cin>>n;

    dp[0][0]=0;
    memset(dp,0,sizeof(dp));

    int i,j;
    for(i=1,j=n;i<=n&&j>=1;i++,j--)
    {
        cin>>str[i];
        nstr[j]=str[i];//给逆序列赋值
    }

    for(i=1;i<=n;i++)
        for(j=1;j<=n;j++)
        {
            if(str[i]==nstr[j])//如果字符相等,dp[i][j]等于左上值加1
                dp[i][j]=dp[i-1][j-1]+1;
            if(str[i]!=nstr[j])//不相等,dp[i][j]等于上方和左方dp值得最大值
                dp[i][j]=dp[i-1][j]>dp[i][j-1]?dp[i-1][j]:dp[i][j-1];
        }

		cout<<n-dp[n][n]<<endl;
		return 0;
}

滚动数组

滚动数组的作用在于优化空间,主要应用在递推或动态规划中(如01背包问题)。因为DP题目是一个自底向上的扩展过程,我们常常需要用到的是连续的解,前面的解往往可以舍去。所以用滚动数组优化是很有效的。利用滚动数组的话在N很大的情况下可以达到压缩存储的作用。

例:斐波那契数列:

一般代码

int fib(int n)
{
    Fib[0] = 0;
    Fib[1] = 1;
    Fib[2] = 1;
    for(int i = 3; i <= n; ++i)
        Fib[i] = Fib[i - 1] + Fib[i - 2];
    return Fib[n];
} 

应用滚动数组

int fib(int n)
{
    Fib[1] = 0;
    Fib[2] = 1;
    for(int i = 2; i <= n; ++i)
    {
        Fib[0] = Fib[1];
        Fib[1] = Fib[2];
        Fib[2] = Fib[0] + Fib[1];
    }
    return Fib[2];
} 

对于本题,用行数以0  1  0  1的滚动方式,滚动表达式为i%2和(i-1)%2 ,求余滚动

#include <iostream>
#include <cstring>
using namespace std;

#define maxn 5005
char str[maxn];//输入的字符串
char nstr[maxn];//输入的字符串的逆序列
int dp[2][maxn];//定义动态二维数组并初始化

int main()
{
    int n;//输入的字符串长度
    cin>>n;

    dp[0][0]=0;
    memset(dp,0,sizeof(dp));

    int i,j;
    for(i=1,j=n;i<=n&&j>=1;i++,j--)
    {
        cin>>str[i];
        nstr[j]=str[i];//给逆序列赋值
    }

    for(i=1;i<=n;i++)
        for(j=1;j<=n;j++)
        {
            if(str[i]==nstr[j])//如果字符相等,dp[i][j]等于左上值加1
                dp[i%2][j]=dp[(i-1)%2][j-1]+1;
            if(str[i]!=nstr[j])//不相等,dp[i][j]等于上方和左方dp值得最大值
                dp[i%2][j]=dp[(i-1)%2][j]>dp[i%2][j-1]?dp[(i-1)%2][j]:dp[i%2][j-1];
        }

		cout<<n-dp[n%2][n]<<endl;
		return 0;
}

POJ 1159 Palindrome(lcs加滚动数组)

时间: 2024-12-13 12:07:02

POJ 1159 Palindrome(lcs加滚动数组)的相关文章

POJ 1159 - Palindrome (LCS, 滚动数组)

Palindrome Time Limit: 3000MS   Memory Limit: 65536K Total Submissions: 55018   Accepted: 19024 Description A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a

poj 1159 Palindrome lcs+滚动数组

点击打开链接题目链接 Palindrome Time Limit: 3000MS   Memory Limit: 65536K Total Submissions: 52910   Accepted: 18248 Description A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are

poj 1159 Palindrome (LCS)

链接:poj 1159 题意:给定一个字符串,求最少添加多少个字符可使得该字符串变为回文字符串 分析:设原序列S的逆序列为S' ,最少需要补充的字母数 = 原序列S的长度 - S和S'的最长公共子串长度 原因:要求最少添加几个字符,我们可以先从原串中找到一个最长回文串,然后对于原串中不属于这个回文串的字符,在它关于回文串中心的对称位置添加一个相同字符即可.那么需要添加的字符数量即为n-最长回文串长度. 最长回文串可以看作是原串中前面和后面字符的一种匹配(每个后面的字符在前面找到一个符合位置要求的

LCS(滚动数组) POJ 1159 Palindrome

题目传送门 1 /* 2 LCS裸题:长度减去最大相同长度就是要插入的个数 3 dp数组二维都开5000的话就会超内存,这里就用到了滚动数组, 4 因为在LCS的计算中,i的变化只相差1,所以可以通过对2取余来进行滚动:) 5 */ 6 #include <cstdio> 7 #include <iostream> 8 #include <cstring> 9 #include <algorithm> 10 #include <string> 1

LCS POJ 1159 Palindrome

题目传送门 1 /* 2 LCS裸题:长度减去最大相同长度就是要插入的个数 3 */ 4 #include <cstdio> 5 #include <iostream> 6 #include <cstring> 7 #include <algorithm> 8 #include <string> 9 using namespace std; 10 11 const int MAXN = 5e3 + 10; 12 const int INF = 0

POJ 1159 Palindrome &amp;&amp; HDU 1159 Common Subsequence

1.先说说杭电的1159吧! 这道题是基础动规,比较简单! 就是要你求最长的公共子序列(不要优化) 动态转移方程: dp[i+1][j+1]=(a[i]=b[i])?dp[i][j]+1:max(dp[i+1][j],dp[i][j+1]) AC代码: #include<stdio.h> #include<string.h> #include<algorithm> using namespace std; #define N 520 char a[N],b[N]; in

POJ 1159 Palindrome 题解

本题的题意理解之后,就是求最长回文子序列 longest palindrome subsequence,这里注意子序列和子串的区别. 有两种求法,一种是直接求,相当于填矩阵右上对角阵,另一种是转化为longest common subsequence的求法. 最大难点就是要求内存不能使用二维的. 故此第一种方法是有点难度的,因为需要把二维矩阵的对角线转化为一维表记录,对好下标就好了. 第二中方法会稍微容易点,效率都是一样的O(n*n). 方法1: #include <cstdio> const

POJ 1159 Palindrome

Palindrome Time Limit: 3000MS   Memory Limit: 65536K Total Submissions: 51518   Accepted: 17733 Description A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a

POJ 1159 Palindrome DP

Palindrome Time Limit: 3000MS   Memory Limit: 65536K Total Submissions: 51913   Accepted: 17877 Description A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a