HDU1010 Tempter of the Bone 【DFS】+【剪枝】

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 70895    Accepted Submission(s): 19535

Problem Description

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately
to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the
T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for
more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively.
The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

‘X‘: a block of wall, which the doggie cannot enter;

‘S‘: the start point of the doggie;

‘D‘: the Door; or

‘.‘: an empty block.

The input is terminated with three 0‘s. This test case is not to be processed.

Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.

Sample Input

4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0

Sample Output

NO
YES

这题真恶心,用scanf("%c")或者getchar一直WA,换成cin就A了。

#include <stdio.h>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#define maxn 10
using namespace std;

char map[maxn][maxn];
int n, m, t, dx, dy;
const int mov[][2] = {-1, 0, 1, 0, 0, 1, 0, -1};

bool check(int x, int y){
    return x >= 0 && x < n && y >= 0 &&
        y < m && map[x][y] != 'X';
}

bool DFS(int x, int y, int step)
{
    if(x == dx && y == dy && step == t)
        return 1;
    int i, a, b, tmp;
    tmp = t - step - abs(dx - x) - abs(dy - y);
    if(tmp < 0 || tmp & 1) return 0;
    for(i = 0; i < 4; ++i){
        a = x + mov[i][0];
        b = y + mov[i][1];
        if(check(a, b)){
            map[a][b] = 'X';
            if(DFS(a, b, step + 1)) return 1;
            map[a][b] = '.';
        }
    }
    return 0;
}

int main()
{
    //freopen("stdin.txt", "r", stdin);
    int i, j, sx, sy, wall;
    while(scanf("%d%d%d", &n, &m, &t), n || m || t){
        for(i = wall = 0; i < n; ++i){
            //getchar();
            for(j = 0; j < m; ++j){
                cin >> map[i][j];
                if(map[i][j] == 'S'){
                    sx = i; sy = j;
                }else if(map[i][j] == 'D'){
                    dx = i; dy = j;
                }else if(map[i][j] == 'X')
                    ++wall;
            }
        }
        if(m * n - wall <= t){ //cut1
            printf("NO\n"); continue;
        }
        map[sx][sy] = 'X';
        if(DFS(sx, sy, 0)) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}

原奇了怪的WA代码:

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define maxn 10

char map[maxn][maxn];
int n, m, t, dx, dy, ok;
const int mov[][2] = {-1, 0, 1, 0, 0, 1, 0, -1};

bool check(int x, int y){
    return x >= 0 && x < n && y >= 0 && y < m
        && map[x][y] != 'x' && map[x][y] != 'X';
}

bool DFS(int x, int y, int step)
{
    if(x == dx && y == dy && step == t){
        return 1;
    }
    int i, a, b, tmp;
    tmp = (t - step) - abs(dx - x) - abs(dy - y);
    if(tmp < 0 || tmp & 1) return 0;
    for(i = 0; i < 4; ++i){
        a = x + mov[i][0];
        b = y + mov[i][1];
        if(check(a, b)){
            map[a][b] = 'X';
            if(DFS(a, b, step + 1)) return 1;
            map[a][b] = '.';
        }
    }
    return 0;
}

int main()
{
    int i, j, sx, sy, wall;
    while(scanf("%d%d%d", &n, &m, &t), n || m || t){
        for(i = wall = 0; i < n; ++i){
            getchar();
            for(j = 0; j < m; ++j){
                scanf("%c", &map[i][j]);
                if(map[i][j] == 'S'){
                    sx = i; sy = j;
                }else if(map[i][j] == 'D'){
                    dx = i; dy = j;
                }else if(map[i][j] == 'X')
                    ++wall;
            }
        }
        if(m * n - wall <= t){ //cut1
            printf("NO\n"); continue;
        }
        map[sx][sy] = 'X'; ok = 0;
        if(DFS(sx, sy, 0)) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}

HDU1010 Tempter of the Bone 【DFS】+【剪枝】,布布扣,bubuko.com

时间: 2024-10-12 08:44:52

HDU1010 Tempter of the Bone 【DFS】+【剪枝】的相关文章

hdu1010 Tempter of the Bone(DFS+剪枝)

Tempter of the Bone Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 90716    Accepted Submission(s): 24683 Problem Description The doggie found a bone in an ancient maze, which fascinated him a

HDU1010 Tempter of the Bone(DFS+剪枝)

1 # include <stdio.h> 2 #include <cstdio> 3 #include <iostream> 4 #include <cstring> 5 #include <cmath> 6 using namespace std; 7 char map[8][8]; 8 int visit[8][8]; 9 struct node{ 10 int x,y; 11 }; 12 int n,m; 13 node Save,Dog

HDU 1010 Tempter of the Bone dfs+剪枝

给你一个迷宫一个起点和一个终点,问你能否走T步刚好到达终点,不能重复走,并且只有4个方向 显然这是一个dfs,虽然N最大只有7,但是裸的dfs复杂度还是太高了,因此要进行一些剪枝 1.如果T比图上所有的可走点还要大,肯定是不可行的.这个可以避免dfs整张图. 2.奇偶剪枝,有性质当前点(x,y)到目标点(tx,ty)的所有路径的长度的奇偶性一定和|x-tx|+|y-ty|一样. #include <cstdio> #include <iostream> #include <c

HDU 1010 Tempter of the Bone(DFS剪枝)

Tempter of the Bone Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 129289    Accepted Submission(s): 34906 Problem Description The doggie found a bone in an ancient maze, which fascinated him a

B - Tempter of the Bone(DFS+剪枝)

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of

HDU_(1010) Tempter of the Bone(DFS,剪枝)

题目请点我 题意: 有一个迷宫,看能不能经过T秒恰好从起点走到终点.因为可能会考虑到绕路,2^49可能会超时(况且涉及到绕路,墙的数目一定不会很多),我们就可以在每次都进行一次判断,看剩下的时间能否走到终点.另外因为只能在T秒走到,那么绕路的话一定会多走偶数步数,利用这个性质也可以剪枝.这道题其实之前做过的,但是第二次做还是TLE了很多次,其实这题的关键不仅是dfs,在T秒恰好到达需要绕路才是这道题的亮点,trap也在这里. 代码: #include <iostream> #include &

HDU1010 Tempter of the Bone(回溯 + 剪枝)

题意: 输入一个 N * M的迷宫,这个迷宫里'S'代表小狗的位置,'X'代表陷阱,‘D’代表门,‘.’代表可行走的地方,小狗每次可以选择往周围的四个方向行走,问这个小狗能否正好T步找到门. 思路: 利用回溯 + 剪枝,这道题剪枝特别重要. 剪枝一: 可以把图看成这样: 1 0 1 0 10 1 0 1 01 0 1 0 10 1 0 1 01 0 1 0 1 则假设从点 a(i + j,横纵坐标之和) 走到点 b(i + j) ,如果 a 和 b 的奇偶性相同,那么从 a 到 b 必须是偶数步

HDU1010 Tempter of the Bone(小狗是否能逃生----DFS)

Tempter of the Bone Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Description The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggi

HDU 1010 Tempter of the Bone heuristic 剪枝法

本题就是考剪枝法了. 应该说是比较高级的应用了.因为要使用heuristic(经验)剪枝法.要总结出这个经验规律来,不容易.我说这是高级的应用也因为网上太多解题报告都没有分析好这题,给出的程序也很慢,仅仅能过掉,由此看来很多人没有做好这道题. 这里我需要更正一下网上流行的说法:奇偶剪枝法. 其实本题使用奇偶剪枝法并不能太大提高速度,只能说仅仅让使用奇偶剪枝过掉.所以网上说本题使用奇偶剪枝的,其实并不能提高速度. 原因: 奇偶剪枝只能剪枝一次,不能在递归的时候剪枝,因为只要初始化位置符合奇偶性,那