BestCoder Round #71 (div.2) (hdu 5620 菲波那切数列变形)

KK‘s Steel

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 350    Accepted Submission(s): 166

Problem Description

Our lovely KK has a difficult mathematical problem:he has a N(1≤N≤1018) meters steel,he will cut it into steels as many as possible,and he doesn‘t want any two of them be the same length or any three of them can form a triangle.

Input

The first line of the input file contains an integer T(1≤T≤10), which indicates the number of test cases.

Each test case contains one line including a integer N(1≤N≤1018),indicating the length of the steel.

Output

For each test case, output one line, an integer represent the maxiumum number of steels he can cut it into.

Sample Input

1

6

Sample Output

3

Hint

1+2+3=6 but 1+2=3 They are all different and cannot make a triangle.

要求:给一个长整形数n让你把n分成若干份,1、任意两份长度不能相等 2、任意三分不能组成三角形

分析:因为斐波那契数列中的数满足此要求,所以从这个方面入手,只要分成的数满足a+b<=c即可,所以我们在数列1  2  3  5  8  13  21 ......的数中选取,如果前i项的和等于n输出i如果前i项的和大于n输出i-1

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
#define MAX 100100
#define INF 0x3f3f3f
#define LL long long
using namespace std;
LL fb[10010];
LL f[1001];
void biao()
{
	LL i,j;
	fb[1]=1;
	fb[2]=2;
	for(i=3;i<120;i++)
	    fb[i]=fb[i-1]+fb[i-2];
	f[1]=fb[1];
	for(i=2;i<120;i++)
	    f[i]=f[i-1]+fb[i];
}
int main()
{
	int t,i,j;
	LL n;
	biao();
	scanf("%d",&t);
	while(t--)
	{
		scanf("%lld",&n);
		for(i=1;i<120;i++)
		{
			if(n==f[i])
			{
				printf("%d\n",i);
				break;
			}
			if(n<f[i])
			{
				printf("%d\n",i-1);
				break;
			}
		}
	}
	return 0;
}

  

时间: 2024-12-25 15:44:36

BestCoder Round #71 (div.2) (hdu 5620 菲波那切数列变形)的相关文章

js实现菲波那切数列的两种常用方法

菲波那切数列即:1 1 2 3 5 8......,后面的数字是前面两个数字的和,并且第一个,第二个数字都是1,用js实现 的两种方法,一种通过常用的递归调用,第二种不通过递归,而是通过强大的闭包实现. 1.递归实现 // fab 1 1 2 3 5 8 function fab(num) { if(num==1 || num==2){ return 1; }else{ return fab(num-1)+fab(num-2); } } alert(fab(5)) 2.闭包实现.闭包主要在于:1

菲波纳切数列

写一个函数,输入n,求斐波那契数列(Fibonacci)数列的第n项.斐波那契数列定义如下: 当n=0时,f(n)=0;当n=1时,f(n)=1;当n>1时,f(n)=f(n-1)+f(n-2). 效率很低的解乏,挑剔的面试官不会喜欢. public int fibo(int n){ if(n<=0) return 0; if(n==1) return 1; return fibo(n-1)+fibo(n-2); } 我们以求解f(10)为例来分析递归的求解过程.想求得f(10),需要先求的f

BestCoder Round #50 (div.2) HDU 5365 Run(简单几何)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5365 题面:(严重吐槽,看着真不舒服,还是改一下吧) Run Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 549    Accepted Submission(s): 245 Problem Description AFA is a g

hduoj 1848 Fibonacci again and again【sg函数】【博弈】【菲波那切数列】

Fibonacci again and again Description 任何一个大学生对菲波那契数列(Fibonacci numbers)应该都不会陌生,它是这样定义的: F(1)=1; F(2)=2; F(n)=F(n-1)+F(n-2)(n>=3); 所以,1,2,3,5,8,13--就是菲波那契数列. 在HDOJ上有不少相关的题目,比如1005 Fibonacci again就是曾经的浙江省赛题. 今天,又一个关于Fibonacci的题目出现了,它是一个小游戏,定义如下: 1.  这是

BestCoder Round #71 (div.2)

比赛链接:click here 题解: KK's Steel 问题描述 我们可爱的KK遇到了一道数学难题:对于一条长为N\left( 1\leq N\leq {10}^{18}\right)N(1≤N≤10?18??)米的钢管,最多可以锯成几根小钢管,使得锯成的钢管互不相等且均不能围成三角形. 输入描述 第一行一个数T\left( 1\leq T\leq 10\right)T(1≤T≤10),表示数据组数. 接着T行,每行一个整数N\left( 1\leq N\leq {10}^{18}\rig

BestCoder Round #52 (div.2) HDU 5418 Victor and World (DP+状态压缩)

[题目链接]:click here~~ [题目大意]: 问题描写叙述 经过多年的努力,Victor最终考到了飞行驾照. 为了庆祝这件事,他决定给自己买一架飞机然后环游世界. 他会驾驶一架飞机沿着规定的航线飞行.在地球上一共同拥有nn个国家,编号从11到nn.各个国家之间通过mm条双向航线连接,第ii条航线连接第u_iu?i??个国家与第v_iv?i??个国家,通过这条航线须要消耗w_iw?i??升油.且从11号国家能够直接或间接到达22到nn中随意一个国家. Victor一開始位于11号国家.他

菲波那切数列

一个数组:1,1,2,3,5,8,13,21...+m: static void Main(string[] args) { Console.Write("输入想求的斐波那契数列项数:"); int n = Convert.ToInt32(Console.ReadLine()); //递归实现 Console.WriteLine("斐波那契数列数列递归算出的第{0}项为:{1}", n, Calculate(n)); } static int Calculate(i

带有记忆的菲波那切数列

public static int Fib(int n) { int q=0; int []r=new int[n+1]; r[0]=1; r[1]=1; for(int j=2;j<=n;j++) { r[j]=r[j-1]+r[j-2]; } return r[n]; }

php实现菲波那切数列和杨辉三角

1.递归  显示斐波那契数列 <?PHP function recursion($num){ //判断是否小于0 if($num<0){ return -1; } if($num==1){ return 0; } if($num==2 || $num==3){ return 1; } return recursion($num-1)+recursion($num-2); } //循环显示 for($i=1;$i<=20;$i++) { $str .= ',',recursion($i);