PAT1006

1006. 换个格式输出整数 (15)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

8000 B

判题程序

Standard

作者

CHEN, Yue

让我们用字母B来表示“百”、字母S表示“十”,用“12...n”来表示个位数字n(<10),换个格式来输出任一个不超过3位的正整数。例如234应该被输出为BBSSS1234,因为它有2个“百”、3个“十”、以及个位的4。

输入格式:每个测试输入包含1个测试用例,给出正整数n(<1000)。

输出格式:每个测试用例的输出占一行,用规定的格式输出n。

输入样例1:

234

输出样例1:

BBSSS1234

输入样例2:

23

输出样例2:

SS123
package com.lwh.agrithmatic.paractice;
import java.util.Scanner;
public class Practise6 {
    public static void main(String[] args) {
        Scanner scanner=new Scanner(System.in);
        int n=scanner.nextInt();
        int a=n/100;
        int b=n%100;
        int c=b/10;
        int d=b%10;
        String result="";
        if(a>0||b>0){//三位数
            for(int i=0;i<a;i++){
                result+="B";
            }
            for(int i=0;i<c;i++){
                result+="S";
            }
            for(int i=1;i<d+1;i++){
                result+=i;
            }
        }else{
            for(int i=1;i<d+1;i++){
                result+=i;
            }
        }
        System.out.println(result);
    }

}
时间: 2024-11-08 03:26:10

PAT1006的相关文章

PAT1006. Sign In and Sign Out

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked a

pat1006. Sign In and Sign Out (25)

1006. Sign In and Sign Out (25) 时间限制 400 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door

PAT1006. 换个格式输出整数 (15)

让我们用字母B来表示“百”.字母S表示“十”,用“12...n”来表示个位数字n(<10),换个格式来输出任一个不超过3位的正整数.例如234应该被输出为BBSSS1234,因为它有2个“百”.3个“十”.以及个位的4. 输入格式:每个测试输入包含1个测试用例,给出正整数n(<1000). 输出格式:每个测试用例的输出占一行,用规定的格式输出n. 输入样例1: 234 输出样例1: BBSSS1234 输入样例2: 23 输出样例2: SS123 思路:注意细节! 1 #include <