ZOJ 1002 DFS

Fire Net


Time Limit: 2 Seconds      Memory Limit: 65536 KB


Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.

Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.

The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a ‘.‘ indicating an open space and an uppercase ‘X‘ indicating a wall. There are no spaces in the input file.

For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

Sample input:

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0

Sample output:

5
1
5
2
4

题意   n*n的地图,‘.‘表示空地,‘X‘表示墙,现在往地图上放置炮塔,要求两两炮塔不能同行同列(除非之间有墙),给定一种地图,问这个地图最多可以放置多少个炮塔?解析   

AC代码
#include <stdio.h>
#include <math.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <sstream>
#include <queue>
#include <stack>
#include <vector>
#include <algorithm>
const int maxn=100000;
using namespace std;
typedef long long ll;
int n;
int ans;             //最多可放炮塔数
char map[5][5];
int canput(int r,int c)            //判断(r,c)位置能否放置炮塔
{
    int i;                                  //因为行列是递增的,因此只需向上和向左搜索是否有碉堡即可
    for(i=r-1;i>=0&&map[i][c]!=‘X‘;i--)      //向上
    {
        if(map[i][c]==‘O‘)
            return 0;
    }
    for(i=c-1;i>=0&&map[r][i]!=‘X‘;i--)    // 向左
    {
        if(map[r][i]==‘O‘)
            return 0;
    }
    return 1;
}
void solve(int k,int current)
{
    int x,y;
    if(k==n*n)              //整个图判断完毕
    {
        if(current>ans)      //更新最优解
        {
            ans=current;
            return;
        }
    }
    else
    {
        x=k/n;                             //将单元数转化为坐标
        y=k%n;
        if(map[x][y]==‘.‘&& canput(x,y)==1)   //如果单元格可以放置炮塔
        {
            map[x][y]=‘O‘;                    //放置一个炮塔
            solve(k+1,current+1);             //递归到下一个单元格
            map[x][y]=‘.‘;                     //恢复单元格 ,回溯
        }
        solve(k+1,current);               //本单元格不能放置炮塔
    }
}
int main(int argc, char const *argv[])
{
    while(scanf("%d",&n)!=EOF&&n)
    {
        ans=0;
        for(int i=0;i<n;i++)
        {
            scanf("%s",map[i]);
        }
        solve(0,0);
        printf("%d\n",ans);
    }
    return 0;
}
时间: 2024-10-01 02:44:36

ZOJ 1002 DFS的相关文章

DFS ZOJ 1002/HDOJ 1045 Fire Net

题目传送门 1 /* 2 题意:在一个矩阵里放炮台,满足行列最多只有一个炮台,除非有墙(X)相隔,问最多能放多少个炮台 3 搜索(DFS):数据小,4 * 4可以用DFS,从(0,0)开始出发,往(n-1,n-1)左下角走,x = cnt / n; y = cnt % n; 更新坐标, 4 直到所有点走完为止,因为从左边走到右边,只要判断当前点左上方是否满足条件就可以了 5 注意:当前点不能放炮台的情况也要考虑 6 g[x][y] == 'o'; 的错误半天才检查出来:) 7 */ 8 #inc

ZOJ 1002 Fire Net

columns, each representing a street or a piece of wall. A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting thro

ZOJ 1002 Fire Net(dfs)

嗯... 题目链接:https://zoj.pintia.cn/problem-sets/91827364500/problems/91827364501 这道题是想出来则是一道很简单的dfs: 将一个4*4的地图给每一个点排序,如下图: 0  1  2  3 4  5  6  7 8  9  10  11 12 13 14 15 设一个点为第k个点,那么它的坐标为(k/n,k%n),根据这个进行dfs,当k == n * n是退出dfs.如果k < n *n,就继续dfs,判断是否能放下,即要

ZOJ 1002 Fire Net(DFS啊 )

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=2 Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. A blockhouse is a

hdu 1045 &amp;&amp; zoj 1002 Fire Net(DFS &amp;&amp; 二分图匹配)

Fire Net Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 7958    Accepted Submission(s): 4542 Problem Description Suppose that we have a square city with straight streets. A map of a city is a

[ZOJ 1002] Fire Net (简单地图搜索)

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=1002 题目大意: 给你一个n*n的地图,地图上的空白部分可以放棋子,也有墙,问最多能放多少棋子使得棋子两两不会袭击? 棋子袭击当且仅当处在同一行或者同一列上并且中间没有墙的阻隔. 真是好久没写过搜索题了..这道题都写了这么久!! 直接写dfs(x,y,now) 代表我现在站在x点,y点上,那么就只能产生两种状态,放棋子或者不放棋子. 然后写一个C(x,y)代表当

【搜索 回溯】 zoj 1002

题意:一些机枪彼此不能在同一行和同一列,但是由于有墙的阻隔,能保证子弹无法穿透,即可以同行同列,现问如果说给了一个n*n(n<=4)的矩阵,并给出了墙的分布情况,能否求出最大能繁殖的机枪数. 思路:之前按八皇后的思想一行一行搜,不理想,之后改成一个格一个格的搜,回溯要理解好就没问题. #include <iostream> #include <cstdio> using namespace std; int n,best; char map[4][4]; int canput

ZOJ 1204:(DFS)

输出一串数所能构成的所有等式,按照加数从大到小,算式从长到短排列 一开始因为无法按照要求输出纠结了好一阵~~最后看了大神的代码才发现只需要每次dfs规定长度就好了~ #include"cstdio" #include"cstring" #include"algorithm" #define MAXN 40 using namespace std; int num[MAXN],n,front,rear,ok; int stack[MAXN]; in

ZOJ 2110 DFS

狗要出门,且正好在T秒 就是DFS + 剪枝, 联系一下剪枝技巧 #include<iostream> #include<cstdio> #include<cstring> #include<algorithm> using namespace std; typedef long long ll; const int step[][2] = {0,1,0,-1,1,0,-1,0}; const int maxn = 10 + 7; char Map[maxn