POJ3107——Godfather

Godfather

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 4853   Accepted: 1671

Description

Last years Chicago was full of gangster fights and strange murders. The chief of the police got really tired of all these crimes, and decided to arrest the mafia leaders.

Unfortunately, the structure of Chicago mafia is rather complicated. There are
n persons known to be related to mafia. The police have traced their activity for some time, and know that some of them are communicating with each other. Based on the data collected, the chief of the police suggests that the mafia hierarchy can be
represented as a tree. The head of the mafia, Godfather, is the root of the tree, and if some person is represented by a node in the tree, its direct subordinates are represented by the children of that node. For the purpose of conspiracy the gangsters only
communicate with their direct subordinates and their direct master.

Unfortunately, though the police know gangsters’ communications, they do not know who is a master in any pair of communicating persons. Thus they only have an undirected tree of communications, and do not know who Godfather is.

Based on the idea that Godfather wants to have the most possible control over mafia, the chief of the police has made a suggestion that Godfather is such a person that after deleting it from the communications tree the size of the largest remaining connected
component is as small as possible. Help the police to find all potential Godfathers and they will arrest them.

Input

The first line of the input file contains n — the number of persons suspected to belong to mafia (2 ≤
n ≤ 50 000). Let them be numbered from 1 to n.

The following n ? 1 lines contain two integer numbers each. The pair
ai
, bi means that the gangster ai has communicated with the gangster
bi. It is guaranteed that the gangsters’ communications form a tree.

Output

Print the numbers of all persons that are suspected to be Godfather. The numbers must be printed in the increasing order, separated by spaces.

Sample Input

6
1 2
2 3
2 5
3 4
3 6

Sample Output

2 3

Source

Northeastern Europe 2005, Northern Subregion

输出树上所有的重心

 /*
    定义dp[i]为去掉i结点,剩下的树里,结点最多的那颗树的结点数。
    可分为2类情况。
    1、由于i结点的儿子结点都成了一棵树的根节点,所以dp[i] = (i的每个儿子所拥有的结点数,的最大值)。
    2、而另一种情况就是剩下的那棵树,所以dp[i] = N-num[i]。
    其中num[i]表示以i为根的树的所有结点数,可以dfs求出。
*/
#include <map>
#include <set>
#include <list>
#include <stack>
#include <queue>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

const int N = 50010;
const int inf = 0x3f3f3f3f;
int n;

struct node
{
	int next;
	int to;
}edge[N << 1];

int zhonxin[N];
int head[N];
int dp[N];
int num[N];
int tot;
bool vis[N];
int dist[N];

void addedge(int from, int to)
{
	edge[tot].to = to;
	edge[tot].next = head[from];
	head[from] = tot++;
}

int dfs(int u)
{
	vis[u] = 1;
	num[u] = 1;
	for (int i = head[u]; ~i; i = edge[i].next)
	{
		int v = edge[i].to;
		if (!vis[v])
		{
			num[u] += dfs(v);
		}
	}
	return num[u];
}

void DP(int u)
{
	vis[u] = 1;
	for (int i = head[u]; ~i; i = edge[i].next)
	{
		int v = edge[i].to;
		if (vis[v])
		{
			dp[u] = max(dp[u], n - num[u]);
		}
		else
		{
			dp[u] = max(dp[u], num[v]);
			DP(v);
		}
	}
}

int main()
{
	int u, v;
	while (~scanf("%d", &n))
	{
		memset ( head, -1, sizeof(head) );
		memset ( num, 0, sizeof(num) );
		memset ( vis, 0, sizeof(vis) );
		memset ( dp, 0, sizeof(dp) );
		tot = 0;
		for (int i = 0; i < n - 1; ++i)
		{
			scanf("%d%d", &u, &v);
			addedge(u, v);
			addedge(v, u);
		}
		dfs(1);
		memset ( vis, 0, sizeof(vis) );
		DP(1);
		int ans = inf;
		for (int i = 1; i <= n; ++i)
		{
			if (ans > dp[i])
			{
				ans = dp[i];
			}
		}
		int res = 0;
		for (int i = 1; i <= n; ++i)
		{
			if (ans == dp[i])
			{
				zhonxin[res++] = i;
			}
		}
		for (int i = 0; i < res - 1; ++i)
		{
			printf("%d ", zhonxin[i]);
		}
		printf("%d\n", zhonxin[res - 1]);
	}
	return 0;
}
时间: 2024-10-17 00:40:43

POJ3107——Godfather的相关文章

poj3107 Godfather

Description Last years Chicago was full of gangster fights and strange murders. The chief of the police got really tired of all these crimes, and decided to arrest the mafia leaders. Unfortunately, the structure of Chicago mafia is rather complicated

poj3107 Godfather 求树的重心

Description Last years Chicago was full of gangster fights and strange murders. The chief of the police got really tired of all these crimes, and decided to arrest the mafia leaders. Unfortunately, the structure of Chicago mafia is rather complicated

[poj3107]Godfather树形dp

题意:求树的重心 解题关键:想树的结构,删去某个点后只剩下它的子树和原树-此树所形成的数,然后第一次dp求每个子树的节点个数,第二次dp求解答案即可. 此题一开始一直T,后来加了输入挂才过,第一次见卡cin+关同步的题目. 用scanf试了一下,也可以过,5s,看来cin关同步和scanf差距也是蛮大的. 一:219ms 1 #include<cstdio> 2 #include<cstring> 3 #include<algorithm> 4 #include<

【树形dp】Godfather

[POJ3107]Godfather Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 7212   Accepted: 2535 Description Last years Chicago was full of gangster fights and strange murders. The chief of the police got really tired of all these crimes, and de

树形DP水题杂记

BZOJ1131: [POI2008]Sta 题意:给出一个N个点的树,找出一个点来,以这个点为根的树时,所有点的深度之和最大. 题解:记录每个点的深度,再根据根节点的深度和逐层推导出其他点的深度和. 我用的是BFS #include <stdio.h> #include <string.h> #include <iostream> #include <queue> using namespace std; typedef long long ll; int

【poj3107】 Godfather (树的重心)

Description Last years Chicago was full of gangster fights and strange murders. The chief of the police got really tired of all these crimes, and decided to arrest the mafia leaders. Unfortunately, the structure of Chicago mafia is rather complicated

[poj3107]Godfather_树形dp_树的重心

Godfather poj-3107 题目大意:求树的重心裸题. 注释:n<=50000. 想法:我们尝试用树形dp求树的重心,关于树的重心的定义在题目中给的很明确.关于这道题,我们邻接矩阵存不下,用链式前向星存边,然后对于任选节点遍历,然后在回溯是进行最大值的最小值更新,之后就是一点显然的结论——树最多只有两个重心,而且这两个加点必须连边. 最后,附上丑陋的代码... ... #include <iostream> #include <cstdio> #include &l

POJ 3107 Godfather

Godfather 时限:2000ms Description Last years Chicago was full of gangster fights and strange murders. The chief of the police got really tired of all these crimes, and decided to arrest the mafia leaders. Unfortunately, the structure of Chicago mafia i

poj 3107 Godfather (树形dp)

Godfather Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 5064   Accepted: 1769 Description Last years Chicago was full of gangster fights and strange murders. The chief of the police got really tired of all these crimes, and decided to