POJ 1733 Parity game (并查集)

Parity game

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6816   Accepted: 2636

Description

Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You choose a continuous subsequence (for example the subsequence from the third to the fifth digit inclusively) and ask him, whether this subsequence contains even or odd number of ones. Your friend answers your question and you can ask him about another subsequence and so on. Your task is to guess the entire sequence of numbers.

You suspect some of your friend‘s answers may not be correct and you want to convict him of falsehood. Thus you have decided to write a program to help you in this matter. The program will receive a series of your questions together with the answers you have received from your friend. The aim of this program is to find the first answer which is provably wrong, i.e. that there exists a sequence satisfying answers to all the previous questions, but no such sequence satisfies this answer.

Input

The first line of input contains one number, which is the length of the sequence of zeroes and ones. This length is less or equal to 1000000000. In the second line, there is one positive integer which is the number of questions asked and answers to them. The number of questions and answers is less or equal to 5000. The remaining lines specify questions and answers. Each line contains one question and the answer to this question: two integers (the position of the first and last digit in the chosen subsequence) and one word which is either `even‘ or `odd‘ (the answer, i.e. the parity of the number of ones in the chosen subsequence, where `even‘ means an even number of ones and `odd‘ means an odd number).

Output

There is only one line in output containing one integer X. Number X says that there exists a sequence of zeroes and ones satisfying first X parity conditions, but there exists none satisfying X+1 conditions. If there exists a sequence of zeroes and ones satisfying all the given conditions, then number X should be the number of all the questions asked.

Sample Input

10
5
1 2 even
3 4 odd
5 6 even
1 6 even
7 10 odd

Sample Output

3

和上一题很类似,但是这题给的范围太大,数组开不下,所以直接用map映射一下,还有个性质就是  奇数+奇数=偶数 奇数+偶数=奇数 偶数+偶数=偶数。括号打偏了WA了一发,囧
#include <iostream>
#include <cstdio>
#include <string>
#include <queue>
#include <vector>
#include <map>
#include <algorithm>
#include <cstring>
#include <cctype>
#include <cstdlib>
#include <cmath>
#include <ctime>
using    namespace    std;

map<int,int>    ROOT;
map<int,int>    SUM;
int    N,M,ANS;
bool    FLAG;

int    find_father(int);
void    unite(int,int,int);
int    main(void)
{
    int    x,y,w;
    char    box[10];

    while(scanf("%d%d",&N,&M) != EOF)
    {
        ROOT.clear();
        SUM.clear();
        FLAG = false;
        for(int i = 1;i <= M;i ++)
        {
            scanf("%d%d%s",&x,&y,box);
            y ++;
            if(FLAG)
                continue;
            w = box[0] == ‘e‘ ? 0 : 1;
            unite(x,y,w);
            if(FLAG)
                ANS = i - 1;
        }
        if(!FLAG)
            ANS = M;
        printf("%d\n",ANS);
    }

    return    0;
}

int    find_father(int n)
{
    if(!ROOT[n])
        return    n;
    int    temp = ROOT[n];
    ROOT[n] = find_father(ROOT[n]);
    SUM[n] = (SUM[n] + SUM[temp]) % 2;
    return    ROOT[n];
}

void    unite(int x,int y,int w)
{
    int    fx = find_father(x);
    int    fy = find_father(y);

    if(fx == fy)
    {
        if((SUM[x] + 2 - SUM[y]) % 2 != w)
            FLAG = true;
        return    ;
    }
    if(fx < fy)
    {
        ROOT[fx] = fy;
        SUM[fx] = (-SUM[x] + w + SUM[y]) % 2;
    }
    else
    {
        ROOT[fy] = fx;
        SUM[fy] = (-SUM[y] - w + SUM[x]) % 2;
    }
}
时间: 2024-10-11 22:29:57

POJ 1733 Parity game (并查集)的相关文章

poj 1733 Parity game 并查集 离散化

点击打开链接题目链接 Parity game Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 6249   Accepted: 2413 Description Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You cho

poj 1733(带权并查集)

题意:有n个结点,给出了q个操作,操作是a b string表示结点a到结点b的和是奇数或偶数,输出x(前x个操作都是正确的). 题解:带权并查集经典题,因为结点可能有10,000,000,000个,所以需要离散化,不用的点就不考虑了.因为要a加到b,如果a==b无法找到各自的根节点并判断是否要合并,所以其实是mp[a - 1]到mp[b]并入集合.另外需要注意结点是有顺序的,父亲结点要大于等于子节点,这样判断才不会出错,所以合并时要考虑两个根结点的大小有不同关系式. #include <std

Parity game POJ - 1733 带权并查集

#include<iostream> #include<algorithm> #include<cstdio> using namespace std; const int N=10010<<1; struct node { int l,r,ans; } q[N]; int a[N],fa[N],d[N],n,m,t_n; int get(int x) { if (x==fa[x]) return x; int root=get(fa[x]); d[x]^=

poj 1733带权并查集

L - Parity game Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u Submit Status Description Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You ch

poj 1733 Parity game【哈希+并查集】

这道题题意我不想说了,但是有一个条件必须的说,就是1-2其实是0-2这条边,3-4是2-4这条边,但是困惑了好久,其他就是哈希给他一个地址 ,然后把注解看下方 #include <stdio.h> #include <string.h> #define maxx 10001 int par[maxx]; int rank[maxx]; void init() { for(int i=0;i<=maxx;i++) { rank[i]=0; par[i]=i; } } int f

[2016-03-18][POJ][1733][Parity game]

时间:2016-03-18 09:55:52 星期五 题目编号:[2016-03-18][POJ][1733][Parity game] 题目大意:给定若干的区间范围内的数字的和,问从哪句开始是错误的 分析: 带权并查集 区间长度高达1000000000显然不可能直接建立数组,但是发现询问只有5000次,也就是最多出现了5000*2个点,离散化就可以解决问题 relation[i] i为区间的左端点,fa[i]为区间的右端点,relation[i]维护(i,fa[i])这段区间的和的奇偶状态,0

POJ 2524 Ubiquitous Religions (幷查集)

Ubiquitous Religions Time Limit: 5000MS   Memory Limit: 65536K Total Submissions: 23090   Accepted: 11378 Description There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in findi

[ACM] POJ 3295 Ubiquitous Religions (并查集)

Ubiquitous Religions Time Limit: 5000MS   Memory Limit: 65536K Total Submissions: 23093   Accepted: 11379 Description There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in findi

poj 1456 Supermarket (贪心+并查集)

# include <stdio.h> # include <algorithm> # include <string.h> using namespace std; int fa[10010]; struct node { int p; int d; }; struct node a[10010]; bool cmp(node a1,node a2)//利润从大到小 { return a1.p>a2.p; } int find(int x) { if(fa[x]