1093. Count PAT's (25)想法题吧,算是排列组合吧

1093. Count PAT‘s (25)

时间限制

120 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CAO, Peng

The string APPAPT contains two PAT‘s as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT‘s contained in the string.

Input Specification:

Each input file contains one test case. For each case, there is only one line giving a string of no more than 105 characters containing only P, A, or T.

Output Specification:

For each test case, print in one line the number of PAT‘s contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:

APPAPT

Sample Output:

2

提交代码

#include<iostream>
#include<cstring>
#include<string>
#include<cmath>
#include<map>
#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
const int maxn=200000;
const int inf=2100000000;
long long  mod=1000000007;
char s[maxn];
int a[maxn];
int b[maxn];
int main()
{
    int n,m,i,k,t,j;
    scanf("%s",s);
    n=strlen(s);
    long long  ans=0;
    int num=0;
    int cnt=0,cnt2=0;
    //统计A前面的P的个数
    for(i=0;i<n;i++)
    {
        if(s[i]=='P')num++;
        else if(s[i]=='A')
        {
            a[cnt++]=num;
        }

    }
    cnt2=cnt-1;num=0;//统计A后面的T的个数
    for(i=n-1;i>=0;i--)
    {
        if(s[i]=='T')num++;
        else if(s[i]=='A')
        {
            b[cnt2--]=num;
        }
    }

    for(i=0;i<cnt;i++)//计算总和
    {
        ans+=a[i]*b[i]%mod;
        ans%=mod;
    }

    printf("%lld\n",ans%mod);
    return 0;
}

1093. Count PAT's (25)想法题吧,算是排列组合吧

时间: 2024-10-10 10:18:46

1093. Count PAT's (25)想法题吧,算是排列组合吧的相关文章

1093. Count PAT&#39;s (25)

The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters. Now given any string, you are supposed to tell the numb

PAT (Advanced Level) 1093. Count PAT&#39;s (25)

预处理每个位置之前有多少个P,每个位置之后有多少个T. 对于每个A,贡献的答案是这个A之前的P个数*这个A之后T个数. #include<cstdio> #include<cstring> long long MOD=1e9+7; const int maxn=1e5+10; long long dp1[maxn],dp2[maxn]; char s[maxn]; int main() { scanf("%s",s); memset(dp1,0,sizeof d

1093. Count PAT&#39;s (25)【计数】——PAT (Advanced Level) Practise

题目信息 1093. Count PAT's (25) 时间限制120 ms 内存限制65536 kB 代码长度限制16000 B The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th c

PAT Advanced 1093 Count PAT&#39;s (25分)

The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters. Now given any string, you are supposed to tell the numb

pat1093. Count PAT&#39;s (25)

1093. Count PAT's (25) 时间限制 120 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CAO, Peng The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3r

1093 Count PAT&#39;s

1093 Count PAT's The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters. Now given any string, you are supposed

A1093. Count PAT&#39;s (25)

The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters. Now given any string, you are supposed to tell the numb

HDU 4372 Count the Buildings(组合数学-斯特林数,组合数学-排列组合)

Count the Buildings Problem Description There are N buildings standing in a straight line in the City, numbered from 1 to N. The heights of all the buildings are distinct and between 1 and N. You can see F buildings when you standing in front of the

【LeetCode每天一题】Permutations(排列组合)

Given a collection of distinct integers, return all possible permutations. Example: Input: [1,2,3] Output: [ [1,2,3], [1,3,2], [2,1,3], [2,3,1], [3,1,2], [3,2,1] ]思路 对于排列组合问题首先应该想到使用递归思想来解决.另外还有一种非递归的解决办法. 解决代码 递归方式 图示步骤 解决代码 1 class Solution(object)