浙大pat1039 Course List for Student(25 分)

1039 Course List for Student(25 分)

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students N?i?? (≤200) are given in a line. Then in the next line, N?i?? student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student‘s name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

作者: CHEN, Yue

单位: 浙江大学

时间限制: 600 ms

内存限制: 64 MB

代码长度限制: 16 KB

题解:这道题就是考差哈希存储 如果暴力肯定过不了,我用的c++自带的map,最后一个测试点过不了,看了网上的大佬基本都用了哈希算法,我当时怕哈希冲突就没用这个,但是网上看到还是可以设计好的哈希函数来避免冲突的

比如这个:

int getID(string name){
    int id = 0;
    for(int i=0; i<3; i++){
        id = id*26+(name[i]-‘A‘);
    }
    id = id * 10 + (name[3] - ‘0‘);
    return id;
}

  当时主要是怕序列问题 比如ABC3 和BCA3的哈希很可能一样,但其实简单点的操作一下就行了。学会这种哈希算法。

(来源:https://blog.csdn.net/Q_smell/article/details/82284795)

下面贴一下我的没用哈希的map代码,虽然最后一个测试点没过,但是这种写法让我熟悉了map的操作(包括值为vector)有一定的借鉴意义。

#include <iostream>
#include <map>
#include <string.h>
#include <vector>
#include <algorithm>
using namespace std;
int main(int argc, char *argv[])
{
	vector<string>query;
	map<string,vector<int> > hash;
	int n,k;
	cin>>n>>k;
	for(int i=0;i<k;i++)
	{
		int n1,k1;
		cin>>n1>>k1;
		for(int j=0;j<k1;j++)
		{
			string s;
			cin>>s;
			hash[string(s)].push_back(n1);
		}
	}
	for(int i = 0;i<n;i++)
	{
		string tmp;
		cin>>tmp;

		query.push_back(tmp);
	}
	for(int  i=0;i<n;i++)
	{
		int num = hash[query[i]].size();
		sort(hash[query[i]].begin(),hash[query[i]].end());
		cout<<query[i]<<" "<<num;
		for(int j=0;j<num;j++)
		{
			cout<<" "<<hash[query[i]][j];
		}
		cout<<endl;
	}
}

  

原文地址:https://www.cnblogs.com/SK1997/p/9581462.html

时间: 2024-10-06 23:06:36

浙大pat1039 Course List for Student(25 分)的相关文章

浙大pat1040 Longest Symmetric String(25 分)

1040 Longest Symmetric String(25 分) Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given Is PAT&TAP symmetric?, the longest symmetric sub-string is s PAT&TAP s, hence you must output 11. Inp

PAT Advanced 1039 Course List for Student (25分) (STL)

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query. Input Specification: Each input file

PAT1039. Course List for Student (25)

水题,但是oj有毒,内存用了1/4,没炸内存,vector也开的够大,莫名给我个段错误,好烦 不能存学生的名字,存了,最后一组测试就给一个段错误,烦 #include<bits/stdc++.h> using namespace std; const int maxn=180000; vector<short> v[maxn]; char s[10]; int convert(char c){ if(isdigit(c))return c-'0'; return c-'A'+10;

STL_A1039 Course List for Student (25 分)

https://pintia.cn/problem-sets/994805342720868352/problems/994805447855292416 #include<cstdio> #include<iostream> using namespace std; #include<vector> #include<algorithm> const int M=26*26*26*10+1; vector<int> selectCourse[M

【PAT甲级】1039 Course List for Student (25 分)(vector嵌套于map,段错误原因未知)

题意: 输入两个正整数N和K(N<=40000,K<=2500),分别为学生和课程的数量.接下来输入K门课的信息,先输入每门课的ID再输入有多少学生选了这门课,接下来输入学生们的ID.最后N次询问,输入学生的ID输出该学生选了多少们课,输出所选课程的数量,按照递增序输出课程的ID. trick: 第5个数据点出现段错误,把原本以map存学生对应ID再映射vector存储该学生所选课程改成vector嵌套在map内,就没有段错误的问题出现,疑似映射过程中指针漂移??? 代码: #define H

1047 Student List for Course (25 分)

1047 Student List for Course (25 分) Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses. Input Specification: E

1012 The Best Rank (25)(25 分)

1012 The Best Rank (25)(25 分) To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean ti

1020 月饼 (25 分)

题目链接:1020 月饼 (25 分) 这道题目逻辑方面比较简单,但是浙大的PAT往往考察细节,果不其然,因为变量类型的原因,一个测试点没过. 特别注意,题目中说种类数N和需求量D为正整数,其它变量则为正数,所以这里的其它变量类型应当是double型. #include <bits/stdc++.h> using namespace std; struct Node { double num; //注意题目中库存为正数,没有说整数 double money; //注意题目中总价为正数,没有说整

PAT 甲级 1083 List Grades (25 分)

1083 List Grades (25 分) Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval. I