POJ 3522 Slim Span

Given an undirected weighted graph G , you should find one of spanning trees specified as follows.

The graph G is an ordered pair (VE) , where V is a set of vertices {v1v2,..., vn} and E is
a set of undirected edges {e1e2,..., em} . Each edge eE has
its weight w(e) .

A spanning tree T is a tree (a connected subgraph without cycles) which connects all the n vertices with n - 1 edges. The slimness of
a spanning tree T is defined as the difference between the largest weight and the smallest weight among the n - 1 edges of T .

For example, a graph G in Figure 5(a) has four vertices {v1v2v3v4} and five undirected edges {e1e2e3e4e5} .
The weights of the edges are w(e1) = 3 , w(e2) = 5 , w(e3) = 6 , w(e4)
= 6 , w(e5) = 7 as shown in Figure 5(b).

=6in 

There are several spanning trees for G . Four of them are depicted in Figure 6(a)∼(d). The spanning tree Ta in Figure 6(a) has three edges whose weights are 3, 6 and 7. The largest
weight is 7 and the smallest weight is 3 so that the slimness of the tree Ta is 4. The slimnesses of spanning trees Tb , Tc and Td shown
in Figure 6(b), (c) and (d) are 3, 2 and 1, respectively. You can easily see the slimness of any other spanning tree is greater than or equal to 1, thus the spanning tree Td in Figure 6(d) is one of the slimmest
spanning trees whose slimness is 1.

Your job is to write a program that computes the smallest slimness.

Input

The input consists of multiple datasets, followed by a line containing two zeros separated by a space. Each dataset has the following format.

nm

a1b1w1

ambmwm

Every input item in a dataset is a non-negative integer. Items in a line are separated by a space.

n is the number of the vertices and m the number of the edges. You can assume 2n100 and 0mn(n -
1)/2 . ak and bk(k = 1,..., m)are positive integers less than or equal to n ,
which represent the two vertices vak and vbk connected by the k -th edge ek . wk is
a positive integer less than or equal to 10000, which indicates the weight of ek . You can assume that the graph G = (VE) is simple, that is, there are no
self-loops (that connect the same vertex) nor parallel edges (that are two or more edges whose both ends are the same two vertices).

Output

For each dataset, if the graph has spanning trees, the smallest slimness among them should be printed. Otherwise, `-1‘ should be printed. An output should not contain extra characters.

Sample Input

4 5
1 2 3
1 3 5
1 4 6
2 4 6
3 4 7
4 6
1 2 10
1 3 100
1 4 90
2 3 20
2 4 80
3 4 40
2 1
1 2 1
3 0
3 1
1 2 1
3 3
1 2 2
2 3 5
1 3 6
5 10
1 2 110
1 3 120
1 4 130
1 5 120
2 3 110
2 4 120
2 5 130
3 4 120
3 5 110
4 5 120
5 10
1 2 9384
1 3 887
1 4 2778
1 5 6916
2 3 7794
2 4 8336
2 5 5387
3 4 493
3 5 6650
4 5 1422
5 8
1 2 1
2 3 100
3 4 100
4 5 100
1 5 50
2 5 50
3 5 50
4 1 150
0 0

Sample Output

1
20
0
-1
-1
1
0
1686 

50

题意:就是要你求出所有生成树的最大边减去最小边的最小值

思路:可以用kruskal的思想。每次连通一棵树,再求出该树的最大边减去最小边

AC代码:
#include<stdio.h>
#include<algorithm>
using namespace std;
#define maxn  105
const int maxnb = maxn*(maxn-1)/2;
int n,m;
int f[maxn];
struct p
{
    int x,y,w;
}num[maxnb];

int find(int x)
{
    if(x!=f[x])
        f[x]=find(f[x]);
    return f[x];
}
bool cmp(p a,p b)
{
    return a.w<b.w;
}

int kruskal(int a)
{
    int i,tot=n,ans=-1;
    for(i=1;i<=n;i++)
        f[i]=i;
    for(i=a;i<m;i++)
    {
        int u=find(num[i].x);
        int v=find(num[i].y);
        if(u==v)
            continue;
        f[u]=v;
        tot--;
        if(tot==1)
        {
            ans=num[i].w;
            break;
        }
    }
    return ans-num[a].w;
}
int main()
{
    while(scanf("%d %d",&n,&m)!=EOF)
    {
        if(n==0&&m==0)break;
        int i,j,sum;
        for(i=0;i<m;i++)
            scanf("%d%d%d",&num[i].x,&num[i].y,&num[i].w);
        sort(num,num+m,cmp);
        sum=kruskal(0);
        if(sum<0)
        {
            printf("-1\n");
            continue;
        }
        for(i=1;i<m;i++)
        {
            int ans=kruskal(i);
            if(ans<0)break;
            if(sum>ans)
                sum=ans;
        }
        printf("%d\n",sum);
    }
    return 0;
}

时间: 2024-12-19 16:00:39

POJ 3522 Slim Span的相关文章

poj 3522 Slim Span 最大边减最小边最小的生成树

枚举最小边进行kruskal. #include <cstdio> #include <algorithm> using namespace std; #define maxn 120 #define maxm 10000 struct edge { int u,v,w; }e[maxm]; int p[maxn],n,m; int find(int x) { if(x==p[x]) return x; return p[x]=find(p[x]); } void link(int

POJ 3522 Slim Span (Kruskal +枚举 边权差最小的生成树)

Slim Span Time Limit: 5000MS Memory Limit: 65536K Total Submissions: 6685 Accepted: 3544 Description Given an undirected weighted graph G, you should find one of spanning trees specified as follows. The graph G is an ordered pair (V, E), where V is a

POJ 3522 ——Slim Span——————【最小生成树、最大边与最小边最小】

Slim Span Time Limit: 5000MS   Memory Limit: 65536K Total Submissions: 7102   Accepted: 3761 Description Given an undirected weighted graph G, you should find one of spanning trees specified as follows. The graph G is an ordered pair (V, E), where V 

POJ 3522 Slim Span【枚举+克鲁斯卡尔求最小生成树】

Slim Span Time Limit: 5000MS Memory Limit: 65536K Total Submissions: 7365 Accepted: 3909 Description Given an undirected weighted graph G, you should find one of spanning trees specified as follows. The graph G is an ordered pair (V, E), where V is a

UVa1395 &amp;&amp; POJ 3522 Slim Span

UVa POJ Description 求苗条度最小的生成树 苗条度指该生成树的最大边 - 最小边 Algorithm Kruskal变形 先sort 然后枚举最小边 构建最小生成树 Hint UVa JAVA的RE 不知道为何= = POJ的JAVA才1.5 λ表达式是JAVA 1.8才有的 然后本人才疏学浅 除了λ表达式以外不会写自定义sort比较 所以CE = = C++就过了 会了C++ 的INF写法 #include <climits> 这样就有 INT_MAX这个常量了 Code

POJ 3522 Slim Span 最小生成树,暴力 难度:0

kruskal思想,排序后暴力枚举从任意边开始能够组成的最小生成树 #include <cstdio> #include <algorithm> using namespace std; const int maxn = 101; const int maxe = maxn * maxn / 2; struct edge{ int f,t,c; bool operator <(edge e2)const { return c<e2.c; } }e[maxe]; int

POJ 3522 Slim Span(最小生成树)

题意:给定一个n个点m条边的无向图,找一颗苗条度(最大边减最小边)最小的生成树. 思路:假设苗条度最小的这棵树的最小边为a,若要使苗条度最小,答案一定是以a为最小边的一颗最小生成树,所以可以考虑枚举最小边,计算出苗条度并更新答案. #include<cstdio> #include<cstring> #include<cmath> #include<cstdlib> #include<iostream> #include<algorithm

POJ 3522 Slim Span (并查集 + 枚举 + kruskal)

链接:点击打开链接 题目好长, 而且还有图片,所以就不复制粘贴过来了,这道题的大意是: 一棵树T(连通无环子图)将用n-1条边连接原图的所有的n个顶点,生成的生成树的最大权值边与最小权值边的差(称"苗条值")尽量小,找出这个最小的苗条值: 思路: 用kruskal枚举: 首先对每条边的权值从小到大进行排序: 枚举每条边为最小边生成最小生成树,并计算这样的生成树的苗条值,枚举玩所有的情况就可以求出苗条值: 代码解析如下: #include <iostream> #includ

uva 1395 - Slim Span poj 3522 Slim Span(最小生成树算法)

最近学习了一下 最小生成树 算法. 所谓最小生成树算法,就是给出一个连通图g[ maxn ][ maxn  ], 找出这个连通图的边权和最小的生成图(树). 可以实现这个目的的算法,我叫它最小生成树算法.kruskal算法就是我学到的一种实现这种功能的算法. 对于kruskal算法的描述以及简单的证明在刘汝佳第二版上已经说得够明白 本题就是求 最小生成树 里面的 最大边权和最小边权 相差最小的最小生成树. #include<cstdio> #include<cstring> #in