Uva401Palindromes

  Palindromes 

A regular palindrome is a string of numbers or letters that is the same forward as backward. For example, the string "ABCDEDCBA" is a palindrome because it is the same when the string is read from left to right as when the string is read from right to left.

A mirrored string is a string for which when each of the elements of the string is changed to its reverse (if it has a reverse) and the string is read backwards the result is the same as the original string. For example, the string "3AIAE" is a mirrored string because "A" and "I" are their own reverses, and "3" and "E" are each others‘ reverses.

A mirrored palindrome is a string that meets the criteria of a regular palindrome and the criteria of a mirrored string. The string "ATOYOTA" is a mirrored palindrome because if the string is read backwards, the string is the same as the original and because if each of the characters is replaced by its reverse and the result is read backwards, the result is the same as the original string. Of course, "A", "T", "O", and "Y" are all their own reverses.

A list of all valid characters and their reverses is as follows.

Character Reverse Character Reverse Character Reverse
A A M M Y Y
B   N   Z 5
C   O O 1 1
D   P   2 S
E 3 Q   3 E
F   R   4  
G   S 2 5 Z
H H T T 6  
I I U U 7  
J L V V 8 8
K   W W 9  
L J X X    

Note that O (zero) and 0 (the letter) are considered the same character and therefore ONLY the letter "0" is a valid character.

Input

Input consists of strings (one per line) each of which will consist of one to twenty valid characters. There will be no invalid characters in any of the strings. Your program should read to the end of file.

Output

For each input string, you should print the string starting in column 1 immediately followed by exactly one of the following strings.

STRING CRITERIA
" -- is not a palindrome." if the string is not a palindrome and is not a mirrored string
" -- is a regular palindrome." if the string is a palindrome and is not a mirrored string
" -- is a mirrored string." if the string is not a palindrome and is a mirrored string
" -- is a mirrored palindrome." if the string is a palindrome and is a mirrored string

Note that the output line is to include the -‘s and spacing exactly as shown in the table above and demonstrated in the Sample Output below.

In addition, after each output line, you must print an empty line.

Sample Input

NOTAPALINDROME
ISAPALINILAPASI
2A3MEAS
ATOYOTA

Sample Output

NOTAPALINDROME -- is not a palindrome.

ISAPALINILAPASI -- is a regular palindrome.

2A3MEAS -- is a mirrored string.

ATOYOTA -- is a mirrored palindrome.

Miguel Revilla 2001-04-16 
 
 

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int namx = 30;

bool is_mirrored(char a, char b)
{
    if((a == ‘E‘ && b == ‘3‘) || (a == ‘3‘ && b == ‘E‘))
       return true;
    else if((a == ‘L‘ && b == ‘J‘) || (a == ‘J‘ && b == ‘L‘))
        return true;
    else if((a == ‘S‘ && b == ‘2‘) || (a == ‘2‘ && b == ‘S‘))
        return true;
    else if((a == ‘Z‘ && b == ‘5‘) || (a == ‘5‘ && b == ‘Z‘))
        return true;
    else if(a == b)
    {
        if(a == ‘A‘ || a == ‘H‘ || a == ‘I‘ || a == ‘M‘ || a == ‘O‘
           || a == ‘T‘ || a == ‘U‘ || a == ‘V‘ || a == ‘W‘ || a == ‘X‘
           || a == ‘Y‘ || a == ‘1‘ || a == ‘8‘)
        {
            return true;
        }
    }
    else
        return false;
}

int main()
{
    char str[namx];

    while(scanf("%s%*c", str) != EOF)
    {
        int len = strlen(str);
        //printf("%d\n", len);
        bool mark = true;
        bool tag = true;
        for(int i = 0; i <= len / 2; ++i)
        {
            if(str[i] != str[len-i-1])
            {
                mark = false;
                //printf("%c == %c %d\n", str[i], str[len-i-1], len-i-1);
                break;
            }
        }

        for(int i = 0; i <= len / 2; ++i)
        {
            if(!is_mirrored(str[i], str[len-i-1]))
            {
                tag = false;
                //printf("%c == %c %d\n", str[i], str[len-i-1], len-i-1);
                break;
            }
        }
        if(mark == false && tag == false)
            printf("%s -- is not a palindrome.\n", str);

        else if(mark == false && tag == true)
            printf("%s -- is a mirrored string.\n", str);

        else if(mark == true && tag == false)
            printf("%s -- is a regular palindrome.\n", str);

        else
            printf("%s -- is a mirrored palindrome.\n", str);
        printf("\n");

    }
    return 0;
}


一个空格, PE一晚上,淡定淡定,不要太大压力

时间: 2024-10-09 20:17:18

Uva401Palindromes的相关文章

紫书第三章 数组和字符串

1  序 系统的整理下第三章的学习笔记.例题代码是在未看书本方法前自己尝试并AC的代码,不一定比书上的标程好:习题除了3-8百度了求解方法,其它均独立完成后,会适当查阅网上资料进行整理总结.希望本博文方便自己日后复习的同时,也能给他人带来点有益的帮助(建议配合紫书--<算法竞赛入门经典(第2版)>阅读本博客).有不足或错误之处,欢迎读者指出. 2  例题 2.1  UVa272--Tex Quotes #include <stdio.h> int main() { bool log