NBUT 1220 SPY

  • [1220] SPY

  • 时间限制: 1000 ms 内存限制: 131072 K
  • 问题描述
  • The
    National Intelligence Council of X Nation receives a piece of credible information that Nation Y will send spies to steal Nation X’sconfidential
    paper. So the commander of The
    National Intelligence Council take measures immediately, he will investigate
    people who will come into NationX. At the same time, there are two List in the Commander’s hand, one is full of spies that Nation Y will send to Nation X, and the other one is full of spies that Nation X has sent to Nation Y before. There may be some overlaps
    of the two list. Because the spy may act two roles at the same time, which means that he may be the one that is sent from Nation X to Nation Y, we just call this type a “dual-spy”. So Nation Y may send “dual_spy” back to Nation X, and it is obvious now that
    it is good for Nation X, because “dual_spy” may bring back NationY’s confidential paper without worrying to be detention by NationY’s frontier So
    the commander decides to seize those that are sent by NationY, and let the ordinary people and the “dual_spy” in at the same time .So can you decide a list that should be caught by the Commander?

    A:the list contains that will come to the NationX’s frontier.

    B:the list contains spies that will be sent by Nation Y.

    C:the list contains spies that were sent to NationY before.

  • 输入
  • There are several test cases.

    Each test case contains four parts, the first part contains 3 positive integers A, B, C, and A is the number which will come into the frontier. B is the number that will be sent by Nation Y, and C is the number that NationX has sent to NationY before.

    The second part contains A strings, the name list of that will come into the frontier.

    The second part contains B strings, the name list of that are sent by NationY.

    The second part contains C strings, the name list of the “dual_spy”.

    There will be a blank line after each test case.

    There won’t be any repetitive names in a single list, if repetitive names appear in two lists, they mean the same people.

  • 输出
  • Output the list that the commander should caught (in the appearance order of the lists B).if no one should be caught, then , you should output “No enemy spy”.
  • 样例输入
  • 8 4 3
    Zhao Qian Sun Li Zhou Wu Zheng Wang
    Zhao Qian Sun Li
    Zhao Zhou Zheng
    2 2 2
    Zhao Qian
    Zhao Qian
    Zhao Qian
    
  • 样例输出
  • Qian Sun Li
    No enemy spy
  • 提示
  • 来源
  • 辽宁省赛2010

    题目意思有点难懂,看了两遍才理解,是说a国家得到情报说b国家要派间谍过来a国家,现在要捕抓‘真正的间谍’。此题为多组输入,输入数据有四行:第一行是三个整数A,B,C;第二行输入A个字符串,表示即将进入a国家的人名单;第三行输入B个字符串,表示b国家派出的间谍名单(其中可能有一些不是真正的间谍——即a国家在此之前已经派到b国家的间谍);第四行输入C个字符串,表示a国家在此之前已经派到b国家的间谍名单。要求在同一行输出所有的需要捕抓的真正的间谍名单,每个人名中间有一个空格(注意:末尾不能有空格,这题最坑的就是格式控制了,我PE了好几次才过)。如果A串中不存在真正的间谍,则输出“No
    enemy spy”。

    #include <algorithm>
    #include <iostream>
    #include <cstring>
    #include <cstdio>
    using namespace std;
    const int mx = 1e3 + 5;
    
    int a,b,c;
    char pe[mx][20],spy[mx][20],dpy[mx][20];
    
    int main() {
        while(~scanf("%d%d%d",&a,&b,&c)) {
            for(int i=0; i<a; i++) {
                scanf("%s",pe[i]);
            }
            for(int i=0; i<b; i++) {
                scanf("%s",spy[i]);
            }
            for(int i=0; i<c; i++) {
                scanf("%s",dpy[i]);
                for(int j=0; j<a; j++)
                    if(strcmp(dpy[i],pe[j])==0) {
                        strcpy(pe[j],"***");
    //                    printf("[%d,%d]     ",i,j);
                        break;
                    }
            }
            int cnt=0;
            for(int i=0; i<b; i++) {
                for(int j=0; j<a; j++)
                    if(strcmp(spy[i],pe[j])==0) {
                        cnt++;
                        if(cnt==1)
                            printf("%s",spy[i]);
                        else
                            printf(" %s",spy[i]);
    
                        continue;
                    }
    
            }
            if(!cnt)
                printf("No enemy spy");
            puts("");
    //        for(int i=0; i<a; i++)
    //            puts(pe[i]);
        }
        return 0;
    }
    

    RunID

    User


    Problem

    All     A - Dinner     B - You are my brother
         C - Time     D - SPY     
    E - Intermediary     F - English Game     
    G - Friends number     H - Happiness Hotel     
    I - NEW RDSP MODE I     J - Boxes in a Line     
    K - Funny Car Racing   D
    - SPY


    Result


    Memory

    (KB)


    Time

    (ms)


    Language


    Length

    (Bytes)

     
    4441548 ZXPxx D
    Accepted
    280 0
    G++
    1190
    4441510 ZXPxx D
    Presentation error
       
    G++
    1149
    4440963 ZXPxx D
    Presentation error
       
    G++
    1094
    4440913 ZXPxx D
    Presentation error
       
    G++
    1088
    4440905 ZXPxx D
    Presentation error
       
    G++
    1070

    好忧伤,PE了这么多次。。。

版权声明:本文为博主原创文章,未经博主允许不得转载。

时间: 2024-08-04 16:04:56

NBUT 1220 SPY的相关文章

SPY

The National Intelligence Council of X Nation receives a piece of credible information that Nation Y will send spies to steal Nation X's confidential paper. So the commander of The National Intelligence Council take measures immediately, he will inve

Uva 1220,Hali-Bula 的晚会

题目链接:https://uva.onlinejudge.org/external/12/1220.pdf 题意: 公司n个人,形成一个数状结构,选出最大独立集,并且看是否是唯一解. 分析: d(i) 是 节点 i 的最优值, i 只有两种决策,就是选和不选. 转移方程: d(i) = max {1+Σ1d(j),Σ2d(j)}; Σ1是所有孙子节点,Σ2是所有儿子节点. 那么状态的定义d(i,0),节点 i 不选,d(i,1),节点 i 选. 那么状态转移方程就是: 是否唯一 f(v,0) =

hdu 4274 Spy&amp;#39;s Work(水题)

Spy's Work Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1266    Accepted Submission(s): 388 Problem Description I'm a manager of a large trading company, called ACM, and responsible for the

A Spy in the Metro

Description Secret agent Maria was sent to Algorithms City to carry out an especially dangerous mission. After several thrilling events we find her in the first station of Algorithms City Metro, examining the time table. The Algorithms City Metro con

Party at Hali-Bula UVA - 1220 (树形dp)

Party at Hali-Bula UVA - 1220 题意:选一个公司的人去参加晚会,要求不能选有直接上下级关系的人,问最多选多少人去,并判断方案是否唯一. 树的最大独立集,并判断是否唯一. d[u][1]表示选u,d[u][0]表示不选u f[u][1]==1表示选u的情况下唯一,f[u][1]==0表示不唯一 f[u][0]为不选u的情况下的唯一性 1 #include <cstdio> 2 #include <bits/stdc++.h> 3 using namespa

HLJU 1220: AC100天 (枚举)

1220: AC100天 Time Limit: 1 Sec  Memory Limit: 128 MB Submit: 89  Solved: 12 [Submit][Status][Web Board] Description 迪迪给自己定了一个雄伟的目标:连续100天每天坚持AC一道题目.100天过去了,迪迪查看自己的AC记录发现有N天由于贪玩忘记AC了.于是迪迪软磨硬泡.强忍着田田歧视的眼神从田田那里要来M张"补AC卡".每张"补AC卡"都能够补回一天的AC

UVa 1025 A Spy in the Metro(动态规划)

传送门 Description Secret agent Maria was sent to Algorithms City to carry out an especially dangerous mission. After several thrilling events we find her in the first station of Algorithms City Metro, examining the time table. The Algorithms City Metro

ACM: NBUT 1105 多连块拼图 - 水题 - 模拟

NBUT 1105  多连块拼图 Time Limit:1000MS     Memory Limit:65535KB     64bit IO Format: Practice Appoint description:  System Crawler  (Aug 12, 2016 9:32:14 AM) Description 多连块是指由多个等大正方形边与边连接而成的平面连通图形. -- 维基百科 给一个大多连块和小多连块,你的任务是判断大多连块是否可以由两个这样的小多连块拼成.小多连块只能

我翻译的第一本英文书《SPY Academy》

我翻译的第一本英文书<SPY Academy>...... 忘记了哪一天,下班回家走进小区的路上,见到了一本“小脏书”.这书不厚,全英文,四下没人就捡了起来.拂去了封面上的脚印,抖落了夹带的小石子.心想哪家掉的?还是抛弃了的?随便翻了几页后我就到家了. 2016年6月1日,因为想学英语,又苦于没有什么兴趣点,就找来这本“小脏书”翻译了起来.这也是我拾起了它的主要原因! 这本书的作者名叫Tracey West,美国儿童畅销书作家.之前没听说过,百度说她写过一本叫<海绵宝宝>的书...