POJ 1251 Jungle Roads (prim)

D - Jungle Roads

Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Submit Status Practice POJ 1251

Description


The
Head Elder of the tropical island of Lagrishan has a problem. A burst
of foreign aid money was spent on extra roads between villages some
years ago. But the jungle overtakes roads relentlessly, so the large
road network is too expensive to maintain. The Council of Elders must
choose to stop maintaining some roads. The map above on the left shows
all the roads in use now and the cost in aacms per month to maintain
them. Of course there needs to be some way to get between all the
villages on maintained roads, even if the route is not as short as
before. The Chief Elder would like to tell the Council of Elders what
would be the smallest amount they could spend in aacms per month to
maintain roads that would connect all the villages. The villages are
labeled A through I in the maps above. The map on the right shows the
roads that could be maintained most cheaply, for 216 aacms per month.
Your task is to write a program that will solve such problems.

Input

The input consists of one to 100 data sets, followed by a final line
containing only 0. Each data set starts with a line containing only a
number n, which is the number of villages, 1 < n < 27, and the
villages are labeled with the first n letters of the alphabet,
capitalized. Each data set is completed with n-1 lines that start with
village labels in alphabetical order. There is no line for the last
village. Each line for a village starts with the village label followed
by a number, k, of roads from this village to villages with labels later
in the alphabet. If k is greater than 0, the line continues with data
for each of the k roads. The data for each road is the village label for
the other end of the road followed by the monthly maintenance cost in
aacms for the road. Maintenance costs will be positive integers less
than 100. All data fields in the row are separated by single blanks. The
road network will always allow travel between all the villages. The
network will never have more than 75 roads. No village will have more
than 15 roads going to other villages (before or after in the alphabet).
In the sample input below, the first data set goes with the map above.

Output

The output is one integer per line for each data set: the minimum cost
in aacms per month to maintain a road system that connect all the
villages. Caution: A brute force solution that examines every possible
set of roads will not finish within the one minute time limit.

Sample Input

9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0

Sample Output

216
30此题输入有问题,再输入字符的时候,如果是scanf(“%c”)的话可能会RE,应该改为1s可以过得
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
const int inf=0x7fffffff;
int map[100][100];
int dis[100],vis[100];
int n;
int prim(int u)
{
    int sum=0;

    for(int i=1; i<=n; i++)
    {
        dis[i]=map[u][i];
    }
    vis[u]=1;
    for(int k=1; k<n; k++)
    {
        int tmin=inf;
        int temp;
        for(int j=1; j<=n; j++)
        {
            if(dis[j]<tmin&&!vis[j])
            {
                tmin=dis[j];
                temp=j;
            }
        }
        vis[temp]=1;
        sum+=tmin;
        for(int i=1; i<=n; i++)
        {
            if(dis[i]>map[temp][i]&&!vis[i])
                dis[i]=map[temp][i];
        }
    }
    return sum;
}
int main()
{

    while(scanf("%d",&n)!=EOF)
    {
        if(!n)
            break;
        getchar();
        memset(vis,0,sizeof(vis));
        memset(dis,0,sizeof(dis));
//        memset(map,0,sizeof(map));

        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=n; j++)
            {
                if(i==j)
                    map[i][j]=0;
                else
                    map[i][j]=inf;
            }
        }
        char c1,c2;
        int cnt,w;
            for(int i=1;i<n;i++){
                scanf("%1s %d",&c1,&cnt);
                int u=c1-‘A‘+1;
                for(int j=1;j<=cnt;j++){
                     scanf(" %1s %d",&c2,&w);
                     int v=c2-‘A‘+1;
                     map[u][v]=map[v][u]=min(w,map[u][v]);
                }
                getchar();
            }
        printf("%d\n",prim(1));

    }
    return 0;
}
				
时间: 2024-10-16 14:57:48

POJ 1251 Jungle Roads (prim)的相关文章

POJ 1251 Jungle Roads (最小生成树)

POJ 1251 Jungle Roads Description The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road

POJ 1251 Jungle Roads(最小生成树)

题意  有n个村子  输入n  然后n-1行先输入村子的序号和与该村子相连的村子数t  后面依次输入t组s和tt s为村子序号 tt为与当前村子的距离  求链接所有村子的最短路径 还是裸的最小生成树咯 #include<cstdio> #include<cstring> #include<algorithm> using namespace std; const int N=30,M=1000; int par[N],n,m,ans; struct edge{int u

hdu1301 Jungle Roads (Prim)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1301 依旧Prim............不多说了 1 #include<iostream> 2 #include<cstdio> 3 #include<algorithm> 4 5 using namespace std; 6 7 #define MAX 'Z'+5 8 #define inf 99999999 9 10 int map[MAX][MAX],node[MA

ZOJ 1406 POJ 1251 Jungle Roads 丛林中的道路,最小生成树,Kruskal算法

题目链接:ZOJ 1406 POJ 1251 Jungle Roads 丛林中的道路 Jungle Roads Time Limit: 2 Seconds      Memory Limit: 65536 KB The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some ye

[2016-04-09][POJ][1251][Jungle Roads]

时间:2016-04-09 00:02:24 星期六 题目编号:[2016-04-09][POJ][1251][Jungle Roads] 题目大意:给定n个城镇的若干条路及其每月维修的代价,问,在所有城市联通的情况下,最少需要多少维修费 分析: 保证边权最小,并且图联通-–>最小生成树 #include <algorithm> #include <cstring> #include <cstdio> using namespace std; int fa[30]

NYOJ 434 &amp;&amp; POJ 1251 Jungle Roads(最小生成树)

链接:click here 题意: 题目大意在相通n个岛屿的所有桥都坏了,要重修,重修每一个桥所用的时间不同,求重修使每个岛屿都间接或直接与其他岛屿相同时所用的的最短时间(只有修完一个桥后才可修下一个桥).简言之就是求最小生成树. 对于数据,数据输入的第一行n代表岛屿的个数,当为0是结束程序,接着n-1行开始时为这岛屿的编号,用大写字母表示,接着是一个整数m,表示与该岛屿连接的字典序大于该岛屿编号的个数,然后该行输入m对数据,每对数据的第一个字母表示与该岛屿连通的岛屿的编号,第二个数字表示要重修

POJ 1251 Jungle Roads(kruskal)

Submit Status Practice POJ 1251 Description The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the l

HDU 1815, POJ 2749 Building roads(2-sat)

HDU 1815, POJ 2749 Building roads 题目链接HDU 题目链接POJ 题意: 有n个牛棚, 还有两个中转站S1和S2, S1和S2用一条路连接起来. 为了使得任意牛棚两个都可以有道路联通,现在要让每个牛棚都连接一条路到S1或者S2. 有a对牛棚互相有仇恨,所以不能让他们的路连接到同一个中转站.还有b对牛棚互相喜欢,所以他们的路必须连到同一个中专站. 道路的长度是两点的曼哈顿距离. 问最小的任意两牛棚间的距离中的最大值是多少? 思路:二分距离,考虑每两个牛棚之间4种连

poj 2749 Building roads(2-sat)

Description Farmer John's farm has N barns, and there are some cows that live in each barn. The cows like to drop around, so John wants to build some roads to connect these barns. If he builds roads for every pair of different barns, then he must bui