(HDUStep 1.2.7)IBM Minus One(字符串运算)

题目:

IBM Minus One

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3943 Accepted Submission(s): 1519
 

Problem Description

You may have heard of the book ‘2001 - A Space Odyssey‘ by Arthur C. Clarke, or the film of the same name by Stanley Kubrick. In it a spaceship is sent from Earth to Saturn. The crew is put into stasis for the long flight, only two men are awake, and the ship is controlled by the intelligent computer HAL. But during the flight HAL is acting more and more strangely, and even starts to kill the crew on board. We don‘t tell you how the story ends, in case you want to read the book for yourself :-)

After the movie was released and became very popular, there was some discussion as to what the name ‘HAL‘ actually meant. Some thought that it might be an abbreviation for ‘Heuristic ALgorithm‘. But the most popular explanation is the following: if you replace every letter in the word HAL by its successor in the alphabet, you get ... IBM.

Perhaps there are even more acronyms related in this strange way! You are to write a program that may help to find this out.


Input

The input starts with the integer n on a line by itself - this is the number of strings to follow. The following n lines each contain one string of at most 50 upper-case letters.


Output

For each string in the input, first output the number of the string, as shown in the sample output. The print the string start is derived from the input string by replacing every time by the following letter in the alphabet, and replacing ‘Z‘ by ‘A‘.

Print a blank line after each test case.


Sample Input

2
HAL
SWERC


Sample Output

String #1
IBM

String #2
TXFSD

 

Source

Southwestern Europe 1997, Practice


Recommend

Ignatius.L

题目分析:

简单的字符串运算。例如: ‘B‘ = ‘A‘+1 .....将给出的字符串中的每个字符加1后输出即可。

代码如下:

/*
 * h.cpp
 *
 *  Created on: 2015年1月28日
 *      Author: Administrator
 */
#include <iostream>
#include <cstdio>

using namespace std;

int main(){
	int n;
	scanf("%d",&n);

	int i;
	for(i = 0 ; i < n ; ++i){
		string str;
		cin >> str;

		int length = str.length();
		int j;
		for(j = 0 ; j < length ; ++j){
			if(str[j] == ‘Z‘){
				str[j] = ‘A‘;
			}else{
				str[j] += 1;
			}
		}

		cout << "String #" << (i+1) <<endl;
		cout<<str<<endl<<endl;
	}

	return 0;
}
时间: 2024-10-19 10:41:53

(HDUStep 1.2.7)IBM Minus One(字符串运算)的相关文章

IBM Minus One(water)

IBM Minus One Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 4475    Accepted Submission(s): 2349 Problem Description You may have heard of the book '2001 - A Space Odyssey' by Arthur C. Clarke

HDU 1328 IBM Minus One (水)

IBM Minus One Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 4036    Accepted Submission(s): 2104 Problem Description You may have heard of the book '2001 - A Space Odyssey' by Arthur C. Clark

JavaScript实现超大字符串运算减法

JavaScript实现超大字符串的相减,没有限制 原文:JavaScript实现超大字符串运算减法 源代码下载地址:http://www.zuidaima.com/share/1550463323638784.htm 源码截图: JavaScript实现超大字符串运算减法

HDU 1328 IBM Minus One

Problem Description You may have heard of the book '2001 - A Space Odyssey' by Arthur C. Clarke, or the film of the same name by Stanley Kubrick. In it a spaceship is sent from Earth to Saturn. The crew is put into stasis for the long flight, only tw

IBM Minus One

描述 You may have heard of the book '2001 - A Space Odyssey' by Arthur C. Clarke, or the film of the same name by Stanley Kubrick. In it a spaceship is sent from Earth to Saturn. The crew is put into stasis for the long flight, only two men are awake,

python 字符串,字符串运算,比较,索引,切片等

一:字符串: str作用:用来记录文本信息,字面值表示方法:用引号括起来的部分都是字符串. '' 单引号"" 双引号''' 三引号""" 三双引号单引号和双引号的区别:单引号的双引号不算结束符双引号内的单引号不算结束符三引号字符串的作用:三引号内可以包含单引号和双引号三引号字符串重的换行会自动转换为换行符'\n' 二:用转义序列代表特殊字符字符串字面值中用子字符反斜杠\后跟一些字符代表特殊的一个字符如: \' 代表一个单引号\" 代表双引号\n

ACM--字母增加--HDOJ 1328--IBM Minus One--字符串

HDOJ题目地址:传送门 IBM Minus One Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 5597    Accepted Submission(s): 2855 Problem Description You may have heard of the book '2001 - A Space Odyssey' by Ar

Python笔记004——字符串

字符串基本定义 1 字符串用引号引起来的(单引号,双引号,三双引号,三单引号) 三引号(三单或三双)支持多行,而单双引只能一行(但是可以加\n) 2 斜杠表转义(\",输出 “) 3 \b的含义 1 print('hello world') 2 print('hello world\bwujiadong')#删除前一个字符,后面字符往前进一个 [[email protected] ~]# python 1.py hello world hello worlwujiadong 字符串运算 加法运算

日常记录(c语言)--字符串实现大整数加法

运行环境:CentOs 64位--vim 最近在看<剑指offer>这本书,看了前面的关于面试的能力,顿时觉得自己的编程能力差得好远. 可能我对鲁棒的代码理解还不深,我觉得鲁棒应该就是代码可以应对各种不同的输入,都能有相应的处理,并给出相应的输出. 下面是我看了之后对之前做过的大整数加法做了一些完善,之前的只能实现对纯数字字符进行求和,甚至连对空指针的处理都没有,好惭愧.我会用注释来记录自己对此算法的理解. 1 #include <stdio.h> 2 #include <s