POJ 1006:Biorhythms 中国剩余定理

Biorhythms

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 121194   Accepted: 38157

Description

Some people believe that there are three cycles in a person‘s life that start the day he or she is born. These three cycles are the physical, emotional, and intellectual cycles, and they have periods of lengths 23, 28, and 33 days, respectively. There is one
peak in each period of a cycle. At the peak of a cycle, a person performs at his or her best in the corresponding field (physical, emotional or mental). For example, if it is the mental curve, thought processes will be sharper and concentration will be easier.

Since the three cycles have different periods, the peaks of the three cycles generally occur at different times. We would like to determine when a triple peak occurs (the peaks of all three cycles occur in the same day) for any person. For each cycle, you will
be given the number of days from the beginning of the current year at which one of its peaks (not necessarily the first) occurs. You will also be given a date expressed as the number of days from the beginning of the current year. You task is to determine
the number of days from the given date to the next triple peak. The given date is not counted. For example, if the given date is 10 and the next triple peak occurs on day 12, the answer is 2, not 3. If a triple peak occurs on the given date, you should give
the number of days to the next occurrence of a triple peak.

Input

You will be given a number of cases. The input for each case consists of one line of four integers p, e, i, and d. The values p, e, and i are the number of days from the beginning of the current year at which the physical, emotional, and intellectual cycles
peak, respectively. The value d is the given date and may be smaller than any of p, e, or i. All values are non-negative and at most 365, and you may assume that a triple peak will occur within 21252 days of the given date. The end of input is indicated by
a line in which p = e = i = d = -1.

Output

For each test case, print the case number followed by a message indicating the number of days to the next triple peak, in the form:

Case 1: the next triple peak occurs in 1234 days.

Use the plural form ``days‘‘ even if the answer is 1.

Sample Input

0 0 0 0
0 0 0 100
5 20 34 325
4 5 6 7
283 102 23 320
203 301 203 40
-1 -1 -1 -1

Sample Output

Case 1: the next triple peak occurs in 21252 days.
Case 2: the next triple peak occurs in 21152 days.
Case 3: the next triple peak occurs in 19575 days.
Case 4: the next triple peak occurs in 16994 days.
Case 5: the next triple peak occurs in 8910 days.
Case 6: the next triple peak occurs in 10789 days.

题意是在人的一生中有三种生物节律,身体、情绪和智力,每一个情绪都有相应的周期,到了这个周期点这个人的这个方面就变得特别屌。

现在给你这三个的周期为23 28 33。这是固定的了。

然后给你上一个三个周期的巅峰时刻是p e i,问从d时间开始还有多久的N天,三个周期一次一起到达巅峰。

列公式是N+d = p+23*N1 = e+28*N2 = i+33*N3

N1,N2,N3是整数我们不用管,也没要求。要求的是N。

再转化一下就是求一个数最小的S,这个数S除以23余p,除以28余e,除以33余i。当然最后要求的那个N只需S-d就好了。

又一次涨姿势了。。。中国剩余定理。

首先求满足  除以23余1,整除28,整除33的三个条件的最小数,发现是5544。

然后求满足  除以28余1,整除23,整除33的三个条件的最小数,是14421。

然后求满足  除以33余1,整除23,整除28的三个条件的最小数,是1288。

然后5544*p+14421*e+1288*i就一定是三个周期的下一个巅峰了,只不过不一定是最小值。

这里解释一下上面那么做的原因是什么:

1.一个数A除以23余1,B除以23整除,那么(A+B)除以23依旧是余1的。即一个数加上整除x的数,其除以x的余数是不变的。

所以对于23来说,A+B+C余数还是1,因为B和C是整除23的。

对于28来说,A+B+C余数还是1,因为A和C是整除28的。

对于33来说,A+B+C余数还是1,因为A和B是整除33的。

2.A除以23余1,A*c除以23就余c*1,即余c了。

所以得到结论就是5544*p除以23就余p,除以28整除,除以33整除

14421*e除以28余e,除以23整除,除以33整除

1288*i除以33余i,除以23整除,除以28整除

所以这三个相加就满足条件喽,只是不一定是最小值,如何求最小值%lcm(23,28,29)即可。

代码:

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <string>
#include <cstring>
#pragma warning(disable:4996)
using namespace std;

int main()
{
	int a,b,c,d,j=1;
	while(cin>>a>>b>>c>>d)
	{
		if(a+b+c+d==-4)
			break;
		cout<<"Case "<<j;
		j++;
		cout<<": the next triple peak occurs in ";
		int temp=(5544*a+14421*b+1288*c-d+21252)%21252;
		if(temp==0)
		{
			cout<<21252;
		}
		else
			cout<<temp;
		cout<<" days."<<endl;
	}
	return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

时间: 2024-10-15 05:35:09

POJ 1006:Biorhythms 中国剩余定理的相关文章

北大ACM1006——Biorhythms~~中国剩余定理

中国剩余定理,百度一下,就有它的定义与证明. 这里我就讲一个例子就好了. 题目的意思就是给你p,e,i,d.(n + d)% 23 = p,(n + d) % 28 = e,(n + d) % 33 = i.求最小n. 将n+d看成一个整体,m =n + d. 要求m: 先使 28 * 33 * a % 23 = 1,求出a,x = 28 * 33 * a: 使 23 * 33 * b % 28 = 1,求出b,y = 23 * 33 * b: 使23 * 28 * c % 33 = 1,求出c

CSUOJ 1858 Biorhythms 中国剩余定理

1858: Biorhythms Submit Page   Summary   Time Limit: 1 Sec     Memory Limit: 256 Mb     Submitted: 69     Solved: 37 Description Some people believe that there are three cycles in a person's life that start the day he or she is born. These three cycl

转载----POJ 1006 中国剩余定理

本文为转载,源地址:   http://blog.csdn.net/dongfengkuayue/article/details/6461298 POJ 1006   Biorhythms Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 78980   Accepted: 23740 Description Some people believe that there are three cycles in a perso

POJ 1006 中国剩余定理

[题意]: 给定p,e,i,d,求解 (x + d) % 23 = p (x + d) % 28 = e(x + d) % 33 = i x最小正整数值 [知识点]: 中国剩余定理 [题解]: 典型的 xmodmi = ai模型,其中mi间两两互素.但该题式子较少,也可以直接自己化简带入值. [代码]: 1 #include <map> 2 #include <set> 3 #include <cmath> 4 #include <ctime> 5 #inc

数论E - Biorhythms(中国剩余定理,一水)

E - Biorhythms Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u Submit Status Description Some people believe that there are three cycles in a person's life that start the day he or she is born. These three cycles are the

poj 1006:Biorhythms(水题,经典题,中国剩余定理)

Biorhythms Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 110991   Accepted: 34541 Description Some people believe that there are three cycles in a person's life that start the day he or she is born. These three cycles are the physical,

acm数论之旅--中国剩余定理

中国剩余定理,又名孙子定理o(*≧▽≦)ツ 能求解什么问题呢? 问题: 一堆物品 3个3个分剩2个 5个5个分剩3个 7个7个分剩2个 问这个物品有多少个 解这题,我们需要构造一个答案 我们需要构造这个答案 5*7*inv(5*7,  3) % 3  =  1 3*7*inv(3*7,  5) % 5  =  1 3*5*inv(3*5,  7) % 7  =  1 这3个式子对不对,别告诉我逆元你忘了(*′?`*),忘了的人请翻阅前几章复习 然后两边同乘你需要的数 2 * 5*7*inv(5*

POJ 1006 Biorhythms (数论-中国剩余定理)

Biorhythms Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 111285   Accepted: 34638 Description Some people believe that there are three cycles in a person's life that start the day he or she is born. These three cycles are the physical,

poj 1006 Biorhythms (中国剩余定理学习)

Biorhythms Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 113517   Accepted: 35597 Description Some people believe that there are three cycles in a person's life that start the day he or she is born. These three cycles are the physical,