7-7 Complete Binary Search Tree (30分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node‘s key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node‘s key.
  • Both the left and right subtrees must also be binary search trees.

    A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

    Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer N (≤). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

    Output Specification:

    For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

    Sample Input:

    10
    1 2 3 4 5 6 7 8 9 0
    

    Sample Output:

    6 3 8 1 5 7 9 0 2 4

给出一个序列,从小到大排序就是树的中序遍历,不妨中序遍历走一遍把各个结点放在各自的位置。由于是完全二叉树,可以用数组按顺序来存,完事输出数组就是层序遍历。

代码:

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
int n,l[1001],tr[2010],c;
void inorder(int k) {
    if(k > n)return;
    inorder(k * 2);
    tr[k] = l[c ++];
    inorder(k * 2 + 1);
}
void levelprint() {
    for(int i = 1;i <= n;i ++) {
        if(i == 1) printf("%d",tr[i]);
        else printf(" %d",tr[i]);
    }
}
int cmp(const void *a,const void *b) {
    return *(int *)a - *(int *)b;
}
int main() {
    scanf("%d",&n);
    for(int i = 0;i < n;i ++)
        scanf("%d",&l[i]);
    qsort(l,n,sizeof(l[0]),cmp);
    inorder(1);
    levelprint();
}

原文地址:https://www.cnblogs.com/8023spz/p/12259527.html

时间: 2024-08-30 03:00:15

7-7 Complete Binary Search Tree (30分)的相关文章

04-树6 Complete Binary Search Tree (30 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties: The left subtree of a node contains only nodes with keys less than the node's key. The right subtree of a node contains only nodes with keys greate

PAT Advanced 1064 Complete Binary Search Tree (30分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties: The left subtree of a node contains only nodes with keys less than the node's key. The right subtree of a node contains only nodes with keys greate

A1064 Complete Binary Search Tree (30分)

一.技术总结 这一题就是将给的数,构造一个完全二叉排序树 关键就是要利用完全二叉树的特点,如果该结点的下标是x,那么左子树的结点下标一定是2 x,右子树下标是2x+1,然后二叉排序树的中序遍历是从小到大的. 二.参考代码 #include<bits/stdc++.h> using namespace std; const int maxn = 1010; //n为结点数,number用以存放结点权值,CBT用以存放完全二叉树 //index从小到大枚举number数组 int n, numbe

PAT Advanced Level 1064 Complete Binary Search Tree (30)(30 分)

1064 Complete Binary Search Tree (30)(30 分) A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties: The left subtree of a node contains only nodes with keys less than the node's key. The right subtree of

04-树8. Complete Binary Search Tree (30)

04-树8. Complete Binary Search Tree (30) 时间限制 100 ms 内存限制 65536 kB 代码长度限制 8000 B 判题程序 Standard 作者 CHEN, Yue A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties: The left subtree of a node contains only

pat1064. Complete Binary Search Tree (30)

1064. Complete Binary Search Tree (30) 时间限制 100 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties: The left subtree of a node contains only

1064. Complete Binary Search Tree (30)【二叉树】——PAT (Advanced Level) Practise

题目信息 1064. Complete Binary Search Tree (30) 时间限制100 ms 内存限制65536 kB 代码长度限制16000 B A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties: The left subtree of a node contains only nodes with keys less tha

二叉查找树——A1064.Complete Binary Search Tree(30) 构建完全二叉查找树,利用完全二叉查找树的性质:左孩子为2x ,右孩子为 2x + 1

#include <bits/stdc++.h> #include <stdio.h> #include <stdlib.h> #include <queue> using namespace std; const int maxn = 1010; int temp[maxn],initial[maxn],n; int ind; void inorder(int root){//中序遍历 if(root > n){ return; } inorder(

A1064. Complete Binary Search Tree (30)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties: The left subtree of a node contains only nodes with keys less than the node's key. The right subtree of a node contains only nodes with keys greate