HDU 1390 Binary Numbers(数学题)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1390

Problem Description

Given a positive integer n, find the positions of all 1‘s in its binary representation. The position of the least significant bit is 0.

Example

The positions of 1‘s in the binary representation of 13 are 0, 2, 3.

Task

Write a program which for each data set:

reads a positive integer n,

computes the positions of 1‘s in the binary representation of n,

writes the result.

Input

The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.

Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.

Output

The output should consists of exactly d lines, one line for each data set.

Line i, 1 <= i <= d, should contain increasing sequence of integers separated by single spaces - the positions of 1‘s in the binary representation of the i-th input number.

Sample Input

1
13

Sample Output

0 2 3

Source

Central Europe 2001, Practice

题意:

找一个数的二进制中为1的位置!

代码如下:

#include <cstdio>
int a[1000007];
int main()
{
    int n;
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        int k = 0;
        int l = -1;
        while(n)
        {
            int t = n%2;
            if(t)
            {
                a[++l] = k;
            }
            k++;
            n/=2;
        }
        for(int i = 0; i < l; i++)
        {
            printf("%d ",a[i]);
        }
        printf("%d\n",a[l]);
    }
    return 0;
}
时间: 2024-08-02 14:00:43

HDU 1390 Binary Numbers(数学题)的相关文章

HDU 1390 Binary Numbers

题目地址: http://acm.hdu.edu.cn/showproblem.php?pid=1390 题目描述: Binary Numbers Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 2834    Accepted Submission(s): 1758Problem Description Given a positive

杭电 HDU ACM 1390 Binary Numbers

Binary Numbers Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 3372    Accepted Submission(s): 2026 Problem Description Given a positive integer n, find the positions of all 1's in its binary r

HDOJ 1390 Binary Numbers(进制问题)

Problem Description Given a positive integer n, find the positions of all 1's in its binary representation. The position of the least significant bit is 0. Example The positions of 1's in the binary representation of 13 are 0, 2, 3. Task Write a prog

[BestCoder Round #5] hdu 4956 Poor Hanamichi (数学题)

Poor Hanamichi Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 743    Accepted Submission(s): 275 Problem Description Hanamichi is taking part in a programming contest, and he is assigned to so

hdu 3117 Fibonacci Numbers

点击此处即可传送到hdu 3117 **Fibonacci Numbers** Problem Description The Fibonacci sequence is the sequence of numbers such that every element is equal to the sum of the two previous elements, except for the first two elements f0 and f1 which are respectively

zju 1383 Binary Numbers

#include <iostream> using namespace std; int a[1000]; int f(int n) { int k=0; while(n) { a[k++]=n%2; n/=2; } return k; } int main(int argc, char *argv[]) { int n,m,k,q; while(cin>>q) { while(q--) { cin>>n; m=f(n); for(int i =0,k=0;i<m

hdu 3123 GCC(数学题)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3123 GCC Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others) Total Submission(s): 3808    Accepted Submission(s): 1234 Problem Description The GNU Compiler Collection (u

hdu 4722 Good Numbers(dp)

public static void main(String[] args) { String a=null; if("aa".equals(a))//这种情形,不出现空指针异常 //if(a.equals("aa"))//出现空指针异常 { System.out.println(true); } else { System.out.println(false); } } 上面的两句不同的比较语句测试,第一句不出现空指针异常,第二句出现. 所以在变量和常量比较的时候

HDU 3117 Fibonacci Numbers(斐波那契前后四位,打表+取对+矩阵快速幂)

HDU 3117 Fibonacci Numbers(斐波那契前后四位,打表+取对+矩阵快速幂) ACM 题目地址:HDU 3117 Fibonacci Numbers 题意: 求第n个斐波那契数的前四位和后四位. 不足8位直接输出. 分析: 前四位有另外一题HDU 1568,用取对的方法来做的. 后四位可以用矩阵快速幂,MOD设成10000就行了. 代码: /* * Author: illuz <iilluzen[at]gmail.com> * Blog: http://blog.csdn.