Ignatius and the Princess III (HDU_1028) 母函数 + 整数拆分

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 17692    Accepted Submission(s): 12403

Problem Description

"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:

N=a[1]+a[2]+a[3]+...+a[m];

a[i]>0,1<=m<=N;

My question is how many different equations you can find for a given N.

For example, assume N is 4, we can find:

4 = 4;

4 = 3 + 1;

4 = 2 + 2;

4 = 2 + 1 + 1;

4 = 1 + 1 + 1 + 1;

so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"

Input

The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.

Output

For each test case, you have to output a line contains an integer P which indicate the different equations you have found.

Sample Input

4
10
20

Sample Output

5
42
627

题目大意:给出一个整数n,将他拆分成1-n的整数,问有多少种组合数;

解题思路:母函数;指数为 数值,用数组下标表示;系数为方案数,用数组存的值表示;不过,也可以用完全背包来做;

代码如下:

#include"iostream"
#include"cstdio"
#include"cstring"
using namespace std;
const int  maxn = 120;

int num[maxn + 1];
int c1[maxn + 1], c2[maxn + 1];

int main(){
	int n;
	while(scanf("%d", &n) != EOF){
		for(int i = 1;i <= n;i ++)
			num[i] = n / i;
		memset(c1, 0, sizeof c1);
		memset(c2, 0, sizeof c2);
		for(int i = 0;i <= num[1];i ++)
			c1[i] = 1;
		for(int i = 2;i <= n;i ++){		//共有26个多项式
			for(int j = 0;j <= maxn;j ++){	//共有maxn+1项
				for(int k = 0;k <= num[i] && j + k*i <= maxn;k ++)
					c2[j + k*i] += c1[j];
			}
			for(int j = 0;j <= maxn;j ++){
				c1[j] = c2[j];
				c2[j] = 0;
			}
		}
		printf("%d\n",c1[n]);
	}
	return 0;
}
时间: 2024-07-31 13:52:47

Ignatius and the Princess III (HDU_1028) 母函数 + 整数拆分的相关文章

hdu 1028 Ignatius and the Princess III(母函数,完全背包)

http://acm.hdu.edu.cn/showproblem.php?pid=1028 整数划分问题. 第一道母函数...母函数入门 小于等于n的整数共有n个,1,2......n,每个数都有无限多个,对于整数1,它所对应的母函数为(1+x+x^2+...+x^k+...),整数2对应的母函数为(1+x^2+X^4+...+x^(2*k)+...),整数3对应的母函数为(1+x^3+x^6+...+x^(3*k)+...),以此类推,直到整数n. 那么n的整数划分的个数就是这n个母函数乘积

HDU1028 Ignatius and the Princess III 【母函数模板题】

Ignatius and the Princess III Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 12521    Accepted Submission(s): 8838 Problem Description "Well, it seems the first problem is too easy. I will let

Ignatius and the Princess III(母函数一种技巧性的暴力)

Ignatius and the Princess III Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 13070    Accepted Submission(s): 9236 Problem Description "Well, it seems the first problem is too easy. I will let

HDU1028 Ignatius and the Princess III【母函数】【完全背包】

题目链接: http://acm.hdu.edu.cn/showproblem.php?pid=1028 题目大意: 给定正整数N,定义N = a[1] + a[2] + a[3] + - + a[m],a[i] > 0,1 <= m <= N. 对于给定的正整数N,问:能够找出多少种这样的等式? 思路: 对于N = 4, 4 = 4: 4 = 3 + 1: 4 = 2 + 2: 4 = 2 + 1 + 1: 4 = 1 + 1 + 1 + 1. 共有5种.N=4时,结果就是5.其实就是

hdu 1028 Ignatius and the Princess III(母函数)

题意: N=a[1]+a[2]+a[3]+...+a[m];  a[i]>0,1<=m<=N; 例如: 4 = 4;  4 = 3 + 1;  4 = 2 + 2;  4 = 2 + 1 + 1;  4 = 1 + 1 + 1 + 1; 共有5种. 给N,问共有几种构造方式. 思路: 一个数N分解的式子中1的个数可以是0,1,2,3,...,N. 2的个数可以是0,1,2,...,N/2. .... 母函数基础题,, 看代码. 当然也可以用DP(背包) 母函数代码: int N,num;

hdu 1028 Ignatius and the Princess III 【整数划分】

Ignatius and the Princess III                                                                                       Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 15730    Accepted Submission(

(简单母函数模板)hdu 1028 Ignatius and the Princess III

Ignatius and the Princess III Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 14405    Accepted Submission(s): 10142 Problem Description "Well, it seems the first problem is too easy. I will le

HDU 1028 Ignatius and the Princess III(母函数)

Ignatius and the Princess III Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 15794    Accepted Submission(s): 11138 Description "Well, it seems the first problem is too easy. I will let you kno

hdu 1028 Ignatius and the Princess III(整数划分)

Ignatius and the Princess III Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 12731    Accepted Submission(s): 8999 Problem Description "Well, it seems the first problem is too easy. I will let