一种排序
时间限制:3000 ms | 内存限制:65535 KB
难度:3
- 描述
- 现在有很多长方形,每一个长方形都有一个编号,这个编号可以重复;还知道这个长方形的宽和长,编号、长、宽都是整数;现在要求按照一下方式排序(默认排序规则都是从小到大);
1.按照编号从小到大排序
2.对于编号相等的长方形,按照长方形的长排序;
3.如果编号和长都相同,按照长方形的宽排序;
4.如果编号、长、宽都相同,就只保留一个长方形用于排序,删除多余的长方形;最后排好序按照指定格式显示所有的长方形;
- 输入
- 第一行有一个整数 0<n<10000,表示接下来有n组测试数据;
每一组第一行有一个整数 0<m<1000,表示有m个长方形;
接下来的m行,每一行有三个数 ,第一个数表示长方形的编号,
第二个和第三个数值大的表示长,数值小的表示宽,相等
说明这是一个正方形(数据约定长宽与编号都小于10000);
- 输出
- 顺序输出每组数据的所有符合条件的长方形的 编号 长 宽
- 样例输入
-
1 8 1 1 1 1 1 1 1 1 2 1 2 1 1 2 2 2 1 1 2 1 2 2 2 1
- 样例输出
-
1 1 1 1 2 1 1 2 2 2 1 1 2 2 1
思路:sort函数的运用
Code:
#include <stdio.h> #include <algorithm> using namespace std; struct node { int w,h,ans; }a[1000]; bool cmp(node x,node y) //cmp函数的改写 { if(x.ans<y.ans) return true; if(x.ans==y.ans&&x.h<y.h) return true; if(x.ans==y.ans&&x.h==y.h&&x.w<y.w) return true; return false; } int main() { int n,m,i; scanf("%d",&n); while(n--) { scanf("%d",&m); for(i=0;i<m;i++) { scanf("%d%d%d",&a[i].ans,&a[i].h,&a[i].w); if(a[i].h<a[i].w) //这里要注意先判断长和宽 swap(a[i].h,a[i].w); } sort(a,a+m,cmp); printf("%d %d %d\n",a[0].ans,a[0].h,a[0].w); for(i=1;i<m;i++) //控制输出,把相同的就不输出了 { if(a[i].ans==a[i-1].ans&&a[i].h==a[i-1].h&&a[i].w==a[i-1].w) continue; printf("%d %d %d\n",a[i].ans,a[i].h,a[i].w); } } return 0; }
时间: 2024-10-10 10:53:54