FatMouse and Cheese (hdu 1078 记忆化搜索)

FatMouse and Cheese

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 5463    Accepted Submission(s): 2227

Problem Description

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole.
Now he‘s going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run
at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks
of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.

Input

There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k

n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on.

The input ends with a pair of -1‘s.

Output

For each test case output in a line the single integer giving the number of blocks of cheese collected.

Sample Input

3 1
1 2 5
10 11 6
12 12 7
-1 -1

Sample Output

37

Source

Zhejiang University Training Contest 2001

Recommend

We have carefully selected several similar problems for you:  1080 1074 1024 1081 1025

题意:给出n*n的数字矩阵,从(0,0)出发,走的下一步格子上的数要大于当前格子上的数,并且每次可以沿直线前进最多k个位置,也就是每次有4*k个选择,问最后所有数之和的最大值。

思路:记忆化搜索。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define maxn 105
#define MAXN 2005
#define mod 1000000009
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
#define lson rt<<1,l,mid
#define rson rt<<1|1,mid+1,r
#define FRE(i,a,b)  for(i = a; i <= b; i++)
#define FRL(i,a,b)  for(i = a; i < b; i++)
#define mem(t, v)   memset ((t) , v, sizeof(t))
#define sf(n)       scanf("%d", &n)
#define sff(a,b)    scanf("%d %d", &a, &b)
#define sfff(a,b,c) scanf("%d %d %d", &a, &b, &c)
#define pf          printf
#define DBG         pf("Hi\n")
typedef long long ll;
using namespace std;

int dir[4][2]={0,1,1,0,0,-1,-1,0};
int mp[maxn][maxn];
int sum[maxn][maxn];
int n,k;

bool Isok(int x,int y)
{
    if (x>=0&&x<n&&y>=0&&y<n) return true;
    return false;
}

int dfs(int x,int y)
{
    if (sum[x][y]) return sum[x][y];        //直接返回
    int maxx=0;
    int i,j;
    FRE(i,1,k)
    {
        FRL(j,0,4)
        {
            int dx=x+dir[j][0]*i;
            int dy=y+dir[j][1]*i;
            if (Isok(dx,dy)&&mp[x][y]<mp[dx][dy])
            {
                maxx=max(maxx,dfs(dx,dy));
            }
        }
    }
    sum[x][y]=maxx+mp[x][y];    //把从(x,y)处出发的最优答案记录下来,下次再遇到(x,y)时直接返回这个值
    return sum[x][y];
}

int main()
{
    int i,j;
    while (sff(n,k))
    {
        if (n==-1&&k==-1) break;
        FRL(i,0,n)
        FRL(j,0,n)
        sf(mp[i][j]);
        mem(sum,0);
        pf("%d\n",dfs(0,0));
    }
    return 0;
}
时间: 2024-07-31 18:15:05

FatMouse and Cheese (hdu 1078 记忆化搜索)的相关文章

P - FatMouse and Cheese HDU 1078 ( 记忆化搜索 )

P - FatMouse and Cheese Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u Submit Status Practice HDU 1078 Description FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid

HDU 1078 记忆化搜索

FatMouse and Cheese Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 4575 Accepted Submission(s): 1829 Problem Description FatMouse has stored some cheese in a city. The city can be considered as a

hdu 1078 FatMouse and Cheese (dfs+记忆化搜索)

pid=1078">FatMouse and Cheese Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 4811    Accepted Submission(s): 1945 Problem Description FatMouse has stored some cheese in a city. The city can

hdu 1078 FatMouse and Cheese(简单记忆化搜索)

题目链接 http://acm.hdu.edu.cn/showproblem.php?pid=1078 题意:给出n*n的格子,每个各自里面有些食物,问一只老鼠每次走最多k步所能吃到的最多的食物 一道简单的记忆化搜索题,从起点开始搜索即可没什么问题,可以拿来练练手. #include <iostream> #include <cstring> #include <algorithm> #include <cstdio> using namespace std

hdu 4960 记忆化搜索 DP

Another OCD Patient Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others) Total Submission(s): 490    Accepted Submission(s): 180 Problem Description Xiaoji is an OCD (obsessive-compulsive disorder) patient. This morni

hdu 3644 记忆化搜索

题目:给出一个有向图,从1到n,每个结点有个权值,每走一步,分值为结点权值的LCM,而且每一步的LCM都要有变化,问到达N的时候分值恰好为K的路径有多少条 记忆化搜索,虽然做过很多了,但是一直比较慢,这次总结出几点 1.注意确定终点状态 2.状态的初始化 3.不可能状态的排除 代码是参考cxlove写的,kuangbin博客要是刷完了,下一个就刷他啦 1 #include<cstdio> 2 #include<iostream> 3 #include<algorithm>

hdu 1978 记忆化搜索

How many ways Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 5203    Accepted Submission(s): 3067 Problem Description 这是一个简单的生存游戏,你控制一个机器人从一个棋盘的起始点(1,1)走到棋盘的终点(n,m).游戏的规则描述如下:1.机器人一开始在棋盘的起始点并有起

HDU 4778 记忆化搜索&amp;状压

给出G种宝石,B个包,和S,S代表到时候每种颜色的宝石凑齐S个能变成一个魔法石 每个包里有N种宝石,分别为c1,c2....... 然后两人轮流拿包,每个包只能拿一次,拿出包把宝石放地上. 如果能变成魔法石则拿走魔法石,下一次还这个人拿包,没变成则换人. 魔法石的个数就是获得分数,问两人最优的时候分差是多少. 状压记忆化搜索 一共21个包,状压存当前取包的状态 无论怎样取,最后获得的魔法石数量一定 dp[i]表示在i状态下,先手可以获得的最高分数 #include "stdio.h"

hdu 1208 记忆化搜索

题目大意:只能按照格子上的数字*方向走,从左上走到右下Sample Input42331121312313110Sample Output3 直接记忆化搜索,注意是0的情况 1 #include<cstdio> 2 #include<iostream> 3 #include<algorithm> 4 #include<cstring> 5 #include<cmath> 6 #include<queue> 7 #include<