dp(最长公共上升子序列)

This is a problem from ZOJ 2432.To make it easyer,you just need output the length of the subsequence.

InputEach sequence is described with M - its length (1 <= M
<= 500) and M integer numbers Ai (-2^31 <= Ai < 2^31) - the
sequence itself.Outputoutput print L - the length of the greatest common increasing subsequence of both sequences.Sample Input

1

5
1 4 2 5 -12
4
-12 1 2 4

Sample Output

2lis(最长上升子序列)和lcs(最长公共子序列)的结合lcis(最长公共上升子序列)还不是很懂这个问题https://www.cnblogs.com/WArobot/p/7479431.html
#include <iostream>
#include <iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<algorithm>
#include <stdio.h>
#include <string.h>
using namespace std;

int w[109] , dp[1009] , a[1009] , b[1009];

int main()
{
    int n ;
    scanf("%d" , &n);
    while(n--)
    {
        int m  , l;
        scanf("%d" , &m);
        memset(dp , 0 , sizeof(dp));
        for(int i = 1 ; i <= m ; i++)
        {
            scanf("%d" , &a[i]);
        }
        scanf("%d" , &l);
        for(int i = 1 ; i <= l ; i++)
        {
            scanf("%d" , &b[i]) ;
        }
        int mas = 0 ;
        for(int i = 1 ; i <= m ; i++)
        {
            mas = 0 ; // 记录b数组前j个与a数组前i个的最长公共升序列的个数
            for(int j = 1 ; j <=l ; j++)
            {
                if(a[i] > b[j])
                    mas = max(mas , dp[j]);
                if(a[i] == b[j])
                    dp[j] = mas + 1 ;
            }
        }
        int ans = 0 ;
        for(int i = 1 ; i <= l ; i++)
        {
            ans = max(ans , dp[i]);
        }
        if(n)
        {
            printf("%d\n\n", ans);
        }
        else
            printf("%d\n" , ans);

    }

    return 0;
}
 

原文地址:https://www.cnblogs.com/nonames/p/11237948.html

时间: 2024-11-07 05:18:42

dp(最长公共上升子序列)的相关文章

POJ 2250 Compromise (DP,最长公共子序列)

Compromise Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 6440 Accepted: 2882 Special Judge Description In a few months the European Currency Union will become a reality. However, to join the club, the Maastricht criteria must be fulfille

Codeforces 10D LCIS 求最长公共上升子序列及输出这个子序列 dp

题目链接:点击打开链接 题意: 给定n长的一个序列 再给定k长的一个序列 求LCIS并输出这个子序列 如有多解输出任意解.. = - = 敲的时候听着小曲儿pre的含义还没有想清楚,万万没想到就过了... #include<stdio.h> #include<iostream> #include<string.h> #include<set> #include<vector> #include<map> #include<mat

[CodeForces10D]LCIS(最长公共上升子序列) - DP

Description 给定两个数列,求最长公共上升子序列,并输出其中一种方案. Input&Output Input 第一行一个整数n(0<n<=500),数列a的长度. 第二行n个空格隔开的整数,数列a的元素. 第三行一个整数m,数据范围同n,数列b的长度. 第四行m个空格隔开的整数,意义同第二行. Output 第一行一个整数k,LCIS的长度. 第二行k个空格隔开的整数,其中一种方案. Solution 对于这类问题我们通常有两种转移方式,一种是以i结尾的数列,另一种是前i个数

POJ 2127 最长公共上升子序列

动态规划法: #include <iostream> #include <cstdio> #include <fstream> #include <algorithm> #include <cmath> #include <deque> #include <vector> #include <queue> #include <string> #include <cstring> #inc

最长公共上升子序列(LCIS)ZOJ 2432

立方算法: #include<cstdio> #include<iostream> #include<algorithm> #include<cstring> #define M 505 using namespace std; typedef long long LL; LL a[M],b[M]; int dp[M][M]; int main() { //freopen("in.txt","r",stdin); in

动态规划——最长公共上升子序列LCIS

问题 给定两个序列A和B,序列的子序列是指按照索引逐渐增加的顺序,从原序列中取出若干个数形成的一个子集,若子序列的数值大小是逐渐递增的则为上升子序列,若A和B取出的两个子序列A1和B1是相同的,则A1/B1为A和B的公共子序列.求出A和B的最长公共上升子序列. 分析     结合最长公共子序列和最长上升子序列来解决这个问题,定义状态dp[i][j]表示A串中前i个字符和B串中前j个字符且以B[j]为结尾的最长公共上升子序列的长度.则有状态转移方程:[在进行动态规划状态的设计的时候,要简单.详尽的

HDU 4512 最长公共上升子序列

各种序列复习: (1)最长上升子序列. 1.这个问题用动态规划就很好解决了,设dp[i]是以第i个数字结尾的上升子序列的最长长度.那么方程可以是dp[i]=max(dp[j]+1).(j<i).复杂度为O(n^2); 2.另外有一个该经典问题的O(nlogn)算法. 首先知道,当求dp[i]时,如果出现a[k]<a[j],而dp[k]=dp[j]时,应当优先选k吧.那么,既然每次选的都是较小,就可以把字符串按照dp[t]=k这个子序列长度分类.当同样dp[t]=k时,记录下该长度的最小的a[p

BNUOJ 4215 最长公共连续子序列

最长公共连续子序列 Time Limit: 1000ms Memory Limit: 65536KB 64-bit integer IO format: %lld      Java class name: Main 给你两个序列S1和S2,长度分别是L1,L2 (1 <= L1 , L2 <= 180). 写一个程序找出最长的连续公共子序列. 连续子序列定义为序列中连续的一个片段.例如序列"1 2 3"的子串有空串,"1","2",

UVA 12511/CSU 1120 virus 最长公共上升子序列

第一次接触一个这最长公共上升子序列 不过其实搞清楚了跟最长公共子序列和 最长上升子序列如出一辙 两重循环,对于当前不相等的,等于前一个的值,相等的,等于比当前A[i]小的最大值+1.弄个临时变量记录最大值即可 #include <iostream> #include <cstdio> #include <cstring> #include <algorithm> using namespace std; int dp[2][1010]; int A[1010