1013 Battle Over Cities (25分) DFS | 并查集

1013 Battle Over Cities (25分)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city?1??-city?2?? and city?1??-city?3??. Then if city?1?? is occupied by the enemy, we must have 1 highway repaired, that is the highway city?2??-city?3??.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

题意:

  给出n个城市之间的路径,假如其中有一座城市被摧毁了,需要另外修多少条路使得其它城市是连通的

题解    

  一、用二维数组存图,使用DFS遍历联通的集合有多少个  

  二、先用数组a[],b[]存m条路径的端点城市(a,b数组的大小必须大于10^6,否则会段错误),然后在k次询问的时候建立并查集(在建立并查集的时候依次剔除摧毁的城市x),用并查集找联通集合的个数。

 

注意:使用cin/cout会超时,必须用scanf和printf,

DFS
#include<iostream>
#include<cstdio>
#include<vector>
#include<cstring>
#include<stack>
#include<algorithm>
#include<map>
#include<string.h>
#include<string>
#define MAX 1000000
#define ll long long
using namespace std;
int a[1005][1005],vis[1005];
int n,m,k;
void dfs(int x)
{
    vis[x]=1;
    for(int i=1;i<=n;i++)
    {
        if(vis[i]==0&&a[x][i]==1)
            dfs(i);
    }
}
int main()
{
    //cin>>n>>m>>k;     使用cin会超时
    scanf("%d %d %d",&n,&m,&k);
    int s,e;
    for(int i=0;i<m;i++)
    {
        //cin>>s>>e;
        scanf("%d%d",&s,&e);
        a[s][e]=a[e][s]=1;
    }
    for(int i=0;i<k;i++)
    {
        int x,cnt=0;
        //cin>>x;
        scanf("%d",&x);
        memset(vis,0,sizeof(vis));
        vis[x]=1;
        for(int j=1;j<=n;j++)
        {
            if(vis[j]==0)
            {
                cnt++;
                dfs(j);
            }
        }

        //cout<<cnt-1<<endl;
        printf("%d\n",cnt-1);
    }
    return 0;

}

并查集

#include<iostream>
#include<cstdio>
#include<vector>
#include<cstring>
#include<stack>
#include<algorithm>
#include<map>
#include<string.h>
#include<string>
#define MAX 1000000
#define ll long long
using namespace std;
int p[10005],r[10005],a[1000005],b[1000005];
int n,m,k;
void init()//初始化集合,每个元素的老板都是自己
{
    for (int i = 1; i <= n; i++)
    {
        p[i] = i;
    }
}

int find(int x)//查找元素x的老板是谁
{
    if (x == p[x])
        return x;
    else
        return p[x] = find(p[x]);
}

void join(int x, int y)//合并两个集合
{
    int xRoot = find(x);
    int yRoot = find(y);

    if (xRoot == yRoot) //老板相同,不合并
        return;
    //cnt=cnt-1;
    if (r[xRoot] < r[yRoot]) //r[i]是元素i所在树的高度,矮树的根节点认高树的根节点做老板
        p[xRoot] = yRoot;
    else if (r[xRoot] > r[yRoot])
        p[yRoot] = xRoot;
    else
    {
        p[yRoot] = xRoot;//树高相同,做老板的树高度要加一
        r[xRoot]++;
    }
}

int main()
{
    cin>>n>>m>>k;

    for(int i=0;i<m;i++)//存边
       scanf("%d%d",&a[i],&b[i]);

    for(int i=0;i<k;i++)
    {
        init();
        int x;
        scanf("%d",&x);
        for(int j=0;j<m;j++)
        {
            if(a[j]==x||b[j]==x)//在建立并查集的时候剔除点x
                continue;
            else
            {
                if(find(a[j])!=find(b[j]))
                    join(a[j],b[j]);
            }
        }
        int cnt=0;
        for(int j=1;j<=n;j++)
        {
            if(p[j]==j)
                cnt++;
        }
        printf("%d\n",cnt-2);//剔除的那个点也会独立成一个集合,所以要减2

    }
    return 0;
}


原文地址:https://www.cnblogs.com/-citywall123/p/12150384.html

时间: 2024-11-07 13:04:21

1013 Battle Over Cities (25分) DFS | 并查集的相关文章

PAT 甲级 1013 Battle Over Cities (25 分)(图的遍历,统计强连通分量个数,bfs,一遍就ac啦)

1013 Battle Over Cities (25 分) It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any oth

PAT-1013 Battle Over Cities (25 分) DFS求连通块

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of

PAT Advanced 1013 Battle Over Cities (25分)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of

PAT Advanced Level 1013 Battle Over Cities (25)(25 分)

1013 Battle Over Cities (25)(25 分) It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any

1013. Battle Over Cities (25)——PAT (Advanced Level) Practise

题目信息: 1013. Battle Over Cities (25) 时间限制 400 ms 内存限制 32000 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward th

pat 1013 Battle Over Cities(25 分) (并查集)

1013 Battle Over Cities(25 分) It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any othe

PAT甲题题解-1013. Battle Over Cities (25)-求联通分支个数

题目就是求联通分支个数删除一个点,剩下联通分支个数为cnt,那么需要建立cnt-1边才能把这cnt个联通分支个数求出来怎么求联通分支个数呢可以用并查集,但并查集的话复杂度是O(m*logn*k)我这里用的是dfs,dfs的复杂度只要O((m+n)*k)这里k是指因为有k个点要查询,每个都要求一下删除后的联通分支数.题目没给定m的范围,所以如果m很大的话,dfs时间会比较小. for一遍1~n个点,每次从一个未标记的点u开始dfs,标记该dfs中访问过的点.u未标记过,说明之前dfs的时候没访问过

Battle Over Cities (25)(DFS、连通图)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of

1013. Battle Over Cities (25)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of