HDoj-2072-单词数

单词数

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 29470    Accepted Submission(s): 7081

Problem Description

lily的好朋友xiaoou333最近很空,他想了一件没有什么意义的事情,就是统计一篇文章里不同单词的总数。下面你的任务是帮助xiaoou333解决这个问题。

Input

有多组数据,每组一行,每组就是一篇小文章。每篇小文章都是由小写字母和空格组成,没有标点符号,遇到#时表示输入结束。

Output

每组只输出一个整数,其单独成行,该整数代表一篇文章里不同单词的总数。

Sample Input

you are my friend
#

Sample Output

4

总会有一种适合你。。。

//*************Set****************/
#include<iostream>
#include<sstream>
#include<string>
#include<set>
using namespace std;
int main()
{
	string line,word;
	set <string> list;
	while(getline(cin,line)&&line!="#")
	{
		list.clear();
		istringstream stream(line);
		while(stream>>word)
		{
			if(list.end()==list.find(word))
				list.insert(word);
		}
		cout<<list.size()<<endl;
	}
	return 0;
} 
//************fopen文件*******************/
#include<stdio.h>
#include<string.h>
#define N 10000
char  article[N],tmp[101],word[N][101];
int main()
{

    int len,pos,k,cnt;
    freopen("hdu_2072_in.txt","r",stdin);
    freopen("hdu_2072_out.txt","w",stdout);
    while(gets(article)!=NULL)
    {
       if(article[0]=='#') break;
       cnt=0;
       len=strlen(article);
       pos=0;
       while(pos<len)
       {
           sscanf(article+pos,"%s",tmp);
           for(k=0;k<cnt;k++)
                  if( strcmp(word[k],tmp)==0) break;
           if( k==cnt )  strcpy(word[cnt++],tmp);
           pos += strlen(tmp) + 1;

       }
       printf("%d/n",cnt);
    }return 0;
}
//************SSSSSSScanf*******//
HDOJ——2072单词数
SSCANF用法:(继qsort,bsearch,strchr后发现的又一好使的函数)
sscanf与scanf类似,都是用于输入的,只是后者以键盘(stdin)为输入源,前者以固定字符串为输入源。
例子:
  1. 常见用法。
char buf[512] ;
sscanf("123456 ", "%s", buf);//此处buf是数组名,它的意思是将123456以%s的形式存入buf中!
printf("%s\n", buf);
结果为:123456
2. 取指定长度的字符串。如在下例中,取最大长度为4字节的字符串。
sscanf("123456 ", "%4s", buf);
printf("%s\n", buf);
结果为:1234
3. 取到指定字符为止的字符串。如在下例中,取遇到空格为止字符串。
sscanf("123456 abcdedf", "%[^ ]", buf);
printf("%s\n", buf);
结果为:123456
4. 取仅包含指定字符集的字符串。如在下例中,取仅包含1到9和小写字母的字符串。
sscanf("123456abcdedfBCDEF", "%[1-9a-z]", buf);
printf("%s\n", buf);
结果为:123456abcdedf
当输入:
sscanf("123456abcdedfBCDEF","%[1-9A-Z]",buf);
printf("%s\n",buf);
结果为:123456
5. 取到指定字符集为止的字符串。如在下例中,取遇到大写字母为止的字符串。
sscanf("123456abcdedfBCDEF", "%[^A-Z]", buf);
printf("%s\n", buf);
结果为:123456abcdedf
6、给定一个字符串iios/[email protected],获取 / 和 @ 之间的字符串,先将 "iios/"过滤掉,再将非'@'的一串内容送到buf中
sscanf("iios/[email protected]", "%*[^/]/%[^@]", buf);
printf("%s\n", buf);
结果为:12DDWDFF
7、给定一个字符串“hello, world”,仅保留world。(注意:“,”之后有一空格)
sscanf(“hello, world”, "%*s%s", buf);
printf("%s\n", buf);
结果为:world
%*s表示第一个匹配到的%s被过滤掉,即hello被过滤了
如果没有空格则结果为NULL。
#include <stdio.h>
#include <string.h>
#include <math.h>
char word[1000];
char arr[100][100];  //arr用于存储以前出现过的单词
int main()
{
        int len, pos;
        char temp[100];
        while(gets(word) && strcmp(word, "#") != 0)//题目要求不是文章结尾为,注意strcmp用比较用“#”
        {
                len = strlen(word);//总长度(包括空格)
                pos = 0;
                int cnt = 0;
                // pos加单词长度一直到>len
                while(pos <= len)
                {
                        sscanf(word + pos, "%s", temp); //把一个单词存入temp,空格省去(sscanf应该是读到空格截止,对于sscanf,空格很重要)
                        //word + pos为指针指向位置
                        //printf("%s++++++++++++++++++++\n",temp);
                        int k;
                        for(k = 0; k < cnt; ++k)
                                if(strcmp(temp, arr[k]) == 0)   //如果和以前存入的单词相同,则不计数
                                    break;
                        if(k == cnt)
                                strcpy(arr[cnt++], temp);   //把temp存入arr,并计数器cnt加一
                        pos += strlen(temp) + 1;// +1表示加上空格,最后一次pos肯定会大于len
                }
                printf("%d\n", cnt);
        }
        return 0;
}
时间: 2024-09-28 09:19:59

HDoj-2072-单词数的相关文章

HDOJ——2072单词数

SSCANF用法:(继qsort,bsearch,strchr后发现的又一好使的函数) sscanf与scanf类似,都是用于输入的,只是后者以键盘(stdin)为输入源,前者以固定字符串为输入源. 例子:   1. 常见用法. char buf[512] ; sscanf("123456 ", "%s", buf);//此处buf是数组名,它的意思是将123456以%s的形式存入buf中! printf("%s\n", buf); 结果为:12

hdu 2072单词数

单词数 Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 28671    Accepted Submission(s): 6877 Problem Description lily的好朋友xiaoou333最近很空,他想了一件没有什么意义的事情,就是统计一篇文章里不同单词的总数.下面你的任务是帮助xiaoou333解决这个问题. Inp

HDU 2072.单词数【STL的优势以及字符串流的使用】【8月4】

单词数 Problem Description lily的好朋友xiaoou333最近很空,他想了一件没有什么意义的事情,就是统计一篇文章里不同单词的总数.下面你的任务是帮助xiaoou333解决这个问题. Input 有多组数据,每组一行,每组就是一篇小文章.每篇小文章都是由小写字母和空格组成,没有标点符号,遇到#时表示输入结束. Output 每组只输出一个整数,其单独成行,该整数代表一篇文章里不同单词的总数. Sample Input you are my friend # Sample

hdu 2072 单词数

http://acm.hdu.edu.cn/showproblem.php?pid=2072 单词数这道题感觉用c写很麻烦,用c++写就比较简单了.不多说,直接贴代码. #include<iostream> #include<string> #include<vector> #include<sstream> using namespace std; int main() { vector<string> s; string s0,s1; int

hdu 2072 单词数(STL set写法)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2072 思路简单,但是注意一个细节就是最后可能是空格结束的,就是这儿让我WA啦好多次呀... code: #include<cstdio> #include<cstring> #include<cmath> #include<iostream> #include<algorithm> #include<set> #include<st

HDU 2072 单词数(map)

Problem Description http://acm.hdu.edu.cn/showproblem.php?pid=2072 lily的好朋友xiaoou333最近很空,他想了一件没有什么意义的事情,就是统计一篇文章里不同单词的总数.下面你的任务是帮助xiaoou333解决这个问题. Input 有多组数据,每组一行,每组就是一篇小文章.每篇小文章都是由小写字母和空格组成,没有标点符号,遇到#时表示输入结束. Output 每组只输出一个整数,其单独成行,该整数代表一篇文章里不同单词的总

HDU ACM 2072单词数

分析:自从有了set.sstream中的istringstream与及string之后,这种问题也变水了,记得不要忘了STL或者是字符串类及字符流等工具哦!. 注意:重复的单词算一个. #include<iostream> #include<sstream> #include<set> using namespace std; int main() { char a[10001]; string b; while(gets(a) && a[0]!='#'

hdu 2072 单词数,set,strtok

STL_set操作: st.begin() 返回指向第一个元素额迭代器 st.end() 返回指向末尾元素的迭代器 st.rbegin() 返回逆向迭代器,指向链表末尾 st.rend() 返回指向开头之前位置的迭代器 st.clear() 清空迭代器 st.count(key_type key) 返回某个值元素的个数 st.empty() 如果为空,返回true st.size() 返回元素的数量 st.swap() 交换两个集合变量 st.insert(val) st.insert(loc,

杭电2072 统计单词数

http://acm.hdu.edu.cn/showproblem.php?pid=2072 用set容器来统计单词数,可以排除相同的单词. #include<iostream>#include<set>#include<string>using namespace std; int main(){ string String,str; set<string> s; int i = 0; bool flag; while(getline(cin,str) &

单词数

单词数 Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 32836    Accepted Submission(s): 7745 Problem Description lily的好朋友xiaoou333最近很空,他想了一件没有什么意义的事情,就是统计一篇文章里不同单词的总数.下面你的任务是帮助xiaoou333解决这个问题. Inp