杭电1047(Integer Inquiry)java水过

点击打开杭电1047

Problem Description

One of the first users of BIT‘s new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.

``This supercomputer is great,‘‘ remarked Chip. ``I only wish Timothy were here to see these results.‘‘ (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)

Input

The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.

Output

Your program should output the sum of the VeryLongIntegers given in the input.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Sample Input

3

123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

 

123456789012345678901234567890

123456789012345678901234567890

123456789012345678901234567890

0

 

0

Sample Output

370370367037037036703703703670

 

370370367037037036703703703670

 

0

注:格式问题!!

代码实现

import java.math.BigInteger;
import java.util.Scanner;
class Main{
    public static void main(String[] args){
        Scanner sc = new Scanner(System.in);
        int n = sc.nextInt();
        while(n-->0){
	   BigInteger sum=BigInteger.ZERO;
            BigInteger x;
	        while(sc.hasNextBigInteger()){
            	x=sc.nextBigInteger();
            	if(x.equals(BigInteger.valueOf(0))){
            		System.out.println(sum);
            		break;
            	}else{
            		sum=sum.add(x);
            	}
            }
            if(n!=0){
            	System.out.println();
            }
        }
    }
}
时间: 2024-08-14 04:09:46

杭电1047(Integer Inquiry)java水过的相关文章

HDUJ 1047 Integer Inquiry

Integer Inquiry Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 12426    Accepted Submission(s): 3123 Problem Description One of the first users of BIT's new supercomputer was Chip Diller. He e

POJ 1053 Integer Inquiry && HDOJ 1047 Integer Inquiry (大数加法)

题目链接(POJ):http://poj.org/problem?id=1503 题目链接(HDOJ):http://acm.hdu.edu.cn/showproblem.php?pid=1047 Integer Inquiry Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 30856   Accepted: 12007 Description One of the first users of BIT's new su

HDOJ 1047 Integer Inquiry

JAVA睑板.... Integer Inquiry Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 12042    Accepted Submission(s): 3037 Problem Description One of the first users of BIT's new supercomputer was Chip D

HDU - 1047 - Integer Inquiry (大数高精度)

Integer Inquiry Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 13969    Accepted Submission(s): 3523 Problem Description One of the first users of BIT's new supercomputer was Chip Diller. He e

HDU 1047.Integer Inquiry【多个大数相加】【高精度】【8月25】

Integer Inquiry Problem Description One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers. ``This supercomputer is great,

求平均成绩(杭电2023)(确实很水很繁琐)

求平均成绩 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 66221    Accepted Submission(s): 15805 Problem Description 假设一个班有n(n<=50)个学生,每人考m(m<=5)门课,求每个学生的平均成绩和每门课的平均成绩,并输出各科成绩均大于等于平均成绩的学生数量. Input

HDU 1047 [Integer Inquiry] 高精度 格式

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1047 题目大意:T组数据.每组给出n个大数,输出他们的和 关键思想:高精度,格式控制 代码如下: #include <iostream> #include <memory.h> using namespace std; int a[102][110]; int ans[110]; int cnt=0; bool flag;//处理前导零 void solve(){ int sum,c=

hdu 1047 Integer Inquiry(高精度数)

Problem Description Oneof the first users of BIT's new supercomputer was Chip Diller. He extended hisexploration of powers of 3 to go from 0 to 333 and he explored taking varioussums of those numbers. ``This supercomputer is great,'' remarked Chip. `

杭电acm2059-龟兔赛跑 java

一看题就知道是动态规划,不过这要看下如何设置变化数组了 先分析这道题:兔子到达终点的时间时固定的,因此只需要考虑乌龟了,乌龟骑电车和骑自行车的时间,然后计算,因为中间有N个充电站,可以看做N个点(到起点的点),加上起点和终点则是N+2的位置,这时我们dp,判断到每个点的最小时间,结果也就是第N+2个点的最短时间 起点时间是0.这是必须的,然后往后面DP 到第i个,就让j从0循环到i-1,依次代表从j站一直开到i站,这样得到到达i站所需要 的最短时间. 最后比较到达第n+2站(终点)的时间与兔子所