2014 UESTC Training for Data Structures D - 长使英雄泪满襟

看出司马懿在等蜀军粮草不济,孔明于是下令分兵屯田以备久战。

司马懿日日只是闭营不出。孔明每日思虑对策至天明,却也无可奈何。

漫天星辰中有一类星叫做将星,它们随着将魂的燃烧会越发明亮。

今夜五丈原的星空格外璀璨。

司马懿一声轻叹。五丈原的星,要落了。

Input

第一行输入三个整数,n,W,H,分别表示有n颗星,矩形宽W,高H,。

接下来n行,每行三个整数,xi,yi,wi。表示第i颗星星的在天空的位置是(xi,yi),亮度是wi。

1≤n≤100000,1≤W,H≤1000000,0≤x,y≤100000000,1≤wi≤100

Output

仅一行,该行只包含一个整数,表示平移矩形后,矩形内星星的亮度之和最大能是多少。

Sample input and output










Sample Input Sample Output
3 5 4
1 2 3
2 3 2
6 3 1

5

题意是找一个矩形可以框住总亮度最大的星星群。

首先需要离散化,因为题目中y的取值太大而又要以y轴建线段树,做法是先排序,按顺序标序号,相同的Y要标相同的序号。然后对每个点操作    
 如果其y值加H比下几个点大那就记录一下一共有几个点(包括这个点)xin.len;

然后再生成n个虚点,他们的坐标是(x-W,y)。

扫描线从左往右扫描,遇到虚点就在y轴的线段树加入区间(当前节点i到i+xin.len-1),遇到实点就删除区间,(如果x相同优先操作实点)。每次区间操作完都更新一下答案max。


#include <iostream>
#include<cstring>
#include<algorithm>
#include<stdio.h>
using namespace std;

struct node{
int left;
int right;
int data;
int lazy;
}shu[200005];
int n,W,H;
struct mmmm{
int x;
int y;
int w;
bool real;
int len;
}xin[200005];
bool cmpy(const mmmm &j,const mmmm &k)
{
if (j.y!=k.y) return (j.y<k.y);
else return (j.x<k.x);
}
bool cmpx(const mmmm &j,const mmmm &k)
{
if (j.x!=k.x) return (j.x<k.x);
else return (j.real>k.real);
}
void jian(int j,int g,int h)
{
shu[j].left=g;shu[j].right=h;
if (g==h) return;
jian(j*2,g,(g+h)/2);
jian(j*2+1,(g+h)/2+1,h);
}
void push_down(int l)
{
if (shu[l].lazy!=0){
shu[l*2].lazy+=shu[l].lazy;
shu[l*2+1].lazy+=shu[l].lazy;
shu[l*2].data+=shu[l].lazy;
shu[l*2+1].data+=shu[l].lazy;
shu[l].lazy=0;
}
return;
}
void inside(int g,int h,int l,int light)
{
bool b=false;
if (shu[l].left==shu[l].right) {shu[l].data+=light;return ;}
if (shu[l].left==g && shu[l].right==h) {shu[l].lazy+=light;shu[l].data+=light;return ;}
push_down(l);
if (g>(shu[l].left+shu[l].right)/2) {inside(g,h,l*2+1,light);b=true;}
if (h<=(shu[l].left+shu[l].right)/2) {inside(g,h,l*2,light);b=true;}
if (!b) {
inside(g,(shu[l].left+shu[l].right)/2,l*2,light);
inside((shu[l].left+shu[l].right)/2+1,h,l*2+1,light);
}
shu[l].data=max(shu[l*2].data,shu[l*2+1].data);
}

int main()
{
memset(shu,0,sizeof(shu));
memset(xin,0,sizeof(xin));
cin>>n>>W>>H;
int g,h,j,l;
for (j=0;j<n;j++) scanf("%d%d%d",&xin[j].x,&xin[j].y,&xin[j].w);
sort(xin,xin+n,cmpy);
h=1;g=0;
while (g<n){
while (g<n && xin[g].y==xin[g+1].y) {
xin[g].len=h;
g++;
}
xin[g].len=h;
h++;g++;
}
g=0;
for (j=0;j<n;j++){
while (g<n && xin[j].y+H>xin[g].y) g++;
g--;
xin[j].y=xin[j].len;
xin[j].len=xin[g].len-xin[j].len+1;
}
h=xin[n-1].y;
for (j=0;j<n;j++){
xin[j].real=true;
xin[j+n].x=xin[j].x-W;
xin[j+n].y=xin[j].y;
xin[j+n].w=xin[j].w;
xin[j+n].real=false;
xin[j+n].len=xin[j].len;
}
sort(xin,xin+2*n,cmpx);
jian(1,1,h);
int max=-1;
for (j=0;j<2*n;j++){
if (xin[j].real) l=-1;else l=1;
inside(xin[j].y,xin[j].y+xin[j].len-1,1,l*xin[j].w);
if (shu[1].data>max) max=shu[1].data;
}
cout<<max<<endl;
return 0;
}

 

 

2014 UESTC Training for Data Structures D - 长使英雄泪满襟,码迷,mamicode.com

时间: 2024-10-07 10:18:41

2014 UESTC Training for Data Structures D - 长使英雄泪满襟的相关文章

2014 UESTC Training for Data Structures H - Cookies Test

H - Cookies Test Time Limit: 3000/1000MS (Java/Others)     Memory Limit: 65535/65535KB (Java/Others) Submit Status As chief programmer at a cookie production plant you have many responsibilities, one of them being that the cookies produced and packag

2014 UESTC Training for Data Structures K - 方师傅与栈

K - 方师傅与栈 Time Limit: 3000/1000MS (Java/Others)     Memory Limit: 65535/65535KB (Java/Others) Submit Status 方师傅有一个1?N的排列,排列的顺序是固定的,他想要把这个排列重新排列成他喜欢的顺序. 于是他买了一个栈,他会按顺序将排列扔进栈内,在某些时刻将栈顶元素取出,这样出栈后的排列就可以重新排序啦. 例如,原序列是1,2,他先将1入栈,再将2入栈,然后将2出栈,最后将1出栈,那么新序列就变

2014 UESTC Training for Data Structures J - 方师傅的01串

J - 方师傅的01串 Time Limit: 3000/1000MS (Java/Others)     Memory Limit: 65535/65535KB (Java/Others) Submit Status 方师傅过生日啦,于是蟹毛买了N个01串,想送给方师傅. 但是蟹毛觉得这些01串不够美,于是他想从中选出一些送给方师傅. 蟹毛对于p个01串的美值定义为: 这些01串的最长公共前缀的长度×p 所以蟹毛想从N个01串中选出一些,使得这些01串的美值最高. 请告诉蟹毛最好的美值是多少.

2014 UESTC Training for Data Structures C - 东风不与周郎便

C - 东风不与周郎便 Time Limit: 3000/1000MS (Java/Others)     Memory Limit: 65535/65535KB (Java/Others) Submit Status "揽二乔于东南兮,乐朝夕之与共" 一首铜雀台赋,将愤怒与恐惧散播在了孙吴大军之中. 对抗曹军,万事俱备,只欠东风. 现在已经找到n个风眼,这些风眼的东风有强有弱,诸葛亮说他每次祈风都能够将一段风眼的东风增强,但需人去帮他布阵.同时他需要时刻掌控风眼的状况,以确定下一步的

2014 UESTC Training for Data Structures A - Islands

A - Islands Time Limit: 30000/10000MS (Java/Others)     Memory Limit: 65535/65535KB (Java/Others) Submit Status Deep in the Carribean, there is an island even stranger than the Monkey Island, dwelled by Horatio Torquemada Marley. Not only it has a re

2014 UESTC Training for Data Structures F - 天下归晋

F - 天下归晋 Time Limit: 3000/1000MS (Java/Others)     Memory Limit: 65535/65535KB (Java/Others) Submit Status 晋朝统一天下已有十年,曹魏.孙吴.蜀汉这些曾与天下相争的王朝,都成为了过眼云烟,仅留于故事之中. "爷爷,讲嘛讲嘛,再讲一次赤壁之战的故事嘛!" "你个死小子,都讲多少遍了,还听!" "就是想听打仗嘛!" "你小子啊...行,

2014 UESTC Training for Data Structures E - 休生伤杜景死惊开

E - 休生伤杜景死惊开 Time Limit: 3000/1000MS (Java/Others)     Memory Limit: 65535/65535KB (Java/Others) Submit Status 陆伯言军陷八卦阵之中,分明只是一条直路,却怎的也走不到尽头.阵中尽是石堆,以某一石堆为参考,无论向走还是向右,总是会回到出发的石堆,最后幸得一黄姓老翁带路才得脱出. 陆伯言逃离八卦阵后,来到山顶观察此阵,记从左往右第i堆石堆的高度为Ai,发现任何两堆较矮的石堆都能和它们之间的一

2014 UESTC Training for Data Structures G - 程序设计竞赛

G - 程序设计竞赛 Time Limit: 3000/1000MS (Java/Others)     Memory Limit: 65535/65535KB (Java/Others) Submit Status "你动规无力,图论不稳,数据结构松散,贪心迟钝,没一样像样的,就你还想和我同台竞技,做你的美梦!今天这场比赛,就是要让你知道你是多么的无能!!" 不训练,无以为战.有n项能力是ACM竞赛要求的,训练则能提升,忽略则会荒废. 这m天,你能做到如何. Input 第一行两个整

2017 UESTC Training for Data Structures

2017 UESTC Training for Data Structures A    水,找区间极差,RMQ怼上去. #include<bits/stdc++.h> using namespace std; #pragma comment(linker, "/STACK:102400000,102400000") #define rep(i,a,b) for (int i=a;i<=b;i++) #define per(i,b,a) for (int i=b;i&