POJ 2349 Prim

Arctic Network

Time Limit: 2000MS Memory Limit: 65536K

Total Submissions: 9973 Accepted: 3302

Description

The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will
in addition have a satellite channel.

Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers.
Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts.

Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.

Input

The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in
km (coordinates are integers between 0 and 10,000).

Output

For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.

Sample Input

1

2 4

0 100

0 300

0 600

150 750

Sample Output

212.13

Source

Waterloo local 2002.09.28

/*********************************************

        author    :    Grant Yuan
        time      :    2014.7.31
        algorithm :    Prim
        source    :    POJ 2349

**********************************************/

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<deque>
#define INF 0x3fffffff
#define MAX 507
using namespace std;

struct point{int x;int y;};
int t,n,p;
point v[MAX];
double cost[MAX][MAX];
bool used[MAX];
double mincost[MAX];
priority_queue<double>path;

void prim()
{

   for(int i=1;i<=n;i++)
   {
       mincost[i]=INF;
       used[i]=false;
   }
   mincost[1]=0;
   for(int i=1;i<=n;i++)
   {
     double temp=INF;int k=1;
     for(int j=1;j<=n;j++)
     {
         if(!used[j]&&mincost[j]<temp)
         {
             temp=mincost[j];
             k=j;
         }
     }
     path.push(temp);
     used[k]=true;
     for(int j=1;j<=n;j++)
     {
         mincost[j]=min(mincost[j],cost[k][j]);
     }
   }
}

int main()
{
   scanf("%d",&t);
   while(t--){
    while(!path.empty())
          path.pop();
    scanf("%d%d",&p,&n);
    for(int i=1;i<=n;i++)
    {
        scanf("%d%d",&v[i].x,&v[i].y);
    }
    for(int i=1;i<=n;i++)
        for(int j=i+1;j<=n;j++)
    {
        cost[i][j]=INF;
        cost[i][j]=cost[j][i]=sqrt(1.0*(v[i].x-v[j].x)*(v[i].x-v[j].x)+1.0*(v[i].y-v[j].y)*(v[i].y-v[j].y));
    }
    prim();
    for(int i=1;i<p;i++)
        path.pop();
    printf("%.2f\n",path.top());
   }
    return 0;
}

POJ 2349 Prim

时间: 2024-10-06 00:54:02

POJ 2349 Prim的相关文章

poj 2349 Arctic Network (prim算法)

Arctic Network Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 10525   Accepted: 3470 Description The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication tec

POJ 2349 Arctic Network 最小生成树题解

本题也是使用Prime和Kruskal都可以的最小生成树的题解. 本题一点新意就是:需要除去最大的S-1个距离,因为可以使用卫星覆盖这些距离. 技巧:建图建有向图,速度快点,不用计算两边. 这里使用Prime,因为是稠密图. #include <stdio.h> #include <math.h> #include <stdlib.h> #include <string.h> #include <limits.h> #include <al

poj 2485(prim最小生成树)

Highways Description The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They're planning to build some highways

POJ 2031 prim

Building a Space Station Time Limit: 1000MS Memory Limit: 30000K Total Submissions: 4400 Accepted: 2255 Description You are a member of the space station engineering team, and are assigned a task in the construction process of the station. You are ex

poj 2349 Arctic Network MST/二分答案

poj 2349 Arctic Network 题目传送 Sol: 方法一: 贪心的想,发现n个点只需要n-1条边即可,求MST即可,再把MST中最大的m-1条边去掉,第m大就是答案. code: #include<string> #include<cmath> #include<cstdio> #include<cstring> #include<algorithm> #define IL inline #define RG register

(最小生成树) Arctic Network -- POJ --2349

链接: http://poj.org/problem?id=2349 代码: #include <cstdio> #include <cstring> #include <cstdlib> #include <cmath> #include <iostream> #include <algorithm> using namespace std; const int N = 510; const int INF = 0xfffffff;

poj 2349 Arctic Network(最小生成树的第k大边证明)

题目链接: http://poj.org/problem?id=2349 题目大意: 有n个警戒部队,现在要把这n个警戒部队编入一个通信网络, 有两种方式链接警戒部队:1,用卫星信道可以链接无穷远的部队. 2,用信号收发器可以链接周围d米以内的部队. 现在有s个卫星信道,问d最小是多少时能连接全部的警戒部队? 解题思路: 我是用求最小生成树,记录路径长度,对路径长度排序后,第k长的边就是答案, 但是队友是用最小k度限制生成树,因为我的方法它证明不了,也推翻不了~~~~, 最后我下去仔细想了想反证

Poj(1251),Prim字符的最小生成树

题目链接:http://poj.org/problem?id=1251 字符用%s好了,方便一点. #include <stdio.h> #include <string.h> #define INF 0x3f3f3f3f int maps[305][305]; bool vis[305]; int dis[305]; int n; int Prim() { memset(vis,false,sizeof(vis)); for(int i=1; i<=n; i++) dis[

Arctic Network poj 2349

http://poj.org/problem?id=2349 题意:现有 m 个地点, n 个卫星.  卫星有一个神奇的作用, 作用在于只要某个地方安装有卫星, 不论他们之间距离为多远, 都能够互相接收到彼此间信 号, (这么好的东西当然不会让每个地方都有的), 那么其他地方需要通过收发器 D 来连接.让你求1 - m 个地方在共安装过 n 个卫星后,我们所需要     的 收发器 D 所需的最大距离是多少?   *****一开始提交错误仍然是因为%lf和%f,吸取吸取教训... *******