[1204 寻找子串位置] 解题报告

题目描述 Description

给出字符串a和字符串b,保证b是a的一个子串,请你输出b在a中第一次出现的位置。

输入描述 Input Description

仅一行包含两个字符串a和b

输出描述 Output Description

仅一行一个整数

样例输入 Sample Input

abcd bc

样例输出 Sample Output

2

数据范围及提示 Data Size & Hint

字符串的长度均不超过100

Pascal用户请注意:两个字符串之间可能包含多个空格

#include <stdio.h>

// 寻找子串位置
inline int findSubStrLocation(int *str,int *subStr){
    int *p = str,*q = NULL,*p_move = NULL;  // p指向主串,p_temp为p的滑动指针,q指向子串
    while (*p != '\0') {
        q = subStr;
        p_move = p;
        while (*q != '\0') {
            // 滑动匹配,滑动过程中出现不匹配直接跳出循环,如果一直匹配到最后一个字符则返回位置
            if (*p_move != *q) {
                break;
            }else{
                q++;
                p_move++;
            }

            if (*q == '\0') {
                return (int)(p - str + 1);
            }
        }
        p++;
        q = subStr;
    }
    return NULL;
}

int main(){

    int str[100],subStr[100],i = 0;
    char temp = NULL;

    while ((temp = getchar()) != ' ') {
        str[i++] = temp;
    }
    str[i] = '\0';
    i = 0;

    while ((temp = getchar()) != '\n') {
        if (temp != ' ') {      // 中间多个空格处理
            subStr[i++] = temp;
        }
    }
    subStr[i] = '\0';

    printf("%d\n",findSubStrLocation(str,subStr));

    return 0;
}
时间: 2024-11-06 10:58:02

[1204 寻找子串位置] 解题报告的相关文章

Wikioi 1204寻找子串位置(strstr()函数)

1204 寻找子串位置 题目描述 Description 给出字符串a和字符串b,保证b是a的一个子串,请你输出b在a中第一次出现的位置. 输入描述 Input Description 仅一行包含两个字符串a和b 输出描述 Output Description 仅一行一个整数 样例输入 Sample Input abcd bc 样例输出 Sample Output 2 数据范围及提示 Data Size & Hint 字符串的长度均不超过100 Pascal用户请注意:两个字符串之间可能包含多个

1204 寻找子串位置

1204 寻找子串位置 时间限制: 1 s 空间限制: 128000 KB 题目等级 : 青铜 Bronze 题目描述 Description 给出字符串a和字符串b,保证b是a的一个子串,请你输出b在a中第一次出现的位置. 输入描述 Input Description 仅一行包含两个字符串a和b 输出描述 Output Description 仅一行一个整数 样例输入 Sample Input abcd bc 样例输出 Sample Output 2 数据范围及提示 Data Size & H

codevs 1204 寻找子串位置

题目描述 Description 给出字符串a和字符串b,保证b是a的一个子串,请你输出b在a中第一次出现的位置. 输入描述 Input Description 仅一行包含两个字符串a和b 输出描述 Output Description 仅一行一个整数 样例输入 Sample Input abcd bc 样例输出 Sample Output 2 数据范围及提示 Data Size & Hint 字符串的长度均不超过100 Pascal用户请注意:两个字符串之间可能包含多个空格 //详细的KMP讲

寻找子串位置 codevs 1204

题目描述 Description 给出字符串a和字符串b,保证b是a的一个子串,请你输出b在a中第一次出现的位置. 输入描述 Input Description 仅一行包含两个字符串a和b 输出描述 Output Description 仅一行一个整数 样例输入 Sample Input abcd bc 样例输出 Sample Output 2 数据范围及提示 Data Size & Hint 字符串的长度均不超过100 代码: #include<iostream>#include&l

CODE[VS]-寻找子串位置-字符串处理-天梯青铜

题目描述 Description 给出字符串a和字符串b,保证b是a的一个子串,请你输出b在a中第一次出现的位置. 输入描述 Input Description 仅一行包含两个字符串a和b 输出描述 Output Description 仅一行一个整数 样例输入 Sample Input abcd bc 样例输出 Sample Output 2 数据范围及提示 Data Size & Hint 字符串的长度均不超过100 Pascal用户请注意:两个字符串之间可能包含多个空格 思路:因为它是用一

【CODEVS1204】寻找子串位置

Description 给出字符串a和字符串b,保证b是a的一个子串,请你输出b在a中第一次出现的位置. Input 仅一行包含两个字符串a和b Output 仅一行一个整数 Sample Input abcd bc Sample Output 2 Hint 字符串的长度均不超过100 Pascal用户请注意:两个字符串之间可能包含多个空格 #include<iostream> #include<cstring> using namespace std; char a[110],b

codevs1204 寻找子串位置

题目描述 Description 给出字符串a和字符串b,保证b是a的一个子串,请你输出b在a中第一次出现的位置. 输入描述 Input Description 仅一行包含两个字符串a和b 输出描述 Output Description 仅一行一个整数 样例输入 Sample Input abcd bc 样例输出 Sample Output 2 #include<iostream> #include<cstdio> #include<cstring> #include&

寻找子串位置&lt;codevs&gt;

KMP板子题; 如果不会可以参考其他算法书 代码: #include<iostream> #include<stdio.h> #include<stdlib.h> #include<cstring> using namespace std; string s1,s2; int len1,len2; int f[200000]; int main(){ cin>>s1>>s2; len1=s1.size(),len2=s2.size()

【解题报告】[动态规划] - PID90 / 未出现的子串

原题地址:http://www.rqnoj.cn/problem/90 解题思路:题目看起来不太像动态规划... 我用一个数组f[i][j]来表示在数组第i个元素的后面第一次出现j的位置,为-1则是没出现过. 然后每次查找最大的位置即可.如题目例子中: f   1  3  5  2  4  1  3  5  2  2  2  2  3  4  1  5  3  2----------------------------------------------------------- 1  1  6