nefu 1116

字符串加密

Problem : 1116

Time Limit : 1000ms

Memory Limit : 65536K

description

给你一段经过加密的字符串,我们称之为密文,现在请你编写程序输出它加密前的字符串(原文)。
已知原文中只包含26个小写字母,而密文中除了包含小写字母,还包含0~9十个数字字符,解密规则是:
1、密文中一个字母前面如果有数字x,那么原文的对应位置是在字母表中从这个字母开始向后移动x位得到的新字母。例如2a表示a向后移动2位,原文中对应就是c,再例如1z表示z向后移动1位,原文中对应就是a。
2、密文中一个字母前面如果没有数字,那么原文的对应位置就是该字母。

input

多组输入数据,每组数据只有一个加密后的字符串。长度不超过1000000,只包含数字字符和小写字母,其中连续数字的长度不超过9,最后一位一定是小写字母。

output

输出一行原字符串。

sample_input

happynewyear
25ia1op4un4a1vy3ba24t

sample_output

happynewyear
happynewyear
#include <iostream>
#include <math.h>
#include <stdio.h>
#include <string.h>
using namespace std;
char *ch="abcdefghijklmnopqrstuvwxyz";
char a[1200000];
int main()
{
    int i,k,j,shu,tmp,cou;
    while(scanf("%s",a)!=-1)
    {
        for(i=0;a[i]!=‘\0‘;)
        {
          k=0;shu=0;j=1;
          while(a[i]>=‘0‘&&a[i]<=‘9‘)
          {
              k++;
              i++;
          }//此时的i是那个字母
          if(k)
          {
             for(cou=1;cou<=k;cou++)
             {
                 shu=shu+(((int)a[i-cou]-48)*j);
                 j=j*10;
             }
             tmp=(a[i]-97+shu)%26;
             printf("%c",ch[tmp]);
          }
          else cout<<a[i];
          i++;
        }
        cout<<endl;
    }
    return 0;
}

//while。。很有趣。。。

//下面是之前超时的代码

#include <iostream>
#include <math.h>
#include <stdio.h>
#include <string.h>
using namespace std;
char *ch="abcdefghijklmnopqrstuvwxyz";
char a[1200000];
int main()
{
    int k,shu,tmp,i;
    while(scanf("%s",a)!=-1)
    {
        for(i=0;i<strlen(a);i++)
        {
          if(a[i]<=‘z‘&&a[i]>=‘a‘)
          {
              if(a[i-1]>‘9‘||a[i-1]<‘0‘)
              printf("%c",a[i]);
              else
              {
                  shu=(int)a[i-1]-48;
                  if(a[i-2]<=‘9‘&&a[i-2]>=‘0‘)
                  shu=shu+((int)a[i-2]-48)*10;
                  tmp=(a[i]-97+shu)%26;
                  printf("%c",ch[tmp]);
              }
          }
        }
        cout<<endl;
    }

    return 0;
}
时间: 2024-10-17 12:33:44

nefu 1116的相关文章

1116 删除元素

题目来源:https://acm.zzuli.edu.cn/zzuliacm/problem.php?id=1116Description输入一个递增有序的整型数组A有n个元素,删除下标为i的元素,使其仍保持连续有序.注意,有效下标从0开始. 定义如下两个函数分别实现删除元素操作和数组输出操作.void del(int a[], int n, int i);  /*删除数组a中下标为i的元素*/void PrintArr(int a[], int n); /*输出数组a的前n个元素*/ Inpu

hihoCoder - 1116 - 计算 (线段树)

计算 题目传送:#1116 : 计算 这里说下sum,pre,suf,ji数组的含义: sum:所求答案 pre:所有前缀积之和 suf:所有后缀积之和 ji:区间内所有数之积 以一个例子说明: 比如我们现在正在合并区间{3,4},{2,5} 而区间{3,4}所表示的 sum1=3 + 4 + 3 * 4 = 19 pre1 = 3 + 3 * 4 = 12 suf1 = 3 * 4 + 4 = 16 ji1 = 3 * 4 = 12 而区间{2,5} sum2 = 2 + 5 + 2 * 5

ACdreamOJ 1116 斐波那契数列+hash计算后缀

http://acdream.info/problem?pid=1116 Problem Description give you a string, please output the result of the following function mod 1000000007 n is the length of the string f() is the function of fibonacci, f(0) = 0, f(1) = 1... a[i] is the total numb

nefu 462 fib组合

nefu 462 fib组合 (斐波那契数列的通项公式以及推倒过程) 分类: 数学2014-05-21 10:27 190人阅读 评论(0) 收藏 举报 题目链接:http://acm.nefu.edu.cn/JudgeOnline/problemshow.php?problem_id=462 斐波那契数列的通项公式 推倒过程: 对于本题分析: 最后一行的一个变形为(6-2√5)^2/4 代码 [cpp] view plaincopyprint? #include <iostream> usi

Hdu 1116 Play on Words

Problem地址:http://acm.hdu.edu.cn/showproblem.php?pid=1116 一道关于欧拉回路的题.由于刚刚接触欧拉图,所以收集了一些资料: 关于欧拉图的相关定义: 若图G中存在这样一条路径,使得它恰通过G中每条边一次,则称该路径为欧拉路径.若该路径是一个圈,则称为欧拉(Euler)回路. 具有欧拉路径的图称为欧拉图(简称E图). 判断欧拉路是否存在的方法: 有向图:图连通,有一个顶点出度大入度1,有一个顶点入度大出度1,其余都是出度=入度. 无向图:图连通,

HDU 1116

http://acm.hdu.edu.cn/showproblem.php?pid=1116 判断有向图欧拉回路和欧拉通路 有向图: 欧拉回路:图联通,所有顶点出度等于入度(通过图中每条边且只通过一次,并且经过每一顶点的回路.) 欧拉通路:图联通,除起点终点所有顶点出度等于入度,起点的出度-入度=1,终点的入度-出度=1(通过图中每条边且只通过一次,并且经过每一顶点的通路.) 图联通均用并查集判断 #include <iostream> #include <cstdio> #inc

NEFU 84 - 五指山 - [exgcd求解一元线性同余方程]

题目链接:http://acm.nefu.edu.cn/JudgeOnline/problemShow.php?problem_id=84 Time Limit:1000ms Memory Limit:65536K Description 西游记中孙吾空大闹天宫,如来佛祖前来降伏他,说道:"我与你打个赌赛:你若有本事,一筋斗打出我这右手掌中,算你赢,再不用动刀兵苦争战,就请玉帝到西方居住,把天宫让你:若不能打出手掌,你还下界为妖,再修几劫,却来争吵." 那大圣闻言,暗笑道:"

【BZOJ 1116】 [POI2008]CLO

1116: [POI2008]CLO Time Limit: 10 Sec  Memory Limit: 162 MB Submit: 612  Solved: 333 [Submit][Status] Description Byteotia城市有n个 towns m条双向roads. 每条 road 连接 两个不同的 towns ,没有重复的road. 你要把其中一些road变成单向边使得:每个town都有且只有一个入度 Input 第一行输入n m.1 <= n<= 100000,1 &

NEFU 116 两仪剑法 【求最小公倍数】

题目链接:http://acm.nefu.edu.cn/JudgeOnline/status.php?problem_id=116&order=1 解题思路:求最小公倍数 #include<stdio.h> long long gcd(long long a,long long b) { if(b==0) return a; else return gcd(b,a%b); } int main() { long long m,n; while(scanf("%lld %lld