LightOJ 1138

Description:

You task is to find minimal natural number N, so that N! contains exactly Q zeroes on the trail in decimal notation. As you know N! = 1*2*...*N. For example, 5! = 120, 120 contains one zero on the trail.

Input:

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer Q (1 ≤ Q ≤ 108) in a line.

Output:

For each case, print the case number and N. If no solution is found then print ‘impossible‘.

Sample Input:

3

1

2

5

Sample Output:

Case 1: 5

Case 2: 10

Case 3: impossible

题意:找阶乘尾0的个数是q的数,输出最小的那个。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int Solve(int n) ///计算n的阶乘的尾0个数
{
    int sum = 0;

    while (n)
    {
        sum += n/5;
        n /= 5;
    }

    return sum;
}

int main ()
{
    int T, q, k = 0, i, mid, j, x, y;

    scanf("%d", &T);

    while (T--)
    {
        scanf("%d", &q);

        k++;
        x = -1;

        i = 1; j = 1e9;

        while (i <= j) ///用二分搜索枚举1e9以内的数的阶乘尾数0的个数,保存在y中
        {
            mid = (i+j)/2;

            y = Solve(mid);

            if (y >= q) ///如果找到的尾数0的个数比q大,继续查找左边区间
            {
                j = mid-1;
                if (y == q) ///如果找到的尾数0的个数等于q,保存这个值终止循环
                {
                    x = mid;
                    break;
                }
            }
            else i = mid+1; ///如果找到的尾数0的个数比q小,继续查找右边区间
        }

        if (x % 5 != 0) x = x-x%5; ///因为题目要求找到最小的x  所以要对x向下取整
                                  ///(eg: q==3 时  二分查找到的x可能是15,16,17,18,19)
        if (x == 0) x = -1; ///可能找不到某个数的阶乘有q个0
        if (x == -1) printf("Case %d: impossible\n", k);
        else printf("Case %d: %d\n", k, x);
    }

    return 0;
}
时间: 2024-10-07 14:50:07

LightOJ 1138的相关文章

LightOj 1138 - Trailing Zeroes (III) 阶乘末尾0的个数 &amp; 二分

题目链接:http://lightoj.com/volume_showproblem.php?problem=1138 题意:给你一个数n,然后找个一个最小的数x,使得x!的末尾有n个0:如果没有输出impossible 可以用二分求结果,重点是求一个数的阶乘中末尾含有0的个数,一定和因子5和2的个数有关,因子为2的明显比5多,所以我们只需要求一个数的阶乘的因子中一共有多少个5即可; LL Find(LL x) { LL ans = 0; while(x) { ans += x/5; x /=

LightOJ 1138 二分

1138 - Trailing Zeroes (III)   PDF (English) Statistics Forum Time Limit: 2 second(s) Memory Limit: 32 MB You task is to find minimal natural number N, so that N! contains exactly Q zeroes on the trail in decimal notation. As you know N! = 1*2*...*N.

Trailing Zeroes (III) -;lightoj 1138

Trailing Zeroes (III)   PDF (English) Statistics Forum Time Limit: 2 second(s) Memory Limit: 32 MB You task is to find minimal natural number N, so that N! contains exactly Q zeroes on the trail in decimal notation. As you know N! = 1*2*...*N. For ex

light_oj 1138 求阶乘后导零的个数

light_oj 1138  求阶乘后导零的个数 N - Trailing Zeroes (III) Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu Submit Status Practice LightOJ 1138 Description You task is to find minimal natural number N, so that N! contains exactly Q 

light oj 1138

Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu Submit Status Practice LightOJ 1138 Description You task is to find minimal natural number N, so that N! contains exactly Q zeroes on the trail in decimal notation. As you kno

kuangbin 带你飞 数学基础

模版整理: 晒素数 void init() { cas = 0; for (int i = 0 ; i < MAXD ; i++) is_prime[i] = true; is_prime[0] = is_prime[1] = false; for (int i = 2 ; i < MAXD ; i++) { if (is_prime[i]) { prime[cas++] = i; for (int j = i + i ; j < MAXD ; j += i) is_prime[j] =

LightOJ Trailing Zeroes (III) 1138【二分搜索+阶乘分解】

1138 - Trailing Zeroes (III) PDF (English) Statistics Forum Time Limit: 2 second(s) Memory Limit: 32 MB You task is to find minimal natural number N, so that N! contains exactly Q zeroes on the trail in decimal notation. As you know N! = 1*2*...*N. F

LightOJ 1030 Discovering Gold【概率】

题目链接:http://www.lightoj.com/volume_showproblem.php?problem=1030 题意:基础概率题. 代码: #include <stdio.h> #include <string.h> #include <vector> #include <string> #include <algorithm> #include <iostream> #include <iterator>

51nod 1138 连续整数的和(数学)

题目描述: http://www.51nod.com/onlineJudge/questionCode.html#!problemId=1138 给出一个正整数N,将N写为若干个连续数字和的形式(长度 >= 2).例如N = 15,可以写为1 + 2 + 3 + 4 + 5,也可以写为4 + 5 + 6,或7 + 8.如果不能写为若干个连续整数的和,则输出No Solution. Input 输入1个数N(3 <= N <= 10^9). OutPut 输出连续整数中的第1个数,如果有多