hdu 1301 最小生成树prim实现

http://acm.hdu.edu.cn/showproblem.php?pid=1301

Jungle Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4145    Accepted Submission(s): 3020

Problem Description


The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.

The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.

The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.

Sample Input

9

A 2 B 12 I 25

B 3 C 10 H 40 I 8

C 2 D 18 G 55

D 1 E 44

E 2 F 60 G 38

F 0

G 1 H 35

H 1 I 35

3

A 2 B 10 C 40

B 1 C 20

0

Sample Output

216

30

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-

经典的prim算法,但是要注意存入图的方式,并且要注意是无向图,赋值要对称赋值

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>

#define Maxint 0x7fffffff

int map[105][105],visit[105],low[105];
int n;

int prim()
{
    int pos=1,i,j,minn,sum=0;
    memset(visit,0,sizeof(visit));
    visit[1]=1;
    for(i=1;i<=n;i++)
    {
        if(i!=pos)
        {
            low[i]=map[pos][i];
        }
    }

    for(i=1;i<n;i++)
    {
        minn=Maxint;
        for(j=1;j<=n;j++)
        {
            if(visit[j]==0 && minn>low[j])
            {
                minn=low[j];
                pos=j;
            }
        }

        sum+=minn;
        visit[pos]=1;

        for(j=1;j<=n;j++)
        {
            if(visit[j]==0 && low[j]>map[pos][j])
            {
                low[j]=map[pos][j];
            }
        }
    }
    return sum;
}

int main()
{
    int i,j;
    while(scanf("%d",&n)!=EOF&&n!=0)
    {
        char a,b,c;
        int m,k;
        for(i=1;i<=n;i++)
            for(j=1;j<=n;j++)
            map[i][j]=Maxint;
        getchar();
        for(i=1;i<n;i++)
        {
            scanf("%c%d%*c",&a,&m);
            //getchar();
            for(j=1;j<=m;j++)
            {
                scanf("%c%d%*c",&b,&k);
                map[a-64][b-64]=map[b-64][a-64]=k;//特别注意是无向图
            }
        }

        int result=prim();
        printf("%d\n",result);
    }
    return 0;
}

  

hdu 1301 最小生成树prim实现

时间: 2024-11-05 16:06:42

hdu 1301 最小生成树prim实现的相关文章

hdu 3371 最小生成树prim算法

Connect the Cities Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 8992    Accepted Submission(s): 2519 Problem Description In 2100, since the sea level rise, most of the cities disappear. Thoug

hdu 3371 最小生成树 prim

http://acm.hdu.edu.cn/showproblem.php?pid=3371 题目大意:告诉你有几座城市,再告诉你哪两座城市之间建路要多少钱,在给你哪几个城市之间已经有路,不需要再建.要求的是要使所有城市之间连通最小要花费多少钱. 这里我用了prim算法..保存城市之间的权值,对于已经建好的城市,将他们的权值赋为0.还有就是要判断是否能找出最小生成树,如果不可以就输出-1,如果在遍历点的时候,并不能找出一个最小的边,那么肯定就是没有最小生成树.(注意要在每个kase开始的时候将所

hdu 1233(最小生成树 prim算法)

还是畅通工程 Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 43080    Accepted Submission(s): 19636 Problem Description 某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离.省政府"畅通工程"的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相

hdu 1301(最小生成树)

Jungle Roads Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 6211    Accepted Submission(s): 4512 Problem Description The Head Elder of the tropical island of Lagrishan has a problem. A burst of

[hdoj]1301最小生成树prim

1 #include<iostream> 2 #include<string> 3 using namespace std; 4 int arr[28][28]; 5 int judge[28]; 6 7 int main() 8 { 9 10 int n; 11 while(cin >> n&&n) 12 { 13 int i,j,pri,count; 14 char C; 15 memset(arr,0,sizeof(arr)); 16 memset

hdu 1301 Jungle Roads (基础最小生成树)

题目: 链接:点击打开链接 题意: 对n个村庄之间的路进行修理, 然后是n-1行,每行的第一组数据时一个大写字母VIL和一个数K,Vil表示从这个村庄出发,K表示刚才的那个字母代表的村庄和其他村庄的路的数目,接下来在同一行是K组数据,每组是一个大写字母和一个数,大写字母表示和第一个村庄连接的村庄,数表示维修他们之间的路所需的费用.现在为了使维修费油最低,只需所维修的路使每个村庄都是直接或间接的连接即可,求最小的费用. 思路: 只需把输入数据处理好即可.其他都是kruskal模板.' 代码: #i

HDU 1162 Eddy&#39;s picture (最小生成树 prim)

题目链接 Problem Description Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the res

hdu 1301 Jungle Roads

链接:hdu 1301 题意:n个村庄,已知n-1村庄分别到其他村庄修路的费用,求是n个村庄连通的最小费用 分析:这个是最小生成树的题,只不过村庄的编号为A-Z的大写字母,操作比较麻烦,可以将其对应转化为1-26, 这样就与普通的最小生成树题一样了 #include<cstdio> #include<algorithm> using namespace std; int f[50],n,m; struct stu { int a,b,c; }t[300]; int cmp(stru

poj1861 最小生成树 prim &amp; kruskal

// poj1861 最小生成树 prim & kruskal // // 一个水题,为的只是回味一下模板,日后好有个照应不是 #include <cstdio> #include <algorithm> #include <cstring> #include <vector> #include <iostream> using namespace std; const int MAX_N = 1008; const int INF =