hdu 4932 Miaomiao's Geometry(暴力枚举)

Miaomiao‘s Geometry

                                                                             Time Limit: 2000/1000 MS (Java/Others)    Memory Limit:
65536/65536 K (Java/Others)

Problem Description

There are N point on X-axis . Miaomiao would like to cover them ALL by using segments with same length.

There are 2 limits:

1.A point is convered if there is a segments T , the point is the left end or the right end of T.

2.The length of the intersection of any two segments equals zero.

For example , point 2 is convered by [2 , 4] and not convered by [1 , 3]. [1 , 2] and [2 , 3] are legal segments , [1 , 2] and [3 , 4] are legal segments , but [1 , 3] and [2 , 4] are not (the length of intersection doesn‘t equals zero), [1 , 3] and [3 , 4]
are not(not the same length).

Miaomiao wants to maximum the length of segements , please tell her the maximum length of segments.

For your information , the point can‘t coincidently at the same position.

Input

There are several test cases.

There is a number T ( T <= 50 ) on the first line which shows the number of test cases.

For each test cases , there is a number N ( 3 <= N <= 50 ) on the first line.

On the second line , there are N integers Ai (-1e9 <= Ai <= 1e9) shows the position of each point.

Output

For each test cases , output a real number shows the answser. Please output three digit after the decimal point.

Sample Input

3
3
1 2 3
3
1 2 4
4
1 9 100 10

Sample Output

1.000
2.000
8.000

Hint

For the first sample , a legal answer is [1,2] [2,3] so the length is 1.
For the second sample , a legal answer is [-1,1] [2,4] so the answer is 2.
For the thired sample , a legal answer is [-7,1] , [1,9] , [10,18] , [100,108] so the answer is 8.

题意:给出n个点,找出一些等长的线段覆盖这些点,这些点只能作为线段的端点,而且任意两条线段的相交长度不能大于0.求满足条件的线段的最大长度。

分析:通过分析可以得出,最终结果是相邻两点之间的长度,或者相邻两点之间长度的一半。因为最多只有50个点,100个长度,所以只需枚举这些长度,求出一个满足条件的最长线段即可。

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
    double b[120], c[60];
    int flag[60];
    int n, i, j, T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(i = 0; i < n; i++)
            scanf("%lf",&c[i]);
        sort(c, c+n);
        int m = 0;
        for(i = 1; i < n; i++)
        {
            b[m++] = c[i] - c[i-1];
            b[m++] = (c[i] - c[i-1]) / 2;
        }
        sort(b, b+m);
        double ans;
        for(i = m - 1; i >= 0; i--)
        {
            memset(flag, 0, sizeof(flag));
            flag[0] = 1;
            double tmp = b[i];
            for(j = 1; j < n - 1; j++)
            {
                if(c[j] - tmp < c[j-1] && c[j] + tmp > c[j+1])  //往左往右都不行
                    break;
                if(c[j] - tmp >= c[j-1])
                {
                    if(flag[j-1] == 2) // 前一个往右
                    {
                        if(c[j] - c[j-1] == tmp) flag[j] = 1;  //两个点作为线段的两个端点
                        else if(c[j] - c[j-1] >= 2 * tmp) flag[j] = 1; //一个往左,一个往右
                        else if(c[j] + tmp <= c[j+1]) flag[j] = 2; //只能往右
                        else break;
                    }
                    else flag[j] = 1;
                }
                else if(c[j] + tmp <= c[j+1])
                    flag[j] = 2;
            }
            if(j == n - 1)
            {
                ans = tmp;
                break;
            }
        }
        printf("%.3lf\n", double(ans));
    }
    return 0;
}

hdu 4932 Miaomiao's Geometry(暴力枚举)

时间: 2024-10-08 10:52:20

hdu 4932 Miaomiao's Geometry(暴力枚举)的相关文章

hdu 4932 Miaomiao&#39;s Geometry 暴力枚举

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4932 Miaomiao's Geometry Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 694    Accepted Submission(s): 180 Problem Description There are N point

hdu 4932 Miaomiao&#39;s Geometry(暴力)

题目链接:hdu 4932 Miaomiao's Geometry 题目大意:在x坐标上又若干个点,现在要用若干条相等长度的线段覆盖这些点,若一个点被一条线段覆盖,则必须在这条线的左端点或者是右端点,并且各个线段放的位置不能又重叠,求最大长度. 解题思路:这题有坑点,比赛的时候o(n)的算法去寻找两点之间最短距离.但起始这样是不行的,比如-1 0 10 12 18 20,这样维护过去的话,最短应该是12~18,长度为6,这段线段可以覆盖12和18的点,然后-1和20又在两端.于是只有0和10两点

HDU 4932 Miaomiao&#39;s Geometry

答案只可能有两种情况 要么是已知点的距离 要么是已知点距离的一半 那么就枚举每个点之间的距离 和距离的一半 先把所有点按照升序排序 然后用枚举的值贪心 对于点A[i] 如果能放[[A[i]-now,A[i]]就放 否则就放[A[i],A[i]+now] #include<bits/stdc++.h> using namespace std; double a[120],b[120]; int main() { int T,N; scanf("%d",&T); for

hdu 4932 Miaomiao&#39;s Geometry 解题报告

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4932 题目意思:给出 n 个点你,需要找出最长的线段来覆盖所有的点.这个最长线段需要满足两个条件:(1)每个点是某条线段的左端点或右端点   (2)任意两条线段之间的重叠部分的长度为0.(一个点重叠默认长度为0,即[1,2] , [2, 3] 视为合法).还有一点我来补充吧,就是这个最大长度是固定的,看第3组测试数据  1 9 100 10,[-7,1] , [1,9] , [10,18] , [1

HDU 4932 Miaomiao&#39;s Geometry(推理)

HDU 4932 Miaomiao's Geometry 题目链接 题意:给定x轴上一些点(不重复),现在要选一个线段,使得能放进这些区间中,保证线段不跨过点(即线段上只能是最左边或最右边是点),并且没有线段相交,求能放进去的最大线段 思路:推理一下,只有两点之间的线段,还有线段的一半可能符合题意,然后对于每种线段,去判断一下能不能成功放进去,这步用贪心,优先放左边,不行再放右边 代码: #include <cstdio> #include <cstring> #include &

HDU 4932 Miaomiao&#39;s Geometry(BestCoder Round #4)

Problem Description: There are N point on X-axis . Miaomiao would like to cover them ALL by using segments with same length. There are 2 limits: 1.A point is convered if there is a segments T , the point is the left end or the right end of T.2.The le

[BestCoder Round #4] hdu 4932 Miaomiao&#39;s Geometry (贪心)

Miaomiao's Geometry Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 363    Accepted Submission(s): 92 Problem Description There are N point on X-axis . Miaomiao would like to cover them ALL by

hdu 4932 Miaomiao&amp;#39;s Geometry(暴力枚举)

Miaomiao's Geometry                                                                              Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Problem Description There are N point on X-axis . Miaomiao would like

hdoj 4932 Miaomiao&#39;s Geometry 【暴力枚举】

题意:在一条直线上有n个点,取一长度差为x的区间, 规定点必须是区间的端点, 让你找出来最大的x 策略:rt 分析可得:两个相邻点之间的区间要么是两个点的差,要么就是两个点的差的一半,那我们就简单枚举一下就好了 排好序之后再枚举 代码: #include <cstdio> #include <cstring> #include <algorithm> #include <cmath> #define M 200 using namespace std; do