POJ 3468-A Simple Problem with Integers(线段树:成段更新,区间求和)

A Simple Problem with Integers

Time Limit: 5000MS   Memory Limit: 131072K
Total Submissions: 62228   Accepted: 19058
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is
to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.

The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.

Each of the next Q lines represents an operation.

"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.

"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15
感觉成段更新好难,lazy数组标记用的很巧妙,以后多做题一定要把它理解透了。
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cctype>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <list>
#define L long long
using namespace std;
const int INF=1<<27;
const int maxn=500010;
L lazy[maxn],sum[maxn];
void push_up(int root)
{
	sum[root]=sum[root*2]+sum[root*2+1];
}
void push_down(int root,int l,int r)
{
	if(lazy[root])
	{
		int m=r-l+1;
		lazy[root*2]+=lazy[root];
		lazy[root*2+1]+=lazy[root];
		sum[root*2]+=(m-m/2)*lazy[root];
		sum[root*2+1]+=(m/2)*lazy[root];
		lazy[root]=0;
	}
}
void update(int root,int l,int r,int ql,int qr,L v)
{
	if(ql>r||qr<l) return ;
	if(ql<=l&&qr>=r)
	{
		lazy[root]+=v;
		sum[root]+=(v*(r-l+1));
		return ;//
	}
	int mid=(l+r)/2;
    push_down(root,l,r);
    update(root*2,l,mid,ql,qr,v);
    update(root*2+1,mid+1,r,ql,qr,v);
    push_up(root);
}
L query_sum(int root,int l,int r,int ql,int qr)
{
	if(ql>r||qr<l) return 0;
	if(ql<=l&&qr>=r) return sum[root];
	push_down(root,l,r);
	int mid=(l+r)/2;
	return query_sum(root*2,l,mid,ql,qr)+query_sum(root*2+1,mid+1,r,ql,qr);
}
int main()
{
    int n,Q,i,ql,qr;L v;char op;
    scanf("%d%d",&n,&Q);
  	//memset(lazy,0,sizeof(lazy));
  	//memset(sum,0,sizeof(sum));
  	for(i=1;i<=n;i++)
	{
		scanf("%lld",&v);
		update(1,1,n,i,i,v);
	}
	while(Q--)
	{
		getchar();
		scanf("%c",&op);
		if(op=='Q')
		{
			scanf("%d%d",&ql,&qr);
			printf("%lld\n",query_sum(1,1,n,ql,qr));
		}
		else
		{
			scanf("%d%d%lld",&ql,&qr,&v);
		    update(1,1,n,ql,qr,v);
		}
	}
  return 0;
}

POJ 3468-A Simple Problem with Integers(线段树:成段更新,区间求和)

时间: 2024-11-12 09:46:33

POJ 3468-A Simple Problem with Integers(线段树:成段更新,区间求和)的相关文章

POJ 3468 A Simple Problem with Integers 线段树成段更新

线段树功能 update:成段更新  query:区间求和 #include <iostream> #include <string> #include <cstdio> #define lson l, m, rt<<1 #define rson m+1, r, rt<<1|1 using namespace std; typedef long long ll; const int MAXN = 111111; ll sum[MAXN<&l

【POJ】3468 A Simple Problem with Integers ——线段树 成段更新 懒惰标记

A Simple Problem with Integers Time Limit:5000MS   Memory Limit:131072K Case Time Limit:2000MS Description You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each

POJ3468_A Simple Problem with Integers(线段树/成段更新)

解题报告 题意: 略 思路: 线段树成段更新,区间求和. #include <iostream> #include <cstring> #include <cstdio> #define LL long long #define int_now int l,int r,int root using namespace std; LL sum[500000],lazy[500000]; void push_up(int root,int l,int r) { sum[ro

A Simple Problem with Integers 线段树 成段更新

Time Limit:5000MS     Memory Limit:131072KB     64bit IO Format:%I64d & %I64u Submit Status Practice POJ 3468 Description You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given

POJ 3468 A Simple Problem with Integers(线段树区间更新)

题目地址:POJ 3468 打了个篮球回来果然神经有点冲动..无脑的狂交了8次WA..居然是更新的时候把r-l写成了l-r... 这题就是区间更新裸题.区间更新就是加一个lazy标记,延迟标记,只有向下查询的时候才将lazy标记向下更新.其他的均按线段树的来就行. 代码如下: #include <iostream> #include <cstdio> #include <cstring> #include <math.h> #include <stac

poj 3468 A Simple Problem with Integers 线段树第一次 + 讲解

A Simple Problem with Integers Description You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of

POJ 3468 A Simple Problem with Integers (线段树区域更新)

A Simple Problem with Integers Time Limit: 5000MS   Memory Limit: 131072K Total Submissions: 62431   Accepted: 19141 Case Time Limit: 2000MS Description You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of

[POJ] 3468 A Simple Problem with Integers [线段树区间更新求和]

A Simple Problem with Integers Description You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of

POJ 3468 A Simple Problem with Integers //线段树的成段更新

A Simple Problem with Integers Time Limit: 5000MS   Memory Limit: 131072K Total Submissions: 59046   Accepted: 17974 Case Time Limit: 2000MS Description You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of

poj 3468 A Simple Problem with Integers 线段树加延迟标记

A Simple Problem with Integers Description You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of