zoj 3818 Pretty Poem (模拟)

ZOJ Problem Set - 3818

Pretty Poem


Time Limit: 2 Seconds     
Memory Limit: 65536 KB



Poetry is a form of literature that uses aesthetic and rhythmic qualities of language. There are many famous poets in the contemporary era. It is said that a few ACM-ICPC contestants can even write poetic code. Some poems has a strict rhyme scheme like "ABABA"
or "ABABCAB". For example, "niconiconi" is composed of a rhyme scheme "ABABA" with A = "ni" and B = "co".

More technically, we call a poem pretty if it can be decomposed into one of the following rhyme scheme: "ABABA" or "ABABCAB". The symbol
A, B and C are different continuous non-empty substrings of the poem. By the way, punctuation characters should be ignored when considering the rhyme scheme.

You are given a line of poem, please determine whether it is pretty or not.

Input

There are multiple test cases. The first line of input contains an integer
T
indicating the number of test cases. For each test case:

There is a line of poem S (1 <= length(S) <= 50). S will only contains alphabet characters or punctuation characters.

Output

For each test case, output "Yes" if the poem is pretty, or "No" if not.

Sample Input

3
niconiconi~
pettan,pettan,tsurupettan
wafuwafu

Sample Output

Yes
Yes
No

给你一个窜,取出里面的字母,问是否满足  ABABA  或  ABABCAB,形似

思路:

分别两个函数判断,判断两种形式,ABABA  的枚举AB的长度,可以变成XYZ  形式,判断X==Y,然后从X中取出Z长度的字符串,判断是否和Z相等,还有Z与X剩余的窜必须不相等(A!=B);

对于ABABCAB 基本相似;

上代码了:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define N 55

char a[N],b[N];
int k;
int vis[N];

int judge()
{
    int i,j;

    char x[N],y[N],z[N];
    int xx,yy,zz;

    for(i=2;i*2<k;i++)
    {
         for(j=0;j<i;j++)
            {
                x[j]=b[j];
            }
          x[j]='\0';

          yy=0;
          for(j;j<i*2;j++)
          {
              y[yy++]=b[j];
          }
          y[yy]='\0';

          if(strcmp(x,y)!=0)  continue;

          zz=0;
          for(j;b[j];j++)
            z[zz++]=b[j];
          z[zz]='\0';

          if(zz>=i) continue;

          char A[N],B[N];
          int AA,BB;

          for(j=0;j<zz;j++)
            A[j]=b[j];

          A[j]='\0';

          if(strcmp(A,z)!=0) continue;

          BB=0;
          for(j;j<i;j++)
            B[BB++]=b[j];
          B[BB]='\0';

          if(strcmp(A,B)==0)  continue;

          //printf("x=%s\ny=%s\nz=%s\n",x,y,z);
          //printf("A=%s\nB=%s\n",A,B);
          return 1;
    }
    return 0;
}

int judgee()
{
    int i,j;
    int vis[N];
    char x[N],y[N],z[N],w[N];
    int xx,yy,zz,ww;

    for(i=2;i*3<k;i++)
    {
        memset(vis,0,sizeof(vis));

        int xx=0;
        for(j=0;j<i;j++)
        {
            x[j]=b[j];
            vis[j]=1;
        }
        x[j]='\0';

        yy=0;
        for(j;j<i*2;j++)
        {
            y[yy++]=b[j];
            vis[j]=1;
        }
        y[yy]='\0';

        zz=0;
        j=k-i;

        for(;b[j];zz++,j++)
        {
            vis[j]=1;
            z[zz]=b[j];
        }
        z[zz]='\0';

        ww=0;
        for(j=i*2;!vis[j];j++)
        {
            w[ww++]=b[j];
        }
        w[ww]='\0';

        if(strcmp(x,y)!=0) continue;

        if(strcmp(y,z)!=0) continue;

        char A[N],B[N];
        int AA,BB;

        for(j=1;j<i;j++)
        {
            int jj;
            for(jj=0;jj<j;jj++)
                A[jj]=b[jj];
              A[jj]='\0';

            BB=0;
            for(jj;jj<i;jj++)
                B[BB++]=b[jj];
            B[BB]='\0';

            if(strcmp(B,A)==0) continue;

            if(strcmp(B,w)==0)  continue;

            if(strcmp(A,w)==0)  continue;

             //printf("x=%s\ny=%s\nw=%s\nz=%s\n",x,y,w,z);
             //printf("A=%s\nB=%s\n",A,B);

            return 1;
        }
    }

    return 0;
}
int main()
{
   int i,t;
   scanf("%d",&t);
   while(t--)
   {
       scanf("%s",a);
       int len=strlen(a);
       k=0;
       for(i=0;i<len;i++)
        if(a[i]>='a'&&a[i]<='z'||a[i]>='A'&&a[i]<='Z')
        b[k++]=a[i];
       b[k]='\0';

       if(judge())
       {
           printf("Yes\n");
           continue;
       }

       if(judgee())
       {
           printf("Yes\n");
           continue;
       }

       printf("No\n");
   }
   return 0;
}

/*

2
ababa

ababcab

*/
时间: 2024-11-08 14:47:19

zoj 3818 Pretty Poem (模拟)的相关文章

ZOJ 3818 Pretty Poem 模拟题

题目链接:点击打开链接 #include <cstdio> #include <iostream> #include <cstring> #include <algorithm> using namespace std; const int N = 55; char a[N], b[N]; int main() { int T; scanf("%d", &T); while(T-- > 0) { scanf("%s

zoj 3818 Pretty Poem(模拟)

# include <stdio.h> # include <algorithm> # include <string.h> # define MAX 55 using namespace std; int L; char a[MAX]; int vis[MAX]; int judge1()//ababa { int i,j; int xx,yy,zz; char x[MAX],y[MAX],z[MAX]; for(i=2; i*2<L; i++) { for(j

ZOJ 3818 Pretty Poem (暴力模拟 string(substr))

Pretty Poem Time Limit: 2 Seconds      Memory Limit: 65536 KB Poetry is a form of literature that uses aesthetic and rhythmic qualities of language. There are many famous poets in the contemporary era. It is said that a few ACM-ICPC contestants can e

ZOJ 3818 Pretty Poem

暴力模拟 细节处理很重要... 1 #include <iostream> 2 #include <cstring> 3 #include <cstdio> 4 using namespace std; 5 6 char s1[100],s[100]; 7 int len1,len; 8 int t; 9 char a[55],b[55],c[55]; 10 11 int solved1 (int l,int len){ 12 int temp=0,j; 13 for

zoj 3818 Pretty Poem(暴力处理字符串)2014年牡丹江赛区网络赛

Pretty Poem Time Limit: 2 Seconds      Memory Limit: 65536 KB Poetry is a form of literature that uses aesthetic and rhythmic qualities of language. There are many famous poets in the contemporary era. It is said that a few ACM-ICPC contestants can e

[ACM] zoj 3818 Pretty Poem (2014 ACMICPC Regional 牡丹江站网络赛 J题)

Pretty Poem Time Limit: 2 Seconds      Memory Limit: 65536 KB Poetry is a form of literature that uses aesthetic and rhythmic qualities of language. There are many famous poets in the contemporary era. It is said that a few ACM-ICPC contestants can e

ZOJ 3818 Pretty Poem (2014年牡丹江赛区网络赛J题)

1.题目描述:点击打开链接 2.解题思路:本题是一道模拟题,输入一个串,要求判断是否形如"ABABA"或"ABABCAB".只需要对两种情况逐一尝试即可.然而这道题有诸多细节需要考虑.这里说一下我自己的方法. 首先,如果输入的串长度<5,那么直接输出No,或者去掉所有的标点后发现长度<5,输出No.长度上没问题后,写一个专门的solve(int type)函数,来判断是否是上述情况中的一种.对于第一种,只需要枚举A的长度即可,B的长度就是(len-3*i

【瞎搞】ZOJ 3818 Pretty Poem 牡丹江网络赛J题

第一种情况:ABABA. 先判断开头的A与结尾的A,得到A的长度,接着判断ABAB 中的AB与AB是否相同(ABAB的长度一定为偶数) 已经知道了A长度,AB的长度 接着判断下A 与B是否相同 第二种情况:ABABCAB-可先讲AB看成整体即DDCD 若存在一个D满足条件 可得到C的长度和位置再判断A-B是否相同A-C是否相同 B-C是否相同(暴力取A的长度咯) #include <stdio.h> #include <string.h> #include <stdlib.h

ZOJ Problem Set - 3818 Pretty Poem

水题 . #include<bits/stdc++.h> using namespace std; int T,n; char buf[55]; string s; bool ok = false; bool ok1(int a,int b) { string s1,s2; s1 = s.substr(0,a); s2 = s.substr(a,b); string buf; if(s1 == s2) return false; buf = s.substr(a+b,a); if(buf !=