hdu 4941 Magical Forest(STL map & 结构体运用)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4941

Magical Forest

Time Limit: 24000/12000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 220    Accepted Submission(s): 105

Problem Description

There is a forest can be seen as N * M grid. In this forest, there is some magical fruits, These fruits can provide a lot of energy, Each fruit has its location(Xi, Yi) and the energy can be provided Ci.

However, the forest will make the following change sometimes:

1. Two rows of forest exchange.

2. Two columns of forest exchange.

Fortunately, two rows(columns) can exchange only if both of them contain fruits or none of them contain fruits.

Your superior attach importance to these magical fruit, he needs to know this forest information at any time, and you as his best programmer, you need to write a program in order to ask his answers quick every time.

Input

The input consists of multiple test cases.

The first line has one integer W. Indicates the case number.(1<=W<=5)

For each case, the first line has three integers N, M, K. Indicates that the forest can be seen as maps N rows, M columns, there are K fruits on the map.(1<=N, M<=2*10^9, 0<=K<=10^5)

The next K lines, each line has three integers X, Y, C, indicates that there is a fruit with C energy in X row, Y column. (0<=X<=N-1, 0<=Y<=M-1, 1<=C<=1000)

The next line has one integer T. (0<=T<=10^5)

The next T lines, each line has three integers Q, A, B.

If Q = 1 indicates that this is a map of the row switching operation, the A row and B row exchange.

If Q = 2 indicates that this is a map of the column switching operation, the A column and B column exchange.

If Q = 3 means that it is time to ask your boss for the map, asked about the situation in (A, B).

(Ensure that all given A, B are legal. )

Output

For each case, you should output "Case #C:" first, where C indicates the case number and counts from 1.

In each case, for every time the boss asked, output an integer X, if asked point have fruit, then the output is the energy of the fruit, otherwise the output is 0.

Sample Input

1
3 3 2
1 1 1
2 2 2
5
3 1 1
1 1 2
2 1 2
3 1 1
3 2 2

Sample Output

Case #1:
1
2
1

Hint

No two fruits at the same location.

Author

UESTC

Source

2014 Multi-University Training Contest 7

题意:

有一个n*m的田地,里边有k棵树,每棵树的位置为(xi,yi),含有能量值ci。之后又q个询问,分三种;

1)1 a b,将a行和b行交换

2)2 a b,将a列和b列交换

3)3 a b,询问(a,b)位置的果树的能量值。

运用map,每次的交换操作只需要交换相应的映射值!

官方题解:http://blog.sina.com.cn/s/blog_6bddecdc0102uzka.html

代码如下:(结构体)

#include <cstdio>
#include <map>
#include <algorithm>
using namespace std;
struct node
{
    int x, y;
    friend bool operator < (node a, node b)
    {
        //从大到小排列
        if(a.x != b.x)
            return a.x < b.x;
        else
            return a.y < b.y;
    }
};
node pos;
map<int , int>row,col;//分别记录行和列
map<node, int>p;//优先级队列如果插入的节点是结构体类型,则要在结构体中重载比较操作符函数
int main()
{
    int t;
    int n, m, k;
    int x, y, c;
    int op, xx, yy;
    int cas = 0;
    scanf("%d",&t);
    while(t--)
    {
        int c1 = 0, c2 = 0;
        scanf("%d%d%d",&n,&m,&k);
        for(int i = 0; i < k; i++)
        {
            scanf("%d%d%d",&x, &y, &c);
            if(row[x] == 0)//离散化
                row[x] = ++c1;
            if(col[y] == 0)
                col[y] = ++c2;
            pos.x = row[x];
            pos.y = col[y];
            p[pos] = c;
        }
        int tt, tmp;
        printf("Case #%d:\n",++cas);
        scanf("%d",&tt);
        for(int i = 0; i < tt; i++)
        {
            scanf("%d%d%d",&op,&xx,&yy);
            if(op == 1)
            {
                tmp = row[xx];
                row[xx] = row[yy];
                row[yy] = tmp;
            }
            else if(op == 2)
            {
                tmp = col[xx];
                col[xx] = col[yy];
                col[yy] = tmp;
            }
            else
            {
                pos.x = row[xx];
                pos.y = col[yy];
                printf("%d\n",p[pos]);
            }
        }
    }
    return 0;
}

非结构体:

#include <cstdio>
#include <map>
#include <algorithm>
using namespace std;
map<int , map<int , int> >mm;
map<int , int> row,col;//分别记录行和列
int main()
{
    int t;
    int n, m, k;
    int x, y, c;
    int op, xx, yy;
    int cas = 0;
    scanf("%d",&t);
    while(t--)
    {
        int c1 = 0, c2 = 0;
        scanf("%d%d%d",&n,&m,&k);
        for(int i = 0; i < k; i++)
        {
            scanf("%d%d%d",&x, &y, &c);
            if(row[x] == 0)//离散化
                row[x] = ++c1;
            if(col[y] == 0)
                col[y] = ++c2;
            mm[row[x]][col[y]] = c;
        }
        int tt, tmp;
        printf("Case #%d:\n",++cas);
        scanf("%d",&tt);
        for(int i = 0; i < tt; i++)
        {
            scanf("%d%d%d",&op,&xx,&yy);
            if(op == 1)
            {
                tmp = row[xx];
                row[xx] = row[yy];
                row[yy] = tmp;
            }
            else if(op == 2)
            {
                tmp = col[xx];
                col[xx] = col[yy];
                col[yy] = tmp;
            }
            else
            {
                printf("%d\n",mm[row[xx]][col[yy]]);
            }
        }
    }
    return 0;
}

hdu 4941 Magical Forest(STL map & 结构体运用),布布扣,bubuko.com

时间: 2024-07-30 13:40:12

hdu 4941 Magical Forest(STL map & 结构体运用)的相关文章

HDU 4941 Magical Forest --STL Map应用

题意: 有n*m个格子(n,m <= 2*10^9),有k(k<=10^5)个格子中有值,现在有三种操作,第一种为交换两行,第二种为交换两列,交换时只有两行或两列都有格子有值或都没有格子有值时才能交换,第三种操作是询问现在第A行第B列值为多少. 解法:格子太大,但是k比较小,所以考虑离散一下,把行离散出来,最多10^5行,列用map存下即可. nowR[i] = j 时表示现在的第 i 行是原来的第 j 行, nowC表示列的 R[]表示该行有没有值, CntC[]表示列 然后交换时直交换上面

hdu 4941 Magical Forest (map容器)

Magical Forest Time Limit: 24000/12000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others) Total Submission(s): 135    Accepted Submission(s): 69 Problem Description There is a forest can be seen as N * M grid. In this forest, there is so

HDU 4941 Magical Forest(map映射+二分查找)杭电多校训练赛第七场1007

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4941 解题报告:给你一个n*m的矩阵,矩阵的一些方格中有水果,每个水果有一个能量值,现在有三种操作,第一种是行交换操作,就是把矩阵的两行进行交换,另一种是列交换操作,注意两种操作都要求行或列至少要有一个水果,第三种操作是查找,询问第A行B列的水果的能量值,如果查询的位置没有水果,则输出0. 因为n和m都很大,达到了2*10^9,但水果最多一共只有10^5个,我的做法是直接用结构体存了之后排序,然后m

HDU 4941 Magical Forest STL

这明明就是给纯C选手的大杀器啊. 题意:给你k坐标,表示 X,Y 有值C,有 3种操作 1) 交换A,B两行 2) 交换A,B两列 3) 询问(A,B)的值 解题思路:map离散化 解题代码: // File Name: 1007.cpp // Author: darkdream // Created Time: 2014年08月12日 星期二 21时05分18秒 #include<vector> #include<list> #include<map> #includ

hdu 4941 Magical Forest ( 双重map )

题目链接 题意: 有一个n*m的田地,里边有k棵树,每棵树的位置为(xi,yi),含有能量值ci.之后又q个询问,分三种; 1)1 a b,将a行和b行交换 2)2 a b,将a列和b列交换 3)3 a b,询问(a,b)位置的果树的能量值. 分析: hdu 4941 Magical Forest ( 双重map )

hdu 4941 Magical Forest(STL之map应用)2014多校训练第7场

Magical Forest                                                                       Time Limit: 24000/12000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others) Problem Description There is a forest can be seen as N * M grid. In this fore

STL : map函数的运用 --- hdu 4941 : Magical Forest

Magical Forest Time Limit: 24000/12000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)Total Submission(s): 724    Accepted Submission(s): 343 Problem Description There is a forest can be seen as N * M grid. In this forest, there is so

hdu 4941 Magical Forest(Map)

http://acm.hdu.edu.cn/showproblem.php?pid=4941 因为地图的行和列很大,操作次数也很多,直接循环模拟肯定不行.但可以用map映射一下,当交换行和列的时候,直接交换它们的映射值,直接O(1)进行交换. #include <stdio.h> #include <iostream> #include <map> #include <set> #include <list> #include <stack

HDU 4941 Magical Forest 【离散化】【map】

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4941 题目大意:给你10^5个点,每个点有一个数值,点的xy坐标是0~10^9,点存在于矩阵中.然后给出10^5个操作,1代表交换行,2代表交换列,3代表查询坐标为xy点的数值. 数据量很大........ 所以一直没有思路 后来赛后看了题解是先用离散化然后存在线性map里面. #include <iostream> #include <cstdio> #include <map