AC日记——逆波兰表达式 openjudge 3.3 1696

1696:逆波兰表达式

总时间限制: 
1000ms

内存限制: 
65536kB
描述
逆波兰表达式是一种把运算符前置的算术表达式,例如普通的表达式2 + 3的逆波兰表示法为+ 2 3。逆波兰表达式的优点是运算符之间不必有优先级关系,也不必用括号改变运算次序,例如(2 + 3) * 4的逆波兰表示法为* + 2 3 4。本题求解逆波兰表达式的值,其中运算符包括+ - * /四个。
输入
输入为一行,其中运算符和运算数之间都用空格分隔,运算数是浮点数。
输出
输出为一行,表达式的值。
可直接用printf("%f\n", v)输出表达式的值v。
样例输入
* + 11.0 12.0 + 24.0 35.0
样例输出
1357.000000
提示
可使用atof(str)把字符串转换为一个double类型的浮点数。atof定义在math.h中。
此题可使用函数递归调用的方法求解。
来源
计算概论05

思路:

  递归大模拟(代码直白如话);

来,上代码:

#include<cstdio>
#include<cstring>
#include<iostream>

using namespace std;

int len,now=0;

char str[100001];

double search(char type)
{
    while((str[now]!=‘*‘&&str[now]!=‘/‘&&str[now]!=‘-‘&&str[now]!=‘+‘)&&(str[now]<‘0‘||str[now]>‘9‘))
    {
        now++;
    }
    double a=0,b=0;
    if(str[now]==‘*‘||str[now]==‘-‘||str[now]==‘/‘||str[now]==‘+‘) a=search(str[now++]);
    else
    {
        bool if_=true;
        double now_=1;
        while((str[now]>=‘0‘&&str[now]<=‘9‘)||str[now]==‘.‘)
        {
            if(str[now]==‘.‘)
            {
                if_=false;
                now++;
                continue;
            }
            if(if_)
            {
                a=a*10+str[now]-‘0‘;
                now++;
            }
            else
            {
                now_*=10;
                a+=(str[now]-‘0‘)/now_;
                now++;
            }
        }
    }
    while((str[now]!=‘*‘&&str[now]!=‘/‘&&str[now]!=‘-‘&&str[now]!=‘+‘)&&(str[now]<‘0‘||str[now]>‘9‘))
    {
        now++;
    }
    if(str[now]==‘*‘||str[now]==‘-‘||str[now]==‘/‘||str[now]==‘+‘) b=search(str[now++]);
    else
    {
        bool if_=true;
        double now_=1;
        while((str[now]>=‘0‘&&str[now]<=‘9‘)||str[now]==‘.‘)
        {
            if(str[now]==‘.‘)
            {
                if_=false;
                now++;
                continue;
            }
            if(if_)
            {
                b=b*10+str[now]-‘0‘;
                now++;
            }
            else
            {
                now_*=10;
                b+=(str[now]-‘0‘)/now_;
                now++;
            }
        }
    }
    if(type==‘*‘) return a*b;
    if(type==‘/‘) return a/b;
    if(type==‘+‘) return a+b;
    if(type==‘-‘) return a-b;
}

int main()
{
    gets(str);
    len=strlen(str);
    printf("%.6lf",search(str[now++]));
    return 0;
}
时间: 2024-11-04 15:59:54

AC日记——逆波兰表达式 openjudge 3.3 1696的相关文章

noi1696 逆波兰表达式

1696:逆波兰表达式 http://noi.openjudge.cn/ch0303/1696/ 总时间限制:  1000ms 内存限制:  65536kB 描述 逆波兰表达式是一种把运算符前置的算术表达式,例如普通的表达式2 + 3的逆波兰表示法为+ 2 3.逆波兰表达式的优点是运算符之间不必有优先级关系,也不必用括号改变运算次序,例如(2 + 3) * 4的逆波兰表示法为* + 2 3 4.本题求解逆波兰表达式的值,其中运算符包括+ - * /四个. 输入 输入为一行,其中运算符和运算数之间

递归--练习10--noi1696逆波兰表达式

递归--练习10--noi1696逆波兰表达式 一.心得 递归大法好 二.题目 1696:逆波兰表达式 总时间限制:  1000ms 内存限制:  65536kB 描述 逆波兰表达式是一种把运算符前置的算术表达式,例如普通的表达式2 + 3的逆波兰表示法为+ 2 3.逆波兰表达式的优点是运算符之间不必有优先级关系,也不必用括号改变运算次序,例如(2 + 3) * 4的逆波兰表示法为* + 2 3 4.本题求解逆波兰表达式的值,其中运算符包括+ - * /四个. 输入 输入为一行,其中运算符和运算

逆波兰表达式

1696:逆波兰表达式 总时间限制: 1000ms 内存限制: 65536kB 描述 逆波兰表达式是一种把运算符前置的算术表达式,例如普通的表达式2 + 3的逆波兰表示法为+ 2 3.逆波兰表达式的优点是运算符之间不必有优先级关系,也不必用括号改变运算次序,例如(2 + 3) * 4的逆波兰表示法为* + 2 3 4.本题求解逆波兰表达式的值,其中运算符包括+ - * /四个. 输入 输入为一行,其中运算符和运算数之间都用空格分隔,运算数是浮点数. 输出 输出为一行,表达式的值.可直接用prin

lintcode 中等题:Evaluate Reverse Polish notation逆波兰表达式求值

题目 逆波兰表达式求值 在逆波兰表达法中,其有效的运算符号包括 +, -, *, / .每个运算对象可以是整数,也可以是另一个逆波兰计数表达. 样例 ["2", "1", "+", "3", "*"] -> ((2 + 1) * 3) -> 9 ["4", "13", "5", "/", "+"]

求解逆波兰表达式的值

题目: Evaluate the value of an arithmetic expression in Reverse Polish Notation. Valid operators are +, -, *, /. Each operand may be an integer or another expression. Some examples:   ["2", "1", "+", "3", "*"

[Leetcode] evaluate reverse polish notation 计算逆波兰表达式

Evaluate the value of an arithmetic expression in Reverse Polish Notation. Valid operators are+,-,*,/. Each operand may be an integer or another expression. Some examples: ["2", "1", "+", "3", "*"] -> (

栈的操作实现逆波兰表达式的计算

代码如下: #include <stdio.h> #include <stdlib.h> #include <ctype.h> #define STACK_INIT_SIZE 20 #define STACKINCREMENT 10 #define MAXBUFFER 10 typedef double ElemType; typedef struct { ElemType *base; ElemType *top; int StackSize; }sqStack; v

C++实现 逆波兰表达式计算问题

C++实现 逆波兰表达式计算问题 #include <iostream> #include <string> using namespace std; class Stack { private: int size; int top; float *listArray; public: Stack(int sz=20); ~Stack(); bool push(float it);//入栈 bool pop(float& it);//出栈 bool isEmpty();//

续前篇-关于逆波兰表达式的计算

相对于逆波兰表达式的转换,逆波兰表达的计算可谓简单不少. 具体计算方法参考:http://www.cnblogs.com/vpoet/p/4659546.html 这里也大致梳理一下: 1.新建一个栈将逆波兰表达式的数字依次压入栈中 2.当遇到运算符时,出栈两个数同时将运算结果压栈 3.重复步骤2直到计算计算,栈中的元素即为逆波兰表达式的计算结果. 实现如下: 1 #include <iostream> 2 #include <stack> 3 using namespace st