PAT 甲级 1150 Travelling Salesman Problem

https://pintia.cn/problem-sets/994805342720868352/problems/1038430013544464384

The "travelling salesman problem" asks the following question: "Given a list of cities and the distances between each pair of cities, what is the shortest possible route that visits each city and returns to the origin city?" It is an NP-hard problem in combinatorial optimization, important in operations research and theoretical computer science. (Quoted from "https://en.wikipedia.org/wiki/Travelling_salesman_problem".)

In this problem, you are supposed to find, from a given list of cycles, the one that is the closest to the solution of a travelling salesman problem.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of cities, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format City1 City2 Dist, where the cities are numbered from 1 to N and the distance Dist is positive and is no more than 100. The next line gives a positive integer K which is the number of paths, followed by K lines of paths, each in the format:

n C?1?? C?2?? ... C?n??

where n is the number of cities in the list, and C?i??‘s are the cities on a path.

Output Specification:

For each path, print in a line Path X: TotalDist (Description) where X is the index (starting from 1) of that path, TotalDist its total distance (if this distance does not exist, output NA instead), and Description is one of the following:

  • TS simple cycle if it is a simple cycle that visits every city;
  • TS cycle if it is a cycle that visits every city, but not a simple cycle;
  • Not a TS cycle if it is NOT a cycle that visits every city.

Finally print in a line Shortest Dist(X) = TotalDist where X is the index of the cycle that is the closest to the solution of a travelling salesman problem, and TotalDist is its total distance. It is guaranteed that such a solution is unique.

Sample Input:

6 10
6 2 1
3 4 1
1 5 1
2 5 1
3 1 8
4 1 6
1 6 1
6 3 1
1 2 1
4 5 1
7
7 5 1 4 3 6 2 5
7 6 1 3 4 5 2 6
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 2 5 4 3 1
7 6 3 2 5 4 1 6

Sample Output:

Path 1: 11 (TS simple cycle)
Path 2: 13 (TS simple cycle)
Path 3: 10 (Not a TS cycle)
Path 4: 8 (TS cycle)
Path 5: 3 (Not a TS cycle)
Path 6: 13 (Not a TS cycle)
Path 7: NA (Not a TS cycle)
Shortest Dist(4) = 8

代码:

#include <bits/stdc++.h>
using namespace std;

#define inf 0x3f3f3f3f
int N, M, K;
int dis[220][220];
int vis[220], go[220];

int main() {
    scanf("%d%d", &N, &M);
    memset(dis, inf, sizeof(dis));
    while(M --) {
        int st, en, cost;
        scanf("%d%d%d", &st, &en, &cost);
        if(cost < dis[st][en]) {
            dis[st][en] = cost;
            dis[en][st] = dis[st][en];
        }
    }

    scanf("%d", &K);
    int temp = 0, ans = INT_MAX;
    for(int k = 1; k <= K; k ++) {
        int T;
        bool can = false;
        int cnt1 = 0, cnt2 = 0;
        memset(vis, 0, sizeof(vis));
        bool flag = true;
        int sum = 0;
        scanf("%d", &T);
        for(int i = 1; i <= T; i ++) {
            scanf("%d", &go[i]);
            vis[go[i]] ++;
            if(i > 1) {
                if(dis[go[i]][go[i - 1]] != inf) {
                    sum += dis[go[i]][go[i - 1]];
                }
                else flag = false;
            }
        }

        printf("Path %d: ", k);
        if(!flag)
            printf("NA (Not a TS cycle)\n");
        else {
            int iscycle = 0;
            for(int i = 1; i <= N; i ++) {
                if(vis[i] == 0)
                    iscycle = 1;
                if(vis[i] == 1) cnt1 ++;
                if(vis[i] > 1) cnt2 ++;
            }

            if(iscycle == 1) printf("%d (Not a TS cycle)\n", sum);
            else if(cnt2 == 1 && vis[go[1]] == 2) {
                can = true;
                printf("%d (TS simple cycle)\n", sum);
            }
            else if(cnt2 >= 1 && vis[go[1]] >= 2) {
                can = true;
                printf("%d (TS cycle)\n", sum);
            }
            else if(cnt2 >= 1 && vis[go[1]] < 2)
                printf("%d (Not a TS cycle)\n", sum);
            else printf("%d (Not a TS cycle)\n", sum);

            if(can && sum < ans) {
                ans = sum;
                temp = k;
            }

        }

    }

    printf("Shortest Dist(%d) = %d\n", temp, ans);
    return 0;
}

  被图论支配的上午 暴躁 Be 主 在线编程

FH 下午去攀岩 然而我一会有牛客的比赛 哭咧咧

原文地址:https://www.cnblogs.com/zlrrrr/p/10333521.html

时间: 2024-08-27 03:44:14

PAT 甲级 1150 Travelling Salesman Problem的相关文章

1150 Travelling Salesman Problem (25 分)

1150 Travelling Salesman Problem (25 分) The "travelling salesman problem" asks the following question: "Given a list of cities and the distances between each pair of cities, what is the shortest possible route that visits each city and retu

1150 Travelling Salesman Problem

实际上挺水... 1 #include <iostream> 2 #include <stdlib.h> 3 #include <string> 4 #include<algorithm> 5 #include<vector> 6 #include<cmath> 7 #include<map> 8 #include<set> 9 #include <unordered_map> 10 using n

构造 - HDU 5402 Travelling Salesman Problem

Travelling Salesman Problem Problem's Link: http://acm.hdu.edu.cn/showproblem.php?pid=5402 Mean: 现有一个n*m的迷宫,每一个格子都有一个非负整数,从迷宫的左上角(1,1)到迷宫的右下角(n,m),并且使得他走过的路径的整数之和最大,问最大和为多少以及他走的路径. analyse: 首先,因为每个格子都是非负整数,而且规定每个格子只能走一次,所以为了使和尽可能大,必定是走的格子数越多越好.这样我们就需

hdu5402 Travelling Salesman Problem(棋盘染色+模拟)

题目: Travelling Salesman Problem Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 906    Accepted Submission(s): 331 Special Judge Problem Description Teacher Mai is in a maze with n rows and m c

HDOJ 5402 Travelling Salesman Problem 模拟

行数或列数为奇数就能够所有走完. 行数和列数都是偶数,能够选择空出一个(x+y)为奇数的点. 假设要空出一个(x+y)为偶数的点,则必须空出其它(x+y)为奇数的点 Travelling Salesman Problem Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 747    Accepted Submission(s): 272

多校9 1007 Travelling Salesman Problem

Travelling Salesman Problem Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 829    Accepted Submission(s): 182Special Judge Problem Description Teacher Mai is in a maze with n rows and m columns

【HDOJ 5402】Travelling Salesman Problem

[HDOJ 5402]Travelling Salesman Problem 一开始以为是搜索 仔细画了画发现就一模拟 奇数行或奇数列的时候怎么走都能全走完 偶数行偶数列的时候就要挑了 . * . * . * * . * . * . . * . * . * * . * . * . 以4*6为例(如上图 星号可以保证不取其中一个可遍历完全图 点好的话就会连带一些星号 所以绕过星号中的最小值 是最佳遍历方式 输入的时候找到最小值并记录下行列 遍历到改行前以 右走到头 下 左走到头 下 右走到头这种方

HDU 5402 Travelling Salesman Problem (模拟 有规律)

Travelling Salesman Problem Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 568    Accepted Submission(s): 200 Special Judge Problem Description Teacher Mai is in a maze with n rows and m colum

HDU 5402 Travelling Salesman Problem (构造)(好题)

大致题意:n*m的非负数矩阵,从(1,1) 只能向四面走,一直走到(n,m)为终点,路径的权就是数的和,输出一条权值最大的路径方案 思路:由于这是非负数,要是有负数就是神题了,要是n,m中有一个是奇数,显然可以遍历,要是有一个偶数,可以画图发现,把图染成二分图后,(1,1)为黑色,总能有一种构造方式可以只绕过任何一个白色的点,然后再遍历其他点,而绕过黑色的点必然还要绕过两个白色点才能遍历全部点,这是画图发现的,所以找一个权值最小的白色点绕过就可以了, 题解给出了证明: 如果n,mn,m都为偶数,