HOJX 1003| Mixing Milk

Problem Description

Since milk packaging is such a low margin business, it is important to keep the price of the raw product (milk) as low as possible. Help Merry Milk Makers get the milk they need in the cheapest possible manner.

The Merry Milk Makers company has several farmers from which they may buy milk, and each one has a (potentially) different price at which they sell to the milk packing plant. Moreover, as a cow can only produce so much milk a day, the farmers only have so much milk to sell per day. Each day, Merry Milk Makers can purchase an integral amount of milk from each farmer, less than or equal to the farmer‘s limit.

Given the Merry Milk Makers‘ daily requirement of milk, along with the cost per gallon and amount of available milk for each farmer, calculate the minimum amount of money that it takes to fulfill the Merry Milk Makers‘ requirements.

Note: The total milk produced per day by the farmers will be sufficient to meet the demands of the Merry Milk Makers.

Input

The first line contains two integers, N and M. The first value, N, (0 <= N <= 2,000,000) is the amount of milk that Merry Milk Makers‘ want per day. The second, M, (0 <= M <= 5,000) is the number of farmers that they may buy from.

The next M lines (Line 2 through M+1) each contain two integers, Pi and Ai. Pi (0 <= Pi <= 1,000) is price in cents that farmer i charges. Ai (0 <= Ai <= 2,000,000) is the amount of milk that farmer i can sell to Merry Milk Makers per day.

Output

A single line with a single integer that is the minimum price that Merry Milk Makers can get their milk at for one day.

Sample Input

100 5

5 20

9 40

3 10

8 80

6 30

Sample Output

630

Time limit : 3 s

Memory limit : 32 mb

Submitted : 9962

Accepted : 4313

题意:这个题的意思是一个人要买数量为N(第一个输入)的牛奶,他从M(第二个输入)家里面挑,后面的输入就是这M家 :每一家牛奶单价 和 牛奶总数量。然后算一下要买到数量N的话,每一家都买多少才能花钱最少,输出花的钱数。

思路:这是一个简单的贪心算法。解题思路就是先挑最便宜的买,看最便宜的这家的量有没有我要的这么多,要是没有的话,再去第二便宜的一家,进行同样的步骤。。。。

代码:

#include<iostream>
#define FARMERS 5000
using namespace std;
int findMin(int *a,int n,bool *flag){
    int min=1001;
    int count;
    for(int i=0;i<n;i++){
        if(flag[i]==true)continue;
        if(a[i]<min){
            min=a[i];
            count=i;
        } 

    }
    flag[count]=true;
    return count;
}
int main(){
    bool flag[FARMERS]={false};
    int all,farmers;
    cin>>all>>farmers;
    int price[FARMERS],amount[FARMERS];
    int buy=0;
    for(int i=0;i<farmers;i++){
        cin>>price[i]>>amount[i];
    }
    while(all>0){
        int min=findMin(price,farmers,flag);
        int this_buy=amount[min];
        if(this_buy>all) this_buy=all;
        all-=this_buy;
        buy+=this_buy*price[min];
    }
    cout<<buy<<endl;
    return 0;
}

注:flag数组的作用是打标记。因为找到最便宜的一家之后,再找第二便宜的一家 正常的思路是找到最便宜的,买完后,删掉它。再再数组里找最小的,重复前面操作。但是考虑到删除数组中的一个元素是很麻烦的,所以采取了打标记的方式,其实就是把它当做已经删除了~

findMin这个函数返回的是当前最便宜的那家的下标。变量all最初是他要买的牛奶总数,随着while循环不断迭代,all记录的就是还需要买的牛奶数量,直到它为0,就代表买完了。

原文地址:https://www.cnblogs.com/qq1337822982/p/10891655.html

时间: 2024-11-05 12:17:46

HOJX 1003| Mixing Milk的相关文章

USACO 1.3 Mixing Milk(贪心)

USACO Mixing Milk 简单的贪心,读入数据,按单价从小到大排序,然后从最便宜的买起,直到买够为止. /* ID:twd30651 PROG:milk LANG:C++ */ #include<iostream> #include<fstream> #include<stdlib.h> using namespace std; int N; int M; typedef struct node { int P; int A; }node; node data

USACO 1.3 Mixing Milk

Mixing Milk The Merry Milk Makers company buys milk from farmers, packages it into attractive 1- and 2-Unit bottles, and then sells that milk to grocery stores so we can each start our day with delicious cereal and milk. Since milk packaging is such

Luogu P1208 [USACO1.3]混合牛奶 Mixing Milk(贪心)

P1208 [USACO1.3]混合牛奶 Mixing Milk 题目描述 由于乳制品产业利润很低,所以降低原材料(牛奶)价格就变得十分重要.帮助Marry乳业找到最优的牛奶采购方案. Marry乳业从一些奶农手中采购牛奶,并且每一位奶农为乳制品加工企业提供的价格是不同的.此外,就像每头奶牛每天只能挤出固定数量的奶,每位奶农每天能提供的牛奶数量是一定的.每天Marry乳业可以从奶农手中采购到小于或者等于奶农最大产量的整数数量的牛奶. 给出Marry乳业每天对牛奶的需求量,还有每位奶农提供的牛奶单

洛谷 P1208 [USACO1.3]混合牛奶 Mixing Milk

题目描述 由于乳制品产业利润很低,所以降低原材料(牛奶)价格就变得十分重要.帮助Marry乳业找到最优的牛奶采购方案. Marry乳业从一些奶农手中采购牛奶,并且每一位奶农为乳制品加工企业提供的价格是不同的.此外,就像每头奶牛每天只能挤出固定数量的奶,每位奶农每天能提供的牛奶数量是一定的.每天Marry乳业可以从奶农手中采购到小于或者等于奶农最大产量的整数数量的牛奶. 给出Marry乳业每天对牛奶的需求量,还有每位奶农提供的牛奶单价和产量.计算采购足够数量的牛奶所需的最小花费. 注:每天所有奶农

Mixing Milk

链接 分析:水题,按照价格从小到大排序,在进行贪心即可 /* PROB:milk ID:wanghan LANG:C++ */ #include "iostream" #include "cstdio" #include "cstring" #include "string" #include "algorithm" using namespace std; const int maxn= 5000+10;

1.3.1 Mixing Milk

The Merry Milk Makers company buys milk from farmers, packages it into attractive 1- and 2-Unit bottles, and then sells that milk to grocery stores so we can each start our day with delicious cereal and milk. Since milk packaging is such a difficult

usaco Mixing Milk

发现我真的是很喜欢使用优先度咧 一个牛奶包装商人,从不同的奶农手里收购牛奶,以最低的价格买够每日所需,问最少花多少钱.直接贪心, /* ID: modengd1 PROG: milk LANG: C++ */ #include <iostream> #include <stdio.h> #include <queue> struct node { int P; int A; node(int p,int a) { A=a; P=p; } node(){} bool fr

USACO Section1.3 Mixing Milk 解题报告

milk解题报告 —— icedream61 博客园(转载请注明出处)------------------------------------------------------------------------------------------------------------------------------------------------[题目] 我是牛奶制造商,我一天需要N加仑的牛奶,总共有M个农民可以供给我. 这M个农民的信息共M行,第i个农民有num[i]加仑牛奶,每加仑

【贪心】Mixing Milk

题目描述 The Merry Milk Makers company buys milk from farmers, packages it into attractive 1- and 2-Unit bottles, and then sells that milk to grocery stores so we can each start our day with delicious cereal and milk.Since milk packaging is such a diffic