hdu1247 Hat’s Words 字典树

Problem Description

A hat’s word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.

You are to find all the hat’s words in a dictionary.

Input

Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 50,000 words.

Only one case.

Output

Your output should contain all the hat’s words, one per line, in alphabetical order.

Sample Input

a
ahat
hat
hatword
hziee
word

Sample Output

ahat
hatword


题意:输入一连串的 单词 组成的字典
输出字典中由两个其他单词组成的单词

构造字典树即可。。。

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
struct node{
    int last;                  //last用来判断是否为一个单词的最后一个字母
    struct node *next[26];
    node()                 //构造函数
    {
        last=0;
        memset(next,NULL,sizeof(next));
    }
}*root;
char str[50005][20];
int s=0;
void insert_str(char *s)        //构造字典树
{
    node *p=root;
    while(*s!='\0')
    {
        int d=*s-'a';
        if(p->next[d]==NULL)
        {
            p->next[d]= new node();
            p=p->next[d];
        }
        else
            p=p->next[d];
        s++;
    }
    p->last=1;
    return ;
}
int find2(char *s)
{
    node *p=root;
    while(*s!='\0')
    {
        int d=*s-'a';
        p=p->next[d];
        if(p!=NULL)
        {
            if(p->last==1&&*(s+1)=='\0')     //当后半部分为单词 且没有后缀
                return 1;
            s++;
        }
        else
            return 0;
    }
    return 0;               //重要  返回可能默认为1
}
int find(char *s)
{
    node *p=root;
    while(*s!='\0')
    {
        int d=*s-'a';
        p=p->next[d];
        if(p!=NULL)
        {
            if(p->last==1&&find2(s+1))    //当已经确认前半部分为一个单词 再确认后半部分是否为单词
                return 1;
            s++;
        }
        else
            return 0;
    }
    return 0;
}
int main()
{
    int i,j;
    root=new node();                 //  根节点
    while(scanf("%s",str[s])!=EOF)
    {
        insert_str(str[s]);
        s++;
    }
    for(i=0;i<s;i++)
    {
        if(find(str[i]))
            cout<<str[i]<<endl;
    }
    return 0;
}
时间: 2025-01-01 23:33:43

hdu1247 Hat’s Words 字典树的相关文章

hdu 1247 Hat’s Words 字典树

// hdu 1247 Hat's Words 字典树 // // 题目大意: // // 在一些字符串中,找到这样字符串:由两个其他的字符串构成 // // 解题思路: // // 字典树,先将这些字符串插入到字典树中,然后枚举断点,如果 // 字符串的前后两段都找到了,输出该串即可~ // // 感悟: // // 这道题目的话,就是字典树上的暴力嘛,细节方面还是要多多注意 // val值还是不能少哟~因为查找到了该串,不一定是一个单词,可能 // 是中间的一个节点,即某个字符串的前缀~~~

Hat’s Words(字典树)

Problem Description A hat's word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary. You are to find all the hat's words in a dictionary. Input Standard input consists of a number of lowercase words, on

hdu 1247 Hat’s Words 字典树,还是比较有意思的题目

Hat's Words Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 8843    Accepted Submission(s): 3171 Problem Description A hat's word is a word in the dictionary that is the concatenation of exactl

HDU 1247 Hat’s Words (字典树&#183;Trie)

题意  给你一个字典  输出字典中能表示成两个单词连接的所有单词 最基础的字典树应用  先把所有单词加入字典树中  标记每个结点是否为某个单词的结尾  然后查找每个单词  在树上查询过程中遇到单词结尾时  如果剩下的后缀也是一个单词  那当前查询的单词就可以是两个单词的连接了 #include <cstdio> #include <cstring> using namespace std; const int N = 50005; int n; char ss[N][20]; st

hdu 1247 Hat’s Words (字典树模板)

//那个单词是有出现的两个单词构成的 # include <cstdio> # include <cstring> # include <algorithm> # include <iostream> # define MAX 26 using namespace std; typedef struct Trie_Node { bool isWord; struct Trie_Node *next[MAX]; } Trie; char s[50000][50

hdoj 1247 Hat’s Words(字典树)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1247 思路分析:题目要求找出在输入字符串中的满足要求(该字符串由输入的字符串中的两个字符串拼接而成)的字符串. 对于长度为LEN的字符串,其可能由LEN种可能的拼接可能:现在问题转化为查找能够拼接成该字符串的可能的两个字符串是否都在 输入的字符串中,使用字典树可以实现快速的字符串查找,算法复杂度为O(N*M),N为输入字符串的个数,M为字符串长度. 代码如下: #include <cstdio>

HDU1247 Hat’s Words【字典树】

题目链接: http://acm.hdu.edu.cn/showproblem.php?pid=1247 题目大意: 一个"hat's word"是一个单词,可以恰好由字典中其他两个单词连接得到(比如字典中是hat's和word). 给出字典中的单词,输出所有的hat's word. 思路: 建立字典树,将每个单词都插入到Trie树中,Count统计单词(不是前缀)出现次数.按顺序将每个单词 所有可能的长度拆分成前缀单词和后缀单词,判断这两部分是否都在字典树中,是就是hat's wor

HDU 1247 Hat&#39;s Words (字典树)

[题目链接]click here~~ [题目大意]A hat's word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary. ,找出由两个子字符串组成的字符串. [解题思路]字典树 #include <bits/stdc++.h> using namespace std; const int N=5*1e4+100; const int MOD=

HDU 1247 Hat’s Words (字典树 &amp;amp;&amp;amp; map)

分析:一開始是用递归做的,没做出来.于是就换了如今的数组.即,把每个输入的字符串都存入二维数组中,然后创建字典树.输入和创建完成后,開始查找. 事实上一開始就读错题目了,题目要求字符串是由其它两个输入的字符串组成的前后缀,自己根本没有推断前缀是否满足.就直接推断后缀,一直想不通自己哪里错了,非常羞愧,水平还是不行. 查找分为前缀查找和后缀查找.事实上两个函数基本差点儿相同的.以下放代码. #include <cstdio> #include <cstring> #include &