poj 1035 Spell checker(暴力判断)

题目链接:http://poj.org/problem?id=1035

Description

You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms.

If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations:

?deleting of one letter from the word;

?replacing of one letter in the word with an arbitrary letter;

?inserting of one arbitrary letter into the word.

Your task is to write the program that will find all possible replacements from the dictionary for every given word.

Input

The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character ‘#‘ on a separate line. All words are different. There will be at most 10000 words in the dictionary.

The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character ‘#‘ on a separate line. There will be at most 50 words that are to be checked.

All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most.

Output

Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct". If the word is not correct then
write this word first, then write the character ‘:‘ (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the
input file). If there are no replacements for this word then the line feed should immediately follow the colon.

Sample Input

i
is
has
have
be
my
more
contest
me
too
if
award
#
me
aware
m
contest
hav
oo
or
i
fi
mre
#

Sample Output

me is correct
aware: award
m: i my me
contest is correct
hav: has have
oo: too
or:
i is correct
fi: i
mre: more me

Source

Northeastern Europe 1998

题意:

输入一些单词作为字典,再输入一些单词查找:

1、  若某个单词能在字典中找到,则输出correct。

2、  若某个单词能通过 变换 或 删除 或 添加一个字符后,在字典中找得到,则输出这些单词,输出顺序根据  输入的字典的字典序。

3、  若某个单词无论操作与否都无法在字典中找得到,则输出空。

代码如下:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
typedef struct letter
{
    int len;
    char s[17];
} let;
let str[10017];

void Repl(char *s, char *ss)
{
    int len = strlen(s);
    int flag = 0;
    int i = 0, j = 0;
    while(i < len)
    {
        if(flag >= 2)
            break;
        if(s[i] == ss[j])
        {
            i++,j++;
        }
        else
        {
            i++,j++;
            flag++;
        }
    }
    if(flag < 2)
        printf(" %s",s);
}
void Inse(char *s, char *ss)
{
    int len = strlen(ss);
    int flag = 0;
    int i = 0, j = 0;
    while(j < len)
    {
        if(flag >= 2)
            break;
        if(s[i] == ss[j])
        {
            i++,j++;
        }
        else
        {
            j++;
            flag++;
        }
    }
    if(flag < 2)
        printf(" %s",s);
}
void Dele(char *s, char *ss)
{
    int len = strlen(s);
    int flag = 0;
    int i = 0, j = 0;
    while(i < len)
    {
        if(flag >= 2)
            break;
        if(s[i] == ss[j])
        {
            i++,j++;
        }
        else
        {
            i++;
            flag++;
        }
    }
    if(flag < 2)
        printf(" %s",s);
}
int main()
{
    char ss[17];
    int k = 0;
    while(~scanf("%s",str[k].s))
    {
        str[k].len = strlen(str[k].s);
        if(str[k].s[0]=='#')
            break;
        k++;
    }
    while(~scanf("%s",ss))
    {
        if(ss[0] == '#')
            break;
        int len = strlen(ss);
        int flag = 0;
        for(int i = 0; i < k; i++)
        {
            if(!strcmp(ss,str[i].s))
            {
                printf("%s is correct\n",ss);
                flag = 1;
                break;
            }
        }
        if(flag)
            continue;
        printf("%s:",ss);
        for(int i = 0; i < k; i++)
        {
            if(len == str[i].len)
                Repl(str[i].s,ss);
            else if(len == str[i].len+1)
                Inse(str[i].s,ss);
            else if(len == str[i].len-1)
                Dele(str[i].s,ss);
        }
        printf("\n");
    }
    return 0;
}
时间: 2024-08-02 07:58:28

poj 1035 Spell checker(暴力判断)的相关文章

[ACM] POJ 1035 Spell checker (单词查找,删除替换增加任何一个字母)

Spell checker Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 18693   Accepted: 6844 Description You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given word

POJ 1035 Spell checker (串)

题目大意: 问你后面输入的串能不能通过  加减一个字符,或者替换一个字符变成字典中的串. 思路分析: 直接模拟替换加减的过程. 比较两个串的长度.要相差为1 的时候才能进行模拟. 模拟的过程就是进行一个个的匹配. 发现失配的次数小于等于 1就可以输出. #include <cstdio> #include <iostream> #include <cstring> #include <algorithm> #include <string> #i

[ACM] POJ 1035 Spell checker (单词查找,删除替换添加不论什么一个字母)

Spell checker Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 18693   Accepted: 6844 Description You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given word

POJ 1035 Spell checker

题目链接 http://poj.org/problem?id=1035 Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 24142   Accepted: 8794 Description You, as a member of a development team for a new spell checking program, are to write a module that will check the cor

POJ 1035 Spell checker (模拟)

题目链接 Description You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms. If the word is absent in

【POJ】1035 Spell checker

字典树. 1 #include <iostream> 2 #include <cstdio> 3 #include <cstring> 4 #include <cstdlib> 5 #include <vector> 6 #include <string> 7 using namespace std; 8 9 typedef struct Trie { 10 int in; 11 Trie *next[26]; 12 } Trie;

POJ 1035 Spell Check 字符串处理

被这样的题目忽悠了,一开始以为使用Trie会大大加速程序的,没想到,一不小心居然使用Trie会超时. 最后反复试验,加点优化,终于使用Trie是可以过的,不过时间大概难高于1500ms,一不小心就会超时. 看来这是一道专门卡Trie的题目,只好放弃不使用Trie了. 也得出点经验,如果字符串很多,如本题有1万个字符串的,那么还是不要使用Trie吧,否则遍历一次这样的Trie是十分耗时的,2s以上. 于是使用暴力搜索法了,这里的技巧是可以使用优化技术: 1 剪枝:这里直接分组搜索,分组是按照字符串

Spell checker(暴力)

Spell checker Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 20188   Accepted: 7404 Description You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given word

Spell checker POJ 1035 字符串

Spell checker Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 25426   Accepted: 9300 Description You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given word